Question about 2010 Ford Escape XLT

1 Answer

How do i fix the problem i have power but no sound sterio comes on but there is no sound

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Passionate:

    Visited the website for 10 consecutive days.

    Habit-Forming:

    Visited the website for 3 consecutive days.

  • Contributor
  • 17 Answers

Depends if there is a internal amplifier int this vehicle some model cars have just a radio some have a radio with built in amp usually in the dash or located in the trunk check your model to see.could be something as easy as a bad fuse or a bad wire to the amp if no amp then your radio is junk you could either replace it with another factory radio or install an aftermarket radio that will not only be cheaper but also perform better as most factory radios are poorly made .hope this helps good luck

Posted on Nov 22, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My radio comes on but no sound. What should I do? Is their a code to be entered?


yes on the back of the radio you may have to call and give company the number to set your sterio up

Mar 09, 2015 | 2005 Kia Amanti

1 Answer

Radio turns on when I turn on the headlights


check where the sterio is getting its power from, sounds like it got wired to the headlight fuse.

Jan 16, 2014 | Ford Cars & Trucks

1 Answer

Alpine stereo


you didnt use proper wire harness when you set up sterio you spliced into the functions of the vehicle take your sterio out fix your splices and buy the proper wire harness for your radio

Nov 09, 2013 | Lincoln Cars & Trucks

2 Answers

Radio display not working


bulbs blown, no easy way to fix, best to put in an aftermarket sterio

Nov 03, 2013 | Mitsubishi Galant Cars & Trucks

1 Answer

What is the color wire the turn of the sterio went u turn off the car ingnicion


Sound like you are looking for a "hot" wire (which are usually red) when the ignition is off, so you can still run your stereo. If this is the case, you should look at the wiring diagram for your vehicle to find a always hot wire. These come from the fuse box under the dash. Problem with doing this is that you can run your battery down when the car is off and leaving the radio on for too long. Most radio's have a red power wire coming from the dash, specifically for the radio, which has power when the key is turned to the "Accessory" position. Connecting to this will solve your problem.

Apr 29, 2012 | 2005 Pontiac Grand Am

1 Answer

No power to my stereo,it does work so could it be the battery connection


u need to test if u have power upto the sterio if so is the sterio earth properly

Jun 04, 2009 | 2001 Kia Sportage

2 Answers

Ive messed with the sterio in my 1986 f250 the


good luck on this ...have fun! that's what old trucks with crazy radios are for!!

May 10, 2009 | 1986 Ford F 250

1 Answer

Sterio wireing


you will need to get a cord that connects to the sterio and then you need to match them up with these wires
the colors for the radio that are hooked up to the car are
  • orange is power
  • red is egnition
  • blue is power antena
  • black is ground
other ones will most likely be the sterio wires you just need to find colors that look a like and they will most likely match

hope this helps

Apr 07, 2009 | 2000 Ford Focus

2 Answers

Sterio and Power Locks won't work on my 1990 F150


I have a kind the same problem I really don't know is i can help but if the sterio if not factory may been installed wrong. i check the wiring most kid try to put the in and instead of spending the 20 buck to do it right they cut wires . if this happen it may be a pain but you can look and see if any wire been cut to power the clock or something

Mar 13, 2009 | 1990 Ford F150

Not finding what you are looking for?
2010 Ford Escape XLT Logo

139 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5467 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...