Question about Ford Explorer

1 Answer

I have a 1998 ford explorer It idles ok but stalls when you rev it up or put it in drive or reverse and try to go. I have replaced the fuel filter and plugs and installed injector cleaner and dry gas. Scanned and no codes found?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 78 Answers

Sounds like a lean fuel condition. If fuel pressure is good, I would suspect a dirty or faulty mass airflow sensor. Try disconnecting the sensor in the air intake tube near the air filter. If the problem goes away, replace the sensor.

Posted on Nov 16, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 2 Answers

SOURCE: My 1993 Nissan Sentra GXE

Have you checked your MAF? Sentra's are famous for them having problems, I havent had an issue with mine yet thank god.

Posted on Oct 03, 2008

  • 5 Answers

SOURCE: surging while driving

This is a notorious problem with the Windstars. There are oodles of ground straps in them. Make sure they are all clean and tight. ESPECIALLY THE STARTER GROUND STRAP. If it's loose, the car may just die when you turn up into a driveway or parking lot or just go over a bump. If you notice the "Check Engine" light comes on momentarily, at the time of the surge or the engine kills completely, it's DEFINITELY the starter ground strap! My engine used to kill at odd times -- even when on the freeway going at 75!-- Then we'd go over another bump and SURGE_O_RAMA, the engine's running again or I'd restart it and it would be fine for a while. What's happening is the loose ground strap loses it's connection when you go over a bump in the road. The next bump jogs it back into the connected mode, albeit tenuous at best. All of the computer techs couldn't find the problem. It took a 70-year old seat-of-the-pants mechanic to make the SIMPLE fix. It took so long to find the common-sense mechanic, however, that the down-shot of all of the surging tanked my tranny, which I had to have rebuilt! AND then, after I drove away from the 5-star AAA BBB "transmissing" shop, I found that THEY HAD NOT TIGHTENED ALL OF THE GROUND STRAPS! I took it back. They had no knowledge of ALL 9(?) ground straps and had to take it to THEIR mechanic who tightened them ALL down! It's been 5 years since then and I haven't had another problem with it. RULE OF THUMB: EVERY TIME YOU HAVE THE VAN SERVICED have them tighten-down ALL of the ground straps! If your mechanic doesn't know what you are talking about, go find a new mechanic. Generally, the AAA "Top Shops" are your best bet. They fix things right the FIRST time. I still haven't found a manual that has all of the ground straps listed, by the way.

Posted on Oct 09, 2008

  • 94 Answers

SOURCE: Engine stalls when stepping on gas pedal and will not idle on its own.

Have you checked the ignition timing? Maybe you need to turn the distributor to the left or right if you don't have the timing light gun

Posted on Nov 11, 2008

  • 1118 Answers

SOURCE: cannot get 1987 chevy van 20 to keep running... stalls out

Best do a fuel pressure test. Should have chg. fuel filter from the get go. The only other filter is on the end of the fuel pump in tank. Bad gas and dirty gas will plug up fuel filter, hense burn pump up.

Posted on Apr 11, 2009

  • 66 Answers

SOURCE: 1995 Chevy K1500 4.3L V6. Engine has inconsistant idle

Have you changed the fuel pump yet?I had the same exact problem.I replaced my fuel pump with an AUTOZONE PIECE OF JUNK fuel pump.That pump lasted almost 2 days.The second day i had it the truck didnt want to start but it did and it ran like ****,and when i put it in gear it ran as long as I didnt touch that gas pedal.You could go get a fuel pressure test or just replace it,your call.You might want to check your filter too but im sure its the pump.Good luck

Posted on Apr 27, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Just replaced heater core, now car dies when put in gear


check for pinch wires around core install. also a vacume leak from same job not plugged

Dec 03, 2013 | 1998 Mercury Grand Marquis

2 Answers

Troubleshooting a 1998 honda accord


If it is has an automatic trans, and it stalls when you put it in reverse or drive, it could be the idle air control valve.
You would be able to speed up the engine with the gas pedal to keep the engine from stalling if this is the case.
The computer should bump up the idle speed when the engine is under load by controlling the air going into the intake.
If the engine stalls suddenly it could be the torque converter clutch.

Dec 22, 2012 | 1998 Honda Accord

1 Answer

My explorer idles fine in park but skips and misses when under load


K the next thing to check is the throttle position sensor. It's probably going bad. The same thing happened to me on my 1995 F250 5.8L

Sep 16, 2012 | 1998 Ford Explorer

1 Answer

My 1998 Ford explorer stalls out when I'm on a


I would suggest you have the fuel pressure monitored while driving, this takes special equipment. Also have a functional test run on the engines automatic idle speed control system, you could have a defective idle speed control valve.

Feb 07, 2012 | 1998 Ford Explorer

1 Answer

Idles ok with a miss but in gear it stalls and loses power. cant get rpms very high


Check all of your spark plugs and wires... If they are all getting a good, clear blue spark, then try changing your fuel filter. Hope this helps, James Booth

May 17, 2011 | 1998 Ford Explorer

1 Answer

Vehicle stalls when put into gear forward or reverse


first try so SPT gas teatment may sure you have a half tank of gas and then put in a little more of gas if this help change the fuel filter also check the vaccum lines and make sure they are all on and in and good conditon and also checkout the intake manifold for leaks

Apr 13, 2009 | 1998 Ford Explorer

1 Answer

Escort 1998 1.8 zetec mis firing


try using a gauge to measure fuel delivery pressure but this tool may only be available to the dealer or a big garage,best advice in a case like this is put car in dealers as you cant read the the ECU readings as the OBD II connector cable doesnt have manufacturers pin connections.Have a funny feeling this problem is a concoction of different faults,but try checking gauze filter on bottom of pump in the fuel tank or for porosity on the flexible connections that connect the plastic fuel lines to the unit on the tank .

Oct 04, 2008 | 1998 Ford Escort

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5516 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...