Question about 1996 Dodge Grand Caravan

1 Answer

Two new fuel pumps in my 1996 grandcaravan. Still no fuel presure at rail. New fuel filter also. The regulator is built into the pump and the van runs on either.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Dodge Master
  • 1,243 Answers

Are you getting at least 12 volts to the harness on the pump and also is it grounded good? Have you checked the fuse for the fuel pump and the fuel pump relay? Is the ASD relay coming on when you turn the switch to run position? Several more things to check to solve your no start condition.

Posted on Nov 07, 2014

  • 5 more comments 
  • maxmhill Nov 08, 2014

    Ive cheked the relay and fuse i hear the realay clicking ill try swaping it with the horn. And ill test for 12 volts at pump i guess it could be geting low voltage and not puting out full presure. I think runing on either should have tested the computer but if theres no fuel at the rail i know it wont run. I will test the injectors just to iliminate them any input is helpful thanks

  • Adam Scott Roberts Nov 08, 2014

    If it runs on ether then that does mean the computer side is working as far as the ignition system anyway. The pump still must not be getting power or ground for there to be no pressure at the fuel rail.

  • maxmhill Nov 08, 2014

    It turns on with the key i hear it. But again thanks for the input. Im geting frustrated as this is my only transportation atm. Third day of working on it but thank you for help

  • maxmhill Nov 08, 2014

    It turns on with the key i hear it. But again thanks for the input. Im geting frustrated as this is my only transportation atm. Third day of working on it but thank you for help
    i guess if i understand u your saying its not pumping when its cranking or trying to run im lossing power that way to pump???

  • maxmhill Nov 08, 2014

    I direct wired the pump hott it runs but nothing coming out of the outlet side of the new filter

  • Adam Scott Roberts Nov 09, 2014

    The wires may be crossed in the harness making the pump run backwards. Just a suggestion.

  • maxmhill Nov 10, 2014

    Thanks

×

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 44 Answers

SOURCE: 1996 astro van stopped running

Sounds like dirty gas and the fuel filter is clogged...try changing the fuel filter...some are under the car, but most are mounted against the firewall in the engine compartment.

Posted on Apr 19, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Just put a new delphi fuel pump in my1996 grand caraban did this twice. Still im geting no pressure at the shrader vaulve. Van runs on either. The pump and regulator are the same assembly is the pump the...


Not likely. It is also not likely that the regulator is in the fuel pump assembly. Some people mistake the check valve in the pump as a regulator. Also, some vehicles have a pump module which includes the fuel gauge sensor and that can be mistaken as the regulator by some DIYers. The caravan uses a return-loop fuel system. This means that the pump is cycling fuel from the tank to the fuel rail on one line and the fuel that is not needed at the injectors flows back through another line to the fuel tank. This is done to prevent the pump from building up too much pressure and allows the fuel flowing through the pump to keep it cool. Because of the looping system, there needs to be a flow restrictor (aka regulator) at the fuel rail to provide a constant pressure source for the injectors. The regulator is normally at the end of the rail and will have a vacuum line attached. Pull the vacuum line, place a rag at the vacuum port, and crank the engine. There should be no fuel coming out the port. If any fuel comes out of the vacuum port, the regulator is faulty. The regulator could still be faulty even if there is no fuel from the port, but fuel leakage is an easy way to be sure. If the regulator is not providing proper restriction to maintain pressure, then the fuel simply flows in a circular loop from and back to the fuel tank without enough pressure to allow the injector to do their thing,

Nov 07, 2014 | 1996 Dodge Grand Caravan

1 Answer

No fuel pressure on gauge is it the presure regulator bad


First check or just replace the fuel filter. Usually located under the car in front of the rear axle, drivers side.
Next, the fuel pump may be worn out. Usually they get loud or stop working (running).
Next, check the fuel pressure regulator. Usually located on the front fuel rail, drivers side.
Is the vacuum line attached? Not leaking or rotted?
Also, do you smell a strong fuel odor when it won't start? May be one or more stuck-open injectors, or the coil pack(s) is/are bad.
Checking these in the order listed will more than likely fix your problem. Try a new fuel filter first. From there have someone check the fuel pressure regulator and then the pump. If you are in need of a new pump, take my word for it and spend the money to get one from a Dealer, and not from your favorite parts store. Most parts store parts are made in China and they are JUNK. At least get a OE pump.

Mar 17, 2013 | 2000 Mercury Villager

1 Answer

96 voyager fuel pump runs but wont pump


have you checked the fuel pressure regulator on the fuel rail

Jan 27, 2013 | 1996 Plymouth Voyager

1 Answer

Hi i have a 1996 chevy astro van wont start


chk in line fuel filter for obstruction, also could be a lot of sediment in the tank clogging up the filter. Hope this helps you resolve your problem.

Oct 22, 2012 | 1993 Chevrolet Astro

1 Answer

Low fuel rail pressure


It could be a poor performing pump, a pump filter sock that is partially clogged, or a bad pressure regulator. Have the fuel system pressure checked to see if it's the pump or the pressure regulator.

Mar 03, 2012 | 2002 Chevrolet Silverado 2500HD

1 Answer

1996 Chev Blazer 4.3 vortrex. Will not start without priming the throtel body after the truck sits for a while and especially when its cold. Fuel pump was replaced in 2010. I can hear the pump...


I would be considering testing/replacing engine coolant temperature sensor. A faulty sensor can send signal that engine is already warm when it is still cold, thus, less fuel delivery than needed at time of engine being cold.

Dec 29, 2011 | 1996 Chevrolet Blazer

2 Answers

My 4.0 litre is not getting fuel @ the injecter rail.i've ruled out the fuel pump relay.where else should i look and how do i test them?


Try the pressure regulator, if not, going to have to check for power at the pump (at which time I would just go ahead and change it due to the work involved).

Hope this helps.

Feb 23, 2011 | 1996 Jeep Grand Cherokee

1 Answer

My friend owns a 96 oasis as well, van only has a pressure of 18 psi, there has been a recent fuel pump change along with filter and screen. What else is left to check? Van was able to start after the...


Forget the injectors. They worked before the new pump,why go there.
The new pump maybe defective,it happens, I suppose.
Your only problem, may have just been the fuel pressure regulator ,and not the pump at all.
I hope you mean, you changed the replaceable fuel filter, not just the sock on the fuel pump in the tank. If the filter is really dirty, it would stop the flow of fuel, and give you less than 40 to 70# psi,but 18#.

Sep 18, 2010 | 1996 Isuzu Oasis

1 Answer

My 2004 astro van staled affter ideling for 15 min. and will not start


tis the seson for fuel pumps, this is where i would start checking to see if there is a problem, try to turn the key on and off letting the pump build up presure and see if this lets you idle the van for a while again
if so you may have a problem with your fuel system, pump, presure regulator, filter, ect.

Mar 01, 2010 | 1999 Chevrolet Astro

Not finding what you are looking for?
1996 Dodge Grand Caravan Logo

101 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...