Question about 2003 Suzuki Aerio

1 Answer

I just had the left fan changed in feb. it is not workin the left fan can the fan have gone bad already.. It was changed by a dealer, I have a 2005 susuki forenza

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Suzuki Master
  • 6,826 Answers

Yes it could but check for fan relay to see if it is working

Posted on Jul 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

My tranmission will not shif into any gear 2005 mitch glant


Check pump pressure. Line tap 1/8 pipe plug on left side of bellhousing. No pressure means front pump exploded. If you have line pressure of at least 100 psi then check linkages to valve body.

Jun 02, 2014 | 2002 Chevrolet Avalanche

1 Answer

Where resistor for blower fan(2005 kia sportage)


if fuse/power to fan/resistor all check out, drop the motor and look for
a mess of leaves inside...in my case, there were so many they kept
the motor from operating/OR taking it all apart/testing and finding nothing
wrong but leaves and removing them somehow corrected a bad ground...who knows or cares?...it's now working

Aug 06, 2012 | 2005 Kia Sportage

1 Answer

Noticed temp gauge running a little higher than normal.cooling fans turn on and off very quickly. turned on ac and the fans run. trying to diagnose without getting taken to the cleaners from the...


Check your coolant levels. If the temperature isn't much higher than normal, you may be fine, or you may have a Coolant Temperature Sensor going bad, and reporting the incorrect temperature. Even though the thermostat was replaced 8 months ago, it is possible it is already going bad again. I believe this is more of a Coolant Temp. Sensor fault though. The cooling fans are On when the AC is on. With the AC off, the cooling fans come on when the engine reaches a certain temperature, and cut off once the temperature is back in range. The Coolant Temperature sensor shouldn't cost much, and is easy to replace. I would start with that, top it off with coolant, and then maybe change the thermostat.

Mar 14, 2011 | Chevrolet Impala Cars & Trucks

1 Answer

The rear fog lights are not workin on my peugoet 406


In my opinion you have already checked and cured the most common problem zones. In my opinion take it to a car electrician and let him find out the problem. May be the wiring is faulty.

Sep 01, 2009 | 2005 Peugeot 405

1 Answer

The A/T temp controller in the middle of the dash is where you change temperature fan speed etc. Looks like on the right hand side the back light is dimmer than the left side. I think one of the bulbs is...


It can be done, but it's better to take it to a electronic shop to do the repair rather then your self. I had the LED screen on the radio go bad and did not now what station or time it was, the screen was dead and the dealer said the same thing. I found a electronic repair shop, they repair mine and in two days and cost me $45.00 with  a radio good as new. Good luck and hope this helps.

Jun 22, 2009 | 2005 GMC Sierra

1 Answer

Where can I find information on changing out the propeller shaft in my 2005 Acura RL? The center support bearing is whining and has gone bad. I inderstand from the dealer the whole assembly must be...


there is no major trick other than removing front and rear flange bolts and center support bracket bolt and $2200 is very high dealer in delaware it sells for $1450 for part

May 06, 2009 | 2005 Acura RL

1 Answer

Dealer says transmission is gone


It sounds like it just failed for whatever reason. It's 50/50 whether there was anything done that could have caused the problem (filter installed incorrectly or wrong part?) The key now is to look for the solution. Make sure that the cooler is working when the transmission gets fixed or replaced so that isn't a problem. Get a good warranty, and I would say it's up to you, but I would think about having the trans fixed somewhere other than where the service was done that might have caused it. They aren't going to tell you if they find out that they screwed up, and letting them 'take a look' is an opportunity to hide anything they did. Have whoever takes it apart look for possible causes and document it.

Apr 16, 2009 | 2005 GMC Envoy

1 Answer

2005 KIA AMANTI WON'T START WHEN TEMP DROPS BELOW 40 DEGREES.


if you went to Kia dealer last Feb and they did not solve problem and it is still a problem in Dec, then you are the problem. Make the dealer fix the darn thing!

Dec 19, 2008 | 2005 Kia Amanti

Not finding what you are looking for?
2003 Suzuki Aerio Logo

Related Topics:

124 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...