Question about 1993 Chevrolet S-10 Blazer

1 Answer

When I start my chev S10, it starts but after a minute, the engine shuts off. I put in a new alternator and the problem still persists. Do you recommend a new fuel pump?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 512 Answers

This truck is fuel injected. I would say by what you are stating that the fuel filter is clogged or you have a bad fuel pressure regulator, or a vacuum leak. If you hear pump going on it is probably not pump but one of things I mentioned. Good luck.

Posted on Jul 03, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1985 CHEV S10 PICKUP CHANGED BATTERY WONT FIRE


may hav a fuse thats bad-chec inside and engine area--also bad harness wire--inspect distributer cap for inside corrosion-clean or replace----test for fuel pressre etc. new batt must have 12.6volts and no less--testit and also alternator

Sep 08, 2014 | Cars & Trucks

1 Answer

Blowing transmission fuse on a 1996 chev 1500


Pinched wire between engine and trans due to mechanic fault during installation.

Dec 27, 2013 | 1996 Chevrolet K1500

1 Answer

1996 chevy s10 pickup brand new motor new everything but wont start thought it was a timing problem..fixed it wondering what it could be? Maybe something with the distributor but not sure where to find a...


Battery light indicates alternator failure. If you have a voltmeter, check voltage at battery with engine running. Should be at least 14 volts. If no voltmeter, remove alternator and take it to parts store for testing.
If the alternator is bad and that is your only problem, the truck should jump start, but it will not go far unless the battery is charged. OK?

Oct 01, 2010 | 1996 Chevrolet S-10 Pickup

2 Answers

1989 Bronco: 89 ford bronco i put a new starter new battery new...


Check the battery cables for corrosion near the battery terminal end. Sometimes it builds up under the rubber insulation. I would check the ground wire that runs from the battery to the engine block.

May 16, 2010 | 1989 Ford Bronco

2 Answers

Chev. S10 starts but stop's immediate when hot


check compression, at that many miles the exhaust seats could be wearing up into head causing valves to stay open longer loosing compression,while the engine is cold oil is thicker ,lifters pump up further do to thick oil when oil thins out you have less lifter pump up thus working working properly check compression cold should be 125 low to 155 any less than 100 you have valve prob.

Jan 25, 2009 | 1988 Chevrolet S-10

1 Answer

My volvo wont start either


If you have started your engine and then shut it off within a minute, then the valves will be held open and you will habe no compression. The only way around this is to not do short journeys/start-ups. To fix it if it does happen, charge your battery, the put the accelerator to the floor and crank the engine to free the valves. It will take minutes of cranking but persist and you will get it to go. By flooring the accelerator, you shut fuel off to the engine too.

Sep 13, 2008 | 2002 Volvo S60

1 Answer

1994 chev. S10 4.3


There is a sensor device, on the right side of the engine block near the front, for the oil pressure that has two parts to it. It is used to control the oil pressure guage on the dash as well as having a switch which has wiring going to the Electronic Control Module, and this ECM input has a software time-out safety feature. After the engine is started, if the indicated oil pressure goes too low or is lost, the voltage to the fuel pump is shut off. This is desired in the case of a crash. This event will cause the engine to quit. On my manual transmission vehicle the ECM will reset if the ignition is turned off for a couple of seconds. It sounds like this oil pressure (aka sending unit) sensor is not working properly, causing the fuel pump power to be removed.....(probably intermittently). About $20 and a few minutes to change if you can get your hands down in there.

Jul 26, 2008 | 1994 Chevrolet S-10

Not finding what you are looking for?
1993 Chevrolet S-10 Blazer Logo

Related Topics:

26 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...