Question about 1990 Buick Century

2 Answers

Fuel pump or crank sensor?

I have a 1990 century 3.3. the car kills after running for about 20 minutes. However, it will crank over . The car will eventually start again then kill agian. I had the coil modulater and coil packs tested and they were fine. The fuel filter is brand new and and the fuel pump does humm when I turn the key even when the car does not run. I can figure out how to test the crak sensor and I am wondering if the is a port hole on the floor to get to the fuel pump or do I have to drop the tank.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

First you must find out if its gas or spark. next ime it stops just cycle key off to run ( not start) do it several times and then try to start it if this works you got a bad pump. If it don't work pop the air cleaner and squirt some gas or either in to carb area and see if it starts if so its a bad pump . Crank sensor is a good guess at that point but they cost 75 bucks and if tou buy one you can't return it if thats not your problem. Good luck

Posted on Jul 13, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Buick Master
  • 3,854 Answers

Your going to have to drop the gas tank to get to the fuel pump, The crank sensor will give you a check engine light on or service engine light on. Good luck and hope this helps. You can go to Auto Zone and pick up the fuel pump and they will have the step by step instructions for you to replace the fuel pump,oh and replace the fuel filter again when you replace the pump. Good luck and hope this helps. The other cause of stalling is the MAP sensor may have gone bad, or the EGR valve may be stuck open from carbon build up, just remove it and clean it out with Carb cleaner. Good luck and hope this helps you get your car running 100% again. Keep me posted be glad to help you save some money. 

Posted on Jul 03, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1990 Buick Century 3.3 L V-6. Starts fine and runs good while i'm parked .


check the temp sensor. and id replace the one bad injector. these engines have problems with the coil pack. id change it with one at a scrap yard.

Mar 25, 2013 | 1990 Buick Century

2 Answers

My timing belt and water pump for Honda Accord 1990 was replaced and used the car for 2- 3 weeks. After driving about 15 minutes, entering the freeway, my car slowed down but the engine still running....


If you have never changed that distributor on your 1990 Accord, I would suspect it. Check for spark while cranking. The sensors inside the distributor would usually heat up, after 15-20 minutes of running, and would then die out, until the car is cooled off for a while. Look into that distributor.

Oct 07, 2010 | 1990 Honda Accord

1 Answer

1990 buick century


It sounds like the engine computer. Also check the resistance in the injectors and o-rings. O2 sensor and coolant temp sensor could give you a problem.

Mar 11, 2010 | 1990 Buick Century

1 Answer

Starts and runs great for 20 to 30 sec shuts off when i try to


Sounds like possible crank sensor failure,will work till warms up they have to cool,then will work again.Also monitor fuel preasure,fuel pumps can act this way too.

Jun 17, 2009 | 1991 Buick Century

2 Answers

1990 Buick Century 3.3L Check Engine Light comes on, stalls.


Need to check for fault codes. Possibly a faulty sensor causing the fuel system to run rich or lean.

Mar 27, 2009 | 1990 Buick Century

1 Answer

Starts fine, Idles fine, Drives Fine for a while


you might want to chk. the crank sensor and or cam sensor. sounds more to me that it could be fuel problem. chk. fuel pressure. pump could be on its way out. don't be fooled by hearing the pump running as they sound like they are pumping but there not, at least not enought pressure to keep it running. pressure should be around 50 p.s.i.

Jan 06, 2009 | 1990 Buick Century

Not finding what you are looking for?
1990 Buick Century Logo

576 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...