Question about 2003 Chevrolet Suburban 1500

1 Answer

Engine dies at freeway speeds

I had a similar problem last year with my 2003 Suburban, after taking it to the dealer and on their recommendation replacing a crank shaft sensor the problem still persisted. I then took it to an independent mechanic and he discovered it was the fuel pump. I have put 20,000 miles on it since the fuel pump has been replaced without any further problems.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 66 Answers

Check the coil pack and check that the exhaust at the converter is not clogged ive seen cars where the muffler is clogged and the car runs like ****, also seen a muffler colapse

Posted on Jul 03, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 Chevrolet Impala ls 3.8l. "Hello, I have an


P0171 and P0174 are lean codes. There is likely a large vacuum leak or the MAF is bad.

Try starting the car and wiggling the connector for the MAF sensor. Also try tapping the MAF sensor. If the idle changes or the car stalls replace the MAF sensor.

The second shop should recognize that these codes don't have anything to do with the ignition module.

Apr 04, 2013 | Cars & Trucks

1 Answer

2003 suburban starts and dies while driving, no codes read amd no engine lights on


check the fule presure on the injector rail is a what looks like a car tyre valve connect a gauge up to this or buy one ,i use a old AC filler pipe for one of them gas can things with the end changed to a tyre valve pump end and it works ok better than paying a lot of money for one ,should read 55lbs and if the pressure drops then suspect the gauze filter on the bottom of the pump first before you replace it as its a complete unit and around 600euros as its only available from the dealer

Mar 28, 2012 | Cars & Trucks

1 Answer

93 chevy suburban v-8 tbi hard to start, but starts, will run but will not idle, can keep it running or driving as long as you rev engine constantly. Holding engine at half throttle it will slow and die. ...


Assuming your engine is in good mechanical condition, there are only a few options.

1. You may have a vacuum leak.
2. The pickup in the distributor may be worn to the point that it is sloppy at idle but normal at higher rpm.
3. Idle control valve/motor may not be working properly.

It probably isn't an ignition related problem as the problem would normally get worse as RPM increases. I've seen #2 about 5 times in the past year or 2 so it's not uncommon and would recommend replacing the entire distributor if you come to that conclusion, but would definitely check all vacuum hoses first.

Jun 24, 2011 | 1993 Chevrolet Suburban

1 Answer

2003 Saturn Ion died out on the freeway


Sounds like a timing belt,, open the oil cap and look in there with a flash light,,
have someone turn the key if you see nothing moving in there then its the timing belt,,

Mar 12, 2010 | 2003 Saturn ION

1 Answer

Engine dies at highway cruising speeds


have fuel pump pressure checked 50-60 Psi at idle 60PSI with vac line diconnected from pressure regulator. If that checks out check for ingation switch failier may be keeps car power on but telling ecm that it has been turned from run. Also have a wave form done on fuel pump as it can still have good pressure but not be fully funtional elctricly. if you have acsses to a tech 2 have it checked for codes as it may not have turned on the light but may have stored a code

Jun 28, 2009 | 2003 Chevrolet Suburban 1500

1 Answer

2003 suburban idles to low.


the idle speed is computer controlled and not adjustable, slow idle is caused by a dirty intake, do the following.

Here are some of the causes of surges, stalls at stops, slow idle speed, erratic idle speed, rough idle and engine hesitation (and other problems), it is in most cases the idle speed control air-bypass valve and or throttle valve and upper intake, these area's get full of gunk and combustion residue over the miles and cause idle issues (stalls, low idle) like yours, Get a can of intake cleaner from any local parts store, not carb spray, intake cleaner, it is made by a company called CRC, remove the air intake hose to the engine, hold the idle high so the engine won't stall, then spray the can of cleaner into the intake while keeping the engine running, use at least 1/2 the can, shut down the engine and disconnect the battery for 5 minutes, then restart and complete a number of mixed driving cycles, town, freeway, stop and go etc., after a few days the problem will go away as the system will relearn to the clean intake.

Mar 30, 2009 | 2003 Chevrolet Suburban 1500

2 Answers

2002 suburban breakdown


it sounds like one of your sensors went out do you have any type of a obd2 tester ? off the top of my head i'm thinking it could be a cam shaft sensor but not sure till you run a diagnostics on it

Mar 13, 2009 | 2002 Chevrolet Suburban

3 Answers

2003 Chevy suburban engine dies while driving


You need to check the Ignition System. Plugs, Wires, Dist. Cap. If these are Ok, You Probably need to Check the Fuel Pump and Filter. Let me Know!

Jan 03, 2009 | 2003 Chevrolet Suburban 1500

1 Answer

Loosing power at cruising speed


Hi. I have two Dynasty LE cars, (a 91 and a 93). Both have the 3.3 litre. The 1991 had almost the same problem as yours except it would only do it once the engine warmed up, (similar to your freeway issue, given distance and time for the engine to warm up to operating temp.) I had it in about three shops before the dealer found an intermittent fault with the cam and crank sensors. I replaced them and now it runs just fine. I hope this helps.

Sep 08, 2008 | 1989 Dodge Dynasty

Not finding what you are looking for?
2003 Chevrolet Suburban 1500 Logo

108 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...