Question about 1999 Kia Sportage

1 Answer

My Kia Sportage 1999 has no acceleration at 3000rpm

When I need to accelerate the power goes totally falet at the 3000rpm mark. Very emabrassing. What would cause this?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 51 Answers

Sounds like a catalytic converter

Posted on Aug 25, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kia sportage acceleration


run fault codes and check for accelerator position sensor / motor problem

Jul 25, 2014 | 2000 Kia Sportage

1 Answer

Engine started loosing power during acceleration.


Sounds like one of your Catalytic convertor's are plugged up.

Jun 05, 2013 | 1999 Kia Sportage

1 Answer

2002 KIA SPORTAGE temporary sudden loss of power no codes,no C.E.L.


it happen from demage of accelerate sensor some time but not a big problem

Aug 26, 2012 | 2002 Kia Sportage

1 Answer

99 kia sportage sputtering under acceleration


Hi Missippirebe, I think you should replace the fuel filter and if the problem persists check fuel pump pressure. It should be at around 3.7 bar. Regards John

Jul 18, 2012 | 1999 Kia Sportage

1 Answer

1999 kia sportage chassis acceleration sensor failed. I need the location and what it looks like.


The chassis acceleration sensor is located on the left side below the motor. Not on the motor but on a little metal plate connected to the body. I paid $55 at KIA for the part. The part # is 0K2NC-18911. They say it's a universal part. It took me two days to convince them the part even exist. But I have it now. I hope this helps.

Oct 03, 2011 | 1999 Kia Sportage

1 Answer

I have a 99 kia sportage and fail emission test because of a p1309 manufacturer specific code. how do u fix it


P1309 Chassis Acceleration Sensor Circuit High Input
To be totally honest i have never heard of this one before and at this time of night i cannot think right so i would ask at kia what it means and as and when you find out please let me know by a reply on the posting ,Sorry i cannot help here now if you ask me about a ford cortina or a humber ?? iam your man

Sep 20, 2011 | 1999 Kia Sportage

Not finding what you are looking for?
1999 Kia Sportage Logo

Related Topics:

496 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

yadayada
yadayada

Level 3 Expert

75807 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8172 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...