Question about Chevrolet Astro

4 Answers

Hello, I have a 1993 Astro van. The problem began with 5 stalls within a half mile trip home from the train station. Next morning would not start at all. Proceeded to replace the pickup in the distributor...new alternator...fuel pump...thought it was the fuel regulator, so replaced with rebuilt fuel injector spider. Checked for spark on all plugs...have spark...set timing...confirmed fuel was entering injectors, but no ignition. Established there wasn't a pulse to the injectors, although there is power in the wiring harness. Was advised it was the computer not sending a pulse to the injectors. You guessed it, replaced with rebuilt computer-still won't start. What else could be causing this problem...a puzzled DIY! Thanks, could you point me in the right direction? AstroBob93

Posted by on

  • 1 more comment 
  • Robert Lariosa Jul 02, 2009

    e-Guru,



    Appreciate the prompt response...asked many what could disable the van...no one knew oil sending switch as a safety mechanism could be the fault. Sprayed ether into air intake and it did run til it burned off, but would not start on own. The ground to the engine indeed was partially torn. Will replace. In fact on way out on my bike to get proper ground tie. Thought problem to be electrical...just didn't know the process. What's the ICP...ECM is the computer, correct? A broken wire seems like quite an undertaking. How would I approach this? The distibutor spins. Will let you know how I make out. Thanks, AstroBob93...

  • Robert Lariosa Jul 03, 2009

    Hi e-Guru,

    The ground to the ECM was partially torn. Corrected with new terminal. After assembling the manifold turned the key and actually heard the sound of a running engine. Didn't last, though. After repeated starts...I'd have to give it gas for it to run, when letting up on the gas it would shut down almost immediately. Idle Air Control Valve...what do you think? This has been the closest I've gotten to resolving this issue...thanks again!

    AstroBob93

  • Robert Lariosa Jul 03, 2009

    Hello e-Guru,

    Had replaced vaccum lines, corrected the ECM ground connection - made turning over possible. Replaced the Idle Air Control Valve, but still repeating ignition with short start up then stall after letting up on the gas. Actually made it around the block - with repeated stalls - not able to reset IAC. Back to square 1. Was able to note code 33 - map sensor - had replaced last May - could it go bad after 1 year? Under warranty - will also replace. What's the proper technique for setting the timing? Mystery continues.

    Have a good 4th - Thank you, AstroBob93

×

4 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 952 Answers

If changing the map sensor doesn't work, check the vacum sensor. I experienced the same symptoms when my car's vacum sensor got busted..

Posted on Jul 04, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,952 Answers

It may be an electrical wiring defect check it...

Posted on Jul 03, 2009

  • 2 more comments 
  • mohammed marika thambi
    mohammed marika thambi Jul 03, 2009



    Need to determine what is missing fuel or spark. Pull plug wire hold next to block crank spark? if yes then spray some cabr cleaner into throttle body crank runs?












    If you have pressure at the rail, I doubt the regulator is the
    problem.Sounds like you dont have injector pulse.Check ALL fuses with a
    test light, if I remember correctly there is an injector fuse in the
    panel.If it is good you most likely have a bad ignition module or computer.
    Check for injector pulse


    check TPS sensor and its volts


    good luck


    let me know


    Need a tool or a tester CHECK IT @


    http://www.2carpros.com/affiliate/uid/bm...


    *****************************************


    need manual CHECK IT @


    http://www.2carpros.com/kpages/auto_repa...


    Need parts check it @


    http://www.eautopartstore.com/


  • mohammed marika thambi
    mohammed marika thambi Jul 03, 2009

    For starter heres one suggestion these vehicles have a very badly designed electrical connector on the


    driver's side, underneath - about mid-ship. This connector is for the


    power to the fuel pump and sender. Known to build up corrosion and act up


    very intermittently. Worth looking at.





    my next guess would be to find a very good automotive electrician and
    have them run diagnosis on the crank and camshaft sensors, a bad crank
    sensor does not give any errors reading to the computer, if its faulty
    it can cause random nonstarting conditon.




    I would also have the fuel pressure
    checked with key off to verify that presure is between 50 and 60 psi
    pressure has to be this high to open the popets or van will not start
    indicating a bad pump even if it reads 60 psi while running.





  • mohammed marika thambi
    mohammed marika thambi Jul 03, 2009

    Check fuel pump pressure. It sounds like the pump is bad. Here is a how to video to help.





    http://www.2carpros.com/dia/test_fuel_pr...


    New pump installed, all pressures are good.
    Bleed down pressure is a little fast so a new pressure regulator will
    be the next thing to fix.




    Vehicle started on the first try!



  • mohammed marika thambi
    mohammed marika thambi Jul 03, 2009

    If you have fuel and timing is ON


    and not 180 off


    firing order OK


    my next step would be compression test


    if compression is good


    than I have to say timing possibly OK


    and back to the distributor and firing order


×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

Thanks - if you have additional concerns - please use the "Continue With This Expert" option so we are connected in the future.

BTW - have you had an OBD scanner on your Vehicle to read any error codes??

Posted on Jul 03, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,917 Answers

Hi,

If You can start the vehicle off ether only then you have a fuel issue. the pump is working and the fuel pressure regulator is too. so either the injectors are not getting an electrical signal to open and close of possibly, Your oil sending unit is defective and has shut down your fuel system (a safety).

The vehicle wont start unless you used ether but then it got worse and even with the use of ether, the vehicle wouldn't start, right? Did the engine light come on and were you able to retrieve any codes? The more info that you get the better. It really did sound like a bad oil sending unit but none the less it didn't work. Unfortunately you are doing process of elimination. With out a good scan tool it wont be easy or fast to fix. Your problem could be a bad ground or a broken wire. On the front/top part of the motor, at the thermostat housing, there is a ground going to one of the bolts. That ground goes to the ECM. Make sure it is clean, tight, free of corrosion, and not broken. You have already tried replacing the ICP, pick-up coil,plugs,wires,cap and rotor, and fuel filter. All good things to consider replacing. Check the PCV valve,coil (for primary and secondary resisdence),vacuum leaks, IAC, coolant temp. sensor, Both fuel injectors (you said the fuel line pressure is 58psi, so the pump and regulator are working but why isnt it spraying past the injectors) check the wiring and connections at the injectors. Check the fuses and relays asociated with the fuel,ignition, and engine. I dont know if you already checked it but turn the engine over and see if the distribtor spins.

Thanks for contacting Fixya.

Posted on Jul 02, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Having trouble with engine killing or running rough even after it's warm.


not for sure but it could be your cam sensor. if the check engine light is on then take it to a parts store and they can run a scan and give you more information

May 11, 2014 | 1993 Buick Riviera

1 Answer

1993 satro van stalls when starting. runs about 5 seconds then stalls. takes between 5 and 10 times then it will run and will stall once in a while while driving. I put my ear to the gas tank and could...


Start with the simple and replace the fuel filter, a dirty fuel filter will also cause what you have described and a ICM (ignition control module) going bad will also do the same.

You can remove your ICM and have it tested free of charge at Auto Zone or Parts Source when you go and pick up the fuel filter. A bad ICM will cause your engine to stall out and eventually fail totally and your going to have a no engine run situation.

Be safe and thank you for using fixya

Sep 18, 2010 | 1993 Chevrolet Astro

2 Answers

93 chevy astro will not start


You need to check fuel pressure. Fuel pump may be working but weak.

Mar 14, 2010 | 1993 Chevrolet Astro

1 Answer

Electronic throttle control symbol illuminated this morning and the engine went to a limp-home, what does it mean, and is it costly? Driving to the train station in Atlanta this morning the symbol came on...


I would not recommend any trip until the car is repaired. The symbol in the dash means the car was in limp mode. It could be caused by the T/P sensor, this is the most likelt problem.

Oct 23, 2009 | 2004 Lincoln LS

1 Answer

Van has poor pick up after short time of running


Did you replace the fuel filter as well?

May 20, 2009 | 1996 Chevrolet Astro

2 Answers

Trouble code 42 ignition module failure


Also check all of your grounds, a little corrosion caused the same problem on mine. Just had to find the right ground. Mine was on front under pass headlight causing mine. Good Luck

Apr 20, 2009 | 1993 Chevrolet Astro

1 Answer

1993 Astro Van won't start after a number of fixes...


it might be your fuel pressure regulator. it its a vortec 4.3 i had to change my regulator twice.

Mar 28, 2009 | 1993 Chevrolet Astro

3 Answers

1994 caravan stalls


if it stalls and start right away without long crank time more likely you have ignition spark cutting out.this vans are notorious for ecm failing to ground contorol.if it is a 3.3 or 3.8 V6 very common problem. check for spark at a plug wire when stalles and if no spark replace ecm.i hope i was helpful. please rate me.

Jan 28, 2009 | 1994 Dodge Caravan

2 Answers

Stalls / Dies / dead


this engine fuel pump prassurae low. it fuel pump celan. Your problem sovel

Jul 13, 2008 | 2003 Ford E150

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...