Question about 2001 BMW 5 Series

Open Question

My Speedo is not working, abs light on, fuel gauge is not correct, rear wiper not working. All these problems happened at about the same time. All fuses are fine, had the ABS module checked and no problems but the car seems to run with the exact same faults with the module removed as when it is in place. Its a 2000 W reg 523i any ideas? I have just bought an ohm meter to check the wiring loom for the abs ecu but would a problem with the loom cause all these problems? Also the computer display on the dashboard is extremely unclear with missing letters. The dashboard was taken off beofre these problems started to fix a climate control problem. The problems started 2 weeks after that. Any ideas?

Posted by on

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1071 Answers

SOURCE: abs and traction control lights, speedo and fuel gauge

abs module

Posted on Jul 25, 2009

alicantecoli
  • 22156 Answers

SOURCE: Nissan murano 2005/55 needs a new ECU Wiring Loom

accident damaged vehicle in scrap yard

Posted on Nov 29, 2010

  • 3 Answers

SOURCE: hello i need help im

Give me some more information about this problem. May be i can help.

Posted on Jul 14, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Is this a speed censor problem


no year, car, are you kidding??? NO YEAR?
that makes any answers impossible.
speedo dead, but is odometer too?
gas gauge dead,
ABS full time failure
Brake lamps same (in dash or rear tail lamps too?)
does car drive?
does engine run.
is the CEL lamp on driving? check engine light or SES lamp.?
sorry for 20 questions but its a complex machine, and me blind. .

Jul 15, 2014 | BMW 325 Cars & Trucks

1 Answer

1998 Plymouth Grand Voyager.........Dashboard instruments quit working and don't light up. Speedo, tach, fuel gauge, temp gauge, and mileage indicators and lights for same stopped working. ABS...


You have some wiring problems shorting out that is coming from the dash board so if you or anyone you know how to use a multimeter to check the wireing harnesses plus check any connectors that might be just very touching the connector of dashboard which means a bad connection to dashboard.

Jun 04, 2011 | 1998 Plymouth Voyager

1 Answer

Rear wiper and dash cluster not working, not fuse


This, below, could very well explain issue with gauges. As for the rear wiper this may be related to the switch, BCM (body Control Module) wiper motor or wiring. I'd start of by accessing the wiper motor and see if powere is getting to it, if there is power you know it's the motor.

There has been issues with the solder joints on the PIN connection to the gauge cluster. The issue being that over time thru vibration and such one of these solder joints will fail (happened on or 1999) you can repair this though. You will have to remove all of the trim from around the driver's side dash board, this will include the trim towards the center of the dash. Once these pieces are remove you'll need to remove the gauge panel (I believe (4) allen head screws) carefully bring the panel and release the wire clip from it. Looking at the back of the panel, where the plug was, carefully with plenty of light look for one of the pins to have a failed solder joint. It will be very faint however the failed joint will be a fine dark line around the pin. To correct use a small soldering iron and reheat this solder until it wants to flow, let it cool and reassemble.
I hope this may have helped,
Tom
PS: I have helped several persons with this issue, please review my profile; good luck with it (also often times with this issue the ABS light stays on)

Apr 14, 2010 | 1999 Plymouth Voyager

1 Answer

2003 Dodge Dakota lost speedo, reverse lights and ...


It's the speed sensor and it is located on the rear axle.

May 14, 2009 | 2003 Dodge Dakota Club Cab

1 Answer

Speed-o-meter and RPM gauge do not work


if the engine is running fine and no limp mode no engine lights. abs is working then the only other thing could be the dash may need replacing as putting the battery on wrong can blow the electronics in the dash as they are both linked. i ask is there any other problems as the rev counter work to ecu in line with speedo and the abs unit to determine timing etc. speedo works of the abs system the connection between them both is the board in the dash board. you can replace the boards in the dash but you will need replacement dash parts to do this but remember if you change the dash you need to log the miles as new dash will have different miles and uk mot log your miles to dvla. USA i dont know you would need to look into this.

Jun 29, 2017 | 1996 Audi A4

Not finding what you are looking for?
2001 BMW 5 Series Logo

Related Topics:

415 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...