Question about 2002 Nissan Maxima

2 Answers

What causes a car not accelerate properly - 2002 Nissan Maxima

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 265 Answers

I know common issues for the the 2000 Maximawas the Mass Air Flow sensor and the coils. I think both of them triggered a Service Engine Soon light.

My 2002 Maxima has had no issues yet (only 70k miles, unlike the 180k on the 2000).

Posted on Jul 12, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,418 Answers

One problem can be a dirty or clogged air filter. Another, it's in need of a tune up. Too many maybes to list. Do you have a Check engine light on? If you do have local auto parts store read codes. ave you put any injector cleaner in the gas? This may help.

Posted on Jul 02, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Motor hesitates & bucks after slowing down & then re-accelerating


HMM, it has been awhile since ive worked on that toyota motor. Check for vacuum leaks on hoses and the intake manifold. Check egr system for a dirty pintle leaving the egr stuck open. It will cause bad acceleration and idle quality. A properly closed egr cannot be blown through to the opposite port. Check for a clean throttle plate, if it is not, clean it. If it is a fuel injected engine check for bad fuel injector o rings for wear, if they leak they cause fuel burning and idle problems.

Feb 09, 2016 | 1990 Toyota Pickup

1 Answer

What would cause my vehicle to have no acceleration power to it?


Can be numerous reasons and there is no value in just guessing what the issue may be on your car.

You need to have the car properly scanned for faults and then a proper diagnosis can be carried out by a professional on the causes of the engine issues you have with the vehicle.

Jan 08, 2016 | 2005 Chevrolet Malibu

1 Answer

I have a 99 Pontiac grand am v6 3400. While driving I have lose of power when accelerator from 35 mph to 50 mph what would cause this


If it is up hills only then you have an underpowered engine that can not accelerate in third gear like the junky little Corolla E110 and it's Chevrolet Prizm clone 120 HP on on 2400 pound car do but a 170 HP V6 on a 3000 lb should have more power then that. In any case it is because you are in third gear and first and second gear have enough torque to accelerate properly.

It is the feature I hate the most on smaller engine cars.

Apr 16, 2015 | 1999 Pontiac Grand Am

1 Answer

What, other than plugs, wires , cap and rotor would be causing loss of power on acceleration, but not all the time,, intermittently.


There is a vacuum advance attached to the distributor. Inside the vacuum advance is a rubber diaphragm that can crack from age an no longer work. Sometimes the vacuum hose that attaches to it may not be getting proper vacuum. This device adjusts your timing when you accelerate. Improper function could cause the problems you describe. Also, a vacuum leak in any of your vacuum system could cause the problem your describing. Too much air intake on take off from a faulty vacuum system could throw off your air fuel mixture on acceleration causing hesitation until the air fuel mixture can catch up which is when the power comes back. Hope this helps.

Oct 29, 2014 | Cars & Trucks

1 Answer

What cause a sluggish acceleration on the 87 fiero


poor fuel pressure and or volume, poor fuel quality, ignition timing is off, bad throttle position sensor(TPS), dirty air filter, fuel injector/s dirty or plugged or not functioning properly, bad manifold air pressure sensor(MAP). just some things that can cause your problem. I would suggest taking your car to a shop to have it diagnosed unless you have the testing equipment and specs to know what is within specs.

Sep 25, 2014 | 1987 Pontiac Fiero

1 Answer

Poor acceleration on a 2005 chevy uplander


Poor acceleration in a car is ofen a symptom of engine hesitation. Unfortunately, engine hesitation has many possible causes, ranging from a simple dirty air filter to a very serious transmission problem.
If the air filter is filthy it prevents the proper amount of air that gets in the engine.
A clogged fuel filter doesn't allow fuel pressure into your cars fuel injection system.
The problem could be from rhe spark plugs being worn or not adjusted correctly.
If your transmission is bad, it will loose the power that the engine has built and cause slow acceleration.
You can go to a parts store to have a diagnostic computer read out to see what the problem is..

I hope this helps.....

May 13, 2013 | Chevrolet Cars & Trucks

1 Answer

While driving when I try to accelerate after 30 miles per hour my car pulsates before picking speed.The car seems like loses speed before it pickup speed.


It's hard to say if this is something more dire than this, but have your spark plugs and wires checked out.

If a cylinder is not igniting properly when you accelerate, it would definitely cause this problem.

I had a car where it would 'jump' when I was trying to accelerate past 30-40mph and switching the wires fixed it right up. Hope this helps!

Mar 13, 2011 | 2003 Mercury Grand Marquis

2 Answers

When accelerating there is no power but when releasing accelerator slowly power picks up. why is this happening 2001 ml270 cdi


Hi, this is a common symptom of a clogged fuel filter that is straining the fuel pump itself.

When you accelerate, this initiates a rapid fuel flow through the lines. if the filter cant pass the proper amount, its will stall or hesitate the engine and cause sputtering or loss of power. due to this clogged filter, the pump cant keep up with your acceleration demands at this time. the reason for the power pick up upon De acceleration, is because the lower amount of fuel is able to pass through quite easily but, as soon as you demand more power, the clog will obstruct the more intense flow of fuel to the injectors.

Simply replacing the fuel filter and pump will fix this issue.

Please rate and god bless:)

Apr 17, 2009 | 1998 Mercedes-Benz C-Class

Not finding what you are looking for?
2002 Nissan Maxima Logo

1,341 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

713 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...