Question about 1993 Chevrolet S-10

1 Answer

I have a 1989 325I BMW. Some it times won't start.

My BMW has 78k miles on it. It runs great. when I start it sometimes it will not start but it does turn over fine. Then if I let it sit for awhile it will start with no hesitation. This could happen one time every 25 starts or one time every ten starts. I have replaced the spark plugs, the fuel pressure regulator, the ignition switch and the wiring harness to the switch. Can someone help. Thanks

Posted by on

  • mgtd252 Jul 02, 2009

    I have replaced the fuel filter. The pump is the only thing I haven't replaced. Would an injector leaking down pressure cause a problem like this? Thanks

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

Check fuel filter and/ or replace check pump and or replace

Posted on Jul 02, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Just purchased 2000 Buick LeSabre. 56,000 miles, sporadic trouble starting--sometimes starts first try, other times will crank and won't start and have to slightly depress the accelerator and then will...


If it runs rough all the time, could be a bad coil pack/wires. If just starting and hesitates on acceleration, I would suspect the throttle position sensor.

Jun 10, 2011 | Buick LeSabre Cars & Trucks

1 Answer

Jeep makes a whining sound when I turn left sometimes. Doesn't do it when turning right ever and only seems to do it when driving forward. Only happens at low speeds and doesn't seem to affect...


It MAY,,,,,, be the start of a power steering pump problem.Just maybe.The pumps can moan and groan without leaking,so keep an eye on it.Hope this helps.

May 19, 2011 | 2004 Jeep Grand Cherokee

1 Answer

I have a 2003 745Li w/ 78k miles ... bought it 6mos ago w/ 75k miles .. i went to BMW dealership for oil change .. and 2weeks later .. ck engine light came on and code in-dash says emission error.. dealler...


Yes, well I would ask both service shops for your BMW, what the codes were so you could judge for yourself which direction to go, with the gasket and catalytic converter first, or the water pump first.

Emissions has more to do with gaskets and catalytic converter than the water pump, unless you were having an overheat condition.

I think you should go with the first shop first, even though it might be expensive to do so.

Nov 12, 2010 | 2003 BMW 7 Series

1 Answer

1992 crown vic with 78K miles. Started skipping


Replace you Maf sensor and have a nice day. lol does the hesitation go away when you let off the gas. does it buck hesitate and misfire under load? most common problem is the maf sesnor.
easy to change. don't buy a used part it may develop the same problem after a little while. you can try cleaning the wire inside with brake cleaner (not intake cleaner). it may or may not help.

Jun 26, 2009 | 1992 Ford Crown Victoria

1 Answer

Starts first time , then sometimes won't after short run


Hi there,

Had the same problem with my motor it was the camshaft sensor and it's easy to fit yourself. Mine would start first time when cold then after driving even short distances wouldn't start. Hope this helps.

Jun 06, 2009 | 1999 BMW 5 Series

1 Answer

Temp Guage Rises While in Traffic Stop and Go


it seems to me that your fan is not working properly ,check the relay first you might get lucky.if not i would start looking for a bad connection or in replacing the fan

Nov 23, 2008 | 1994 Pontiac Grand Prix

3 Answers

2000 bmw 528i shudders when first started and when it idles


I had the same issue with my 2000 528i. You more than likely need to have the Vanos seals replaced. BMW will tell you that the Vanos unit needs to be replaced but the problem is more than likely isolated to the OEM seals that shipped with the Vanos. This issue has been reported by several BMW owners. This issue has been thoroughly documented and reported to BMW in an effort to seek a corrective fix. Since BMW failed to address the problem, the guys that investigated the issue started their own company providing superior Vanos seals to the deficient OEM Vanos seals.

The company is Beisan Systems, LLC. I ordered their Vanos seal kit and had them installed at a local BMW performance shop for less than half of what BMW wanted to charge me for a Vanos replacement with the same faulty seals. Besian also provides step-by-step DIY instructions; if you have the time.

http://www.beisansystems.com/index.html

Good Luck.

Nov 13, 2008 | 2000 BMW 5 Series

Not finding what you are looking for?
1993 Chevrolet S-10 Logo

397 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...