Question about 1989 Buick Century

1 Answer

Cold Start and TRanny issues.

I have a 1989 Buick Century Custom with less than 130,000 miles on it, as of the last few months it's had trouble with what I have been told is the central neutral lock, it's a sensor that goes into the transmission, basically what happens is when I cold start, sometimes it wont start at all, sometimes it will, then when I shift into drive it acts as if no fuel is getting to the motor and it sputters and will not put any fuel into it to get it going, do I have multiple problems or is this just a sensor that needs fixed?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 3,113 Answers

A neutral park switch keeps you from activating the starter in drive or reverse. It also turns the reverse lights on. Its on top of the transmission at the end of the shift cable . If it does not turn over in park try it in neutral, Clean battery cables. Check fuel pressure. Is check engine light on?

Posted on Jul 02, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2004 Century. Sometimes when I start up from a stop it feels like the rear wheels are slipping (like on wet pavement, but road is dry) then they take hold and I hear a thunk. It is sporadic and won't...


You are pretty sharp...most likely an early tranny problem...I would add a full bottle of Lucas Oil Transmission stabilizer to "treat" the transmission...this is only an $11. bottle and can be added without draining any fluid...This could solve your tranny problem for many trouble free miles...Hope this helps.

Feb 21, 2011 | 2004 Buick Century

1 Answer

1992 Buick Century Custom. Trouble starting as though not getting gas. Changed the fuel pump and filter and still has the problem. After a few trys it will start and run ok. ?????


Sounds like you need to replace the fuel pump relay which is about $13 at Autozone. It is simple to replace. It is under the hood on the passenger side right behind the headlights.

Oct 11, 2010 | 1992 Buick Century

1 Answer

1989 buick century custom problems


sounds like a dirty idle speed control valve.

To correct this problem I want you to get a can of intake cleaner (ABOUT $5.00) from any local auto parts store like NAPA or Carquest, do not use carburetor spray, intake cleaner only or u will damage the Teflon coating inside the throttle valve and air bypass valve, it is made by a company called CRC, remove the air intake hose to the engine, hold the idle high so the engine won't stall, then spray the can of cleaner into the intake while keeping the engine running, use at least 1/2 the can, shut down the engine and disconnect the battery for 5 minutes, then restart and complete a number of mixed driving cycles, town, freeway, stop and go etc., after a few days the problem will go away as the system will relearn to the clean intake.

May 19, 2010 | 1989 Buick Century

1 Answer

96 Grand Am GT 130,000 Miles My car has been


cause you either low on water or your heater core is half plugged

Jan 14, 2010 | 1996 Pontiac Grand Am

1 Answer

My car is jerking while accelerating and reaching certain RPM


clean mass air flow sensor check for mil light

Jun 01, 2009 | 2002 Buick Century

2 Answers

2000 Buick Custom - no response on inital start


that sounds like its the ignitionswitch is going bad on the car or its the ignition its self. it could also be a loose wire going to your starter.

Mar 24, 2009 | 2004 Buick LeSabre

1 Answer

1989 Park Avenue dying after 60 miles, restart immediately then


sounds like the ignition module but it could be a fuel problem

Jan 10, 2009 | 1989 Buick LeSabre

2 Answers

1995 buick century transmission trouble


Most likely causes is the OD shift solenoid or less likely the VSS

Oct 25, 2008 | 1995 Buick Century

2 Answers

Car won't start; Replacement Key from GM or Starter Bad?


Check the cylinder, maybe the magnetic spot is not contacting the correct area of the cylinder. Cylinder may be loose, also poosibly bad computer chips on the keys.

Jul 23, 2008 | 2001 Buick Century

Not finding what you are looking for?
Cars & Trucks Logo

226 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...