Question about 2005 Chevrolet Impala

1 Answer

01 impala can a bad front hub bearing cause the abs light to come on?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Chevrolet Master
  • 3,854 Answers

Yes it can if the hub has lot's of play but you will have drive issues first. Check the ABS sensor for broken wire, dirt, and the gap to the speed ring on the hub. You can clean the the ABS sensor with brake parts cleaner with out removing it, just a good spray should to the trick and check the gap from the sensor to the speed ring. You can use a dime as a reference for the gap to make sure you have the right gap and make sure the ABS wire harness is not damages in any way. Good luck and hope this helps, also check the fuse to the ABS system. If there is a Auto Zone have the can scanned since it's fee of charge just to make sure it's not the ABS module that has gone bad.

Posted on Jul 01, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Changed bearings and abs light and stabletrack still on do they reset after u replace the bearings and if so how long


Service Traction Control - Stabilitrak and ABS light, Help - Page ...

chevroletforum.com > ... > Tahoe & Suburban
Aug 16, 2012 - Service Traction Control - Service Stabilitrak and ABS light came on. ... Its supposed to still be under warranty, "Major Guard". ... I replaced my rear shocks with OEM re-manufactured Arnott shocks (great company) and in the ...

SilveradoSierra.com • Traction Control, Stabilitrak & ABS Issue

www.silveradosierra.com/.../traction-control-stabilitrak-abs-issue-t18976...
Jan 28, 2014 - Traction Control, Stabilitrak & ABS Issue. Tue Jan 28 ... The wife and I got in to head out and see my brother and as soon as I turned the key the ServiceTraction Control, Service Stabilitrak messages flashed and the ABS light came on. ... check your wheel bearings my was gone and caused the same thing ...

Chevrolet Impala Questions - Hello. I have a 2012 Chevy ...

www.cargurus.com > Questions > Chevrolet > Impala

CarGurusApr 6, 2013 - Occasionally when I hit the brakes I get a Stabilitrak Error Message " ... I believe GM still had 3 year/ 36,000 mile bumper to bumper ... After about 2 months of intermittent noises the ABS light came on, the service stabilitrak warning, servicetraction ... Edit....left hub bearing change after the right one changed.

Replaced front hub - now ABS/Stabilitrak lights on... - Chevy ...


Dec 12, 2015 | Cars & Trucks

1 Answer

Our 2007 impala...the traction light and the ABS light stays on all the time..also we are having a roar sound with our tires as if they were snow tires, but they are not.The noise is loud.. any sugges


I would suspect you have a bad wheel hub (bearing) assembly. The bearings will roar/growl when they start to go bad. I've seen the bearings actually disappear from the hubs because it got so bad. Also, the ABS light will come on when the bearings go bad. I would take it to a mechanic before it gets any worse. BTW, GMs are known to have wheel hubs go bad.

I hope I was able to help you out.

Scott
ASE Certified Automotive Technician
ASE Certified MED/HVY Truck Technician

Jan 22, 2013 | 2007 Chevrolet Impala

2 Answers

My services traction light comes on on my 05 chevy impala and my abs light doesnt go off neither does my trac light. What could be the problem? and how much would u think i looking at in cost to fix it?


Very common problem. The MOST LIKELY cause is that you have a front wheel speed sensor that is not working properly. This could be due to a bad front wheel bearing assembly or it could be a wiring problem. GM has had a LOT of problems with the wiring harnesses. A company named "DORMAN" makes a harness repair kit. (See picture below) The Dorman part number is: Part Number: 970-041 The wheel speed sensor itself and the wheel bearing come as a complete "HUB" assembly. The wheel bearing should be checked for looseness and the speed sensor should be tested at the speed sensor connector for AC voltage output when the wheel is spinning. If the bearing or the sensor is bad, then you must replace the hub assembly. If this is the case, I recommend using the "Timken" hub assemblies. They are more expensive, but are much better quality. I have had many problems using the cheaper brands. (See picture below) If the wheel bearing and sensor is OK, then the harness should be replaced. You will have to scan your Antilock Brake System (ABS) module to find out which one is causing the light to come on. As far as cost...it depends on exacltly WHAT it needs and WHO is doing the job. There also may be more than one speed sensor giving you problems. Your best bet is to get it diagnosed and get an estimate of repairs. If they try to sell you a hub assembly, ASK them if they actually TESTED the speed sensor. MOST mechanics out there will just throw a speed sensor (hub assembly) at the problem if they have a speed sensor code, only to find out later that the problem is in the harness. Of course, the customer is the one who ends up paying for their incompetence when this happens. dttech_36.jpg
SPEED SENSOR WIRING HARNESS REPAIR KIT


dttech_37.jpg WHEEL BEARING, SPEED SENSOR AND HUB ASSEMBLY

Aug 06, 2011 | 2005 Chevrolet Impala

1 Answer

Replace front wheel bearing


The front wheel bearing for your Impala is an integrated wheel hub/bearing/ABS.
The whole thing gets replaced. It should look like the one off my Bonneville; Bearing.

Remove wheel/tire. Remove brakes. Remove rotor. Remove axle nut. Press-out axle shaft*. Unplug ABS connector. Remove 3 bearing bolts.

*To press out axle, you may need a special tool from an auto parts store.
Don't forget to put the heat sheild back on during reassembly, and the axle nut need to be very tight.

zeevert_62.jpg


After Bearing/hub removed:
zeevert_73.jpg

Apr 21, 2011 | 2004 Chevrolet Impala

4 Answers

Why is my abs light on in my 03 chevy? and on the passanger side the front tire is roaring really bad when i drive, please help


Ok, there are sensors on your front wheel hubs. This could easily cause the abs light to turn on. The loud noise could easily be your wheel hub going bad. Easiest way to check, jack up the front of the truck, grab tire, shake back and forth and up and down. Same amout of play each way? You're wheel hub is bad.......

Aug 27, 2010 | 2003 Chevrolet Tahoe

1 Answer

2002 impala abs light and tracrion control light are both on has had new front hubs and pads and rotors replaced recently Could it be rear bearings


the speed sensors come with the hub bearings may be a rear sensor if you pull the codes on it it will tell you where the problem is don

Jun 24, 2010 | 2002 Chevrolet Impala

1 Answer

Abs light on, traction light off and grinding


could be a warn front hub bearing. this is real common . new hub should come with the abs
wheel speed sensor. jack up car and safely
support , rotate tires and listen for noise ,
also attempt to wigggle/ move wheels and
see if any play

Nov 22, 2009 | 2003 Chevrolet Impala

4 Answers

Impala - trac off and ABS light along with service traction syst


THE PROBLEM IS WITH A HUB WHEEL SPEED SENSOR OR MORE LIKELY THE HARNESS LEADING TO THE HUB.

CHECK THE RESISTANCE AT THE HUB CONNECTION, IT SHOULD BE BETWEEN 900OHMS AND 1300OHMS. THEN SWITCH TO A-C VOLTAGE, IT SHOULD BE 100MV WHEN TURNING THE WHEEL BY HAND. IF BOTH CHECK OUT THE PROBLEM IS IN THE WIRING TO THE HUB.

THE RIGHT FRONT HUB USUALLY HAS A BEND, DOWNWARD THEN UPWARD NEAR THE CONNECTOR TO THE HUB. THAT IS WHERE THE PROBLEM USUALLY OCCURS.

NEW HARNESS WIRES CAN BE BOUGHT AT THE DEALER.

Jun 14, 2009 | 2003 Chevrolet Impala

1 Answer

2005 impala


All the hubs on the car have the abs sensor built into the hub. The abs system has to be re set to read the sensor . The rear hub bearing if noisy should be replaced. There are wiring harnesses that connect to the abs sensor. The harnesses to each of the abs sensor should be replaced.

Mar 18, 2009 | 2005 Chevrolet Impala

4 Answers

Abs light


A common cause for an ABS light is a broken wire to one of the front wheel speed sensor, or the sensor itself is bad. The sensor is part of the hub/wheel bearing assembly. A problem in the ABS causes the traction control system to be dissabled, thus turning on that light.

Jul 25, 2008 | 2001 Chevrolet Impala

Not finding what you are looking for?
2005 Chevrolet Impala Logo

316 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

81400 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...