Question about 1995 Ford F150 Styleside Regular Cab

3 Answers

Third altenator and blown main

I am on my third altenator in 2 months and now my main fuse has blown what could cause this? I have a 1987 mercury tracer

Posted by on

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 138 Answers

Could be you got wrong alternator the first time around. There are different amps. Check specs on orginal Alt. for your size engine, taking into affect if it has AC or not.

Posted on Jul 01, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 31 Answers

That happened to me, it turned out the cure was straightening the alernator bracket, it was bent just enough to say it was bent and i went through 3 alternators in 2 weeks and that was the problem the whole time, just before the 2nd and 3rd alernator died they surged the main fuse and blew it, all for the sake of it being slightly out of place, it makes the load uneven on the pulley wich in turn is hard on the inside with more pressure in the back of the guts and next to no pressure on the guts in the front, it fluctuated the power and even made the lights act up and all kinds of akward things
... if that dosent work make sure the ground on the alternator is properly secured and not corroded anywhere that will deter its performance

see if it works for you

Posted on Jul 01, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 378 Answers

Check the voltage to the battery during the engine running, it should be 14vdc regulated even the engine rpm is high, 15vdc volt is consider a over voltage.
next check the ground connection from engine to the chasis.

Posted on Jul 01, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Cc1987 mercury grand marqeis cruse control does not work


I would start by checking the fuses on that circuit.look in owners manual under (fuses) Locate fuse block and look for a blown fuse.There might be a relay fuse under hood

Jun 11, 2011 | 1987 Mercury Grand Marquis

2 Answers

No juice out of new altenator with new battey on 2001 taurus 3.0l


it's possible to get a bad "new" alternator. Get it tested.

Dec 31, 2010 | 2001 Ford Taurus

1 Answer

Blue High beam indicator flashing and high beam lights and daytime running lights no longer working


Check your altenator. Mine had the same problem blew all the front headlights, running lights. My altenator was over charging the system. Sounds like you need a new altenator. Pull the bulbs to see if they are blown..if your lucky the fuse just went. Fuses #15,16,17,18 located beside the battery may just be blown also.

Nov 29, 2009 | 1998 Ford Contour

2 Answers

1987 mercury topaz that has a rough idle and then stalls, the car will not stay on


Three things come to mind.

First is it a rough idle at normal rpm level which could indicate the throttle body needs cleaning.

Second is you have a faulty Idle Air Control valve (IAC)'

Third is you have clogged or dripping injectors. Injectors should have a smooth cylindrical spray pattern.

Jul 14, 2009 | 1987 Mercury Topaz 2 Door

1 Answer

I put on a new alternator but its not charging the battery. What could cause this ?


Check to see if it has an external voltage regulator.
Also check the main fuse's
Have you checked the alternators output with a multimeter ?
Have you had the battery checked ?

Jun 28, 2009 | 1987 Mercury Cougar

1 Answer

1997 moutaineer Non functioning power windows, sunroof, door locks and power seats. What's the cause?


Check the fuse under the hood top right corner fuse box Third fuse down on the left side It is a 30 but in older Mercury Mountaineers the wires come slightly corroded and tend to not transfer enough power. So in conclusion either A: the fuse is blown or B: Boost it up to a 50 fuse which is what I had to do

Jun 23, 2009 | 1997 Mercury Mountaineer

1 Answer

Drained battery


It's a small draw if it takes that long, I would start by checking the under hood lamp, they have a mercury switch which if it is not on level ground have tendency to stay on, the switches also plain and simple fail and keep the light on. Same holds true if it has a trunk lamp, and the third is the glove box lamp. The best was to check these of course is in the dark.
Typically you would remove one of the battery cables use an Ammeter in line and this would give you an amp reading if there is a draw an how much, once you have this, you can pull fuses until the draw stops. which ever fuse or disconnected item will now be exposed.

Apr 15, 2009 | 1993 Cadillac DeVille

1 Answer

Is there a fuse/fusible link to alternator,


The wiring burning up at the altenator most likely caused the diode inside the altenator to short out. I would just replace the altenator now.

Mar 18, 2009 | 1987 Ford F 150

1 Answer

Altenator is not charging the battery


sir , the altenator has 3 wires at the connector correct ? a white/red , a green/white and a black , the white/red wire is involved with a 10 amp fuse to do with the charging meter / gauge , the fuse located behind left side of dash .. the green/white wire is is involved with 2 fuses , a 10 amp ECU fuse and a 25 amp Main fuse located at left rear of engine compartment main box , and the black wire is involved with a main 80 amp fuse at the main box also . both of these 2 wires end up at the positive side of the battery , please verify all these fuses are good . if they are indeed good , then open wiring would be next step verify continuity on black and the white/green wires . i would post a link to diagram but autozone repair info site is down at this time . if ya need more help , please ask .

Jan 05, 2009 | 2002 Kia Rio

Not finding what you are looking for?
1995 Ford F150 Styleside Regular Cab Logo

29 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...