Question about Mercury Topaz

1 Answer

I have a 1998 Mercury Topaz that starts to miss under acceleration and can hardly make 100k per hour. Ignition system is ok. The problem seems to be in the fuel system. New fuel filter installed and there seems to be lots of fuel going through the filter. Can you suggest something to try?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,305 Answers

Even tho the ignition seems ok, I'd check the ignition cables to the plugs. Sometimes these break down over time... it will idle and drive ok, but when you need power for a hill, or acceration, that's when the wires faults start to show up.
A quick test is to put the car in drive with your left foot on the brake FIRMLY while you press the accerator... if the miss and lack of power shows up, it's usually the ignition cables to the plugs.
k

Posted on Jun 30, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

X5 2001 4.4i - rough on low down acceleration at medium pedal press. idle at accelerate is fine, only under acceleration. At higher speeds is fine and no spluttering. When I put in drive, put foot on...


Sounds like lack of preventative maintenance

Spark Plugs every 3 years or 30 to 40,000 miles

You may have ignition coils failing

Clean MAF Sensor

Replace any O2 Sensors over 100,000 miles

Gas filter every 3 years

Sep 30, 2012 | 2001 BMW 5 Series

1 Answer

While driving when I try to accelerate after 30 miles per hour my car pulsates before picking speed.The car seems like loses speed before it pickup speed.


It's hard to say if this is something more dire than this, but have your spark plugs and wires checked out.

If a cylinder is not igniting properly when you accelerate, it would definitely cause this problem.

I had a car where it would 'jump' when I was trying to accelerate past 30-40mph and switching the wires fixed it right up. Hope this helps!

Mar 13, 2011 | 2003 Mercury Grand Marquis

1 Answer

1987 Topaz, has trouble accelerating.


Most likely it is a transmission problem. Being that old the transmission needs work and possibly the clutch replaced or Throw-out bearing.

May 11, 2010 | 1987 Mercury Topaz 2 Door

1 Answer

1991 Mercury Topaz


I'm surprised there isn't a cover that has the diagram on it but for the fan its gotta be a relay under the hood i'd say

Apr 05, 2010 | 1991 Mercury Topaz 4 Door

2 Answers

Car starts ok, but when i release the key, the car dies. In park, the starter grinds if i hold the key on all the way. In drive, I can hold the key on all the way & starter does not grind. Is this...


First thing I would do is change your fuel filter! This dramatically changes the way a car starts. When key is on, it pumps the fuel, when released, the engine, regulator take over for most part, I would say fuel filter or ignition is bad.

Jan 27, 2010 | 1993 Mercury Topaz

1 Answer

Where is the fuel pump relay located on a 1992 Mercury topaz


the fuel pump relay is located on the left shock tower in the engine compartment in a black box 6x4x1 inches. there are other relays inside the same box which is actually called the ccrm or constant contorl relay module, there should be a double connector with 20 to 26 wires in it, hard to miss.

May 31, 2009 | 1992 Mercury Topaz

1 Answer

1992 topaz turns over but wont start


Ok when you turn the key to start it do you hear a high pitch whine for like 1 to 2 seconds if you do it is not your fuel pump. If you do not hear it then you might be correct. I have never changed it but i believe it is under the rear seat not too certain which side. Before you get that far though have you checked any of your battery components or starter? It may be a simple solution
Good Luck

Aug 12, 2008 | 1992 Mercury Topaz

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

215 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

fordexpert

Level 3 Expert

5495 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...