Question about 1996 Dodge Avenger

1 Answer

1996 Dodge Avenger runs rough

2.5 V-6 Runs fine when cold; after warm-up starts running rough - missing and backfiring.

Posted by on

  • Anonymous Mar 16, 2014

    1996 dodge sratus engine running rough

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 776 Answers

Could be a defective engine coolant temperature sensor -- if it's sending erroneous signals/data to the engine control module, it can cause the symptom you describe (of course there are numerous other possible causes for the symptom you describe. Good Luck

Posted on Jun 30, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Dodge dakota backfire


It sounds like you need a good tune-up, such as spark plugs and/or wires. They will act up when cold and when warmed by engine temperature will let the engine run smoothly again. And possibly a distributor cap/rotor.

Apr 17, 2014 | 1992 Dodge Dakota

1 Answer

Buick 97 lesabre, runs rough when warm


Buick 97 lesabre, runs rough when warm

Jan 25, 2012 | 1997 Buick LeSabre

1 Answer

Ram idles rough at start then fine after warms up


1. Injector cleaner.2. Does it have enough miles (75K-plus) to consider changing plugs?3. What's the air cleaner look like?4. Any codes showing?Here I am trying to give answers when I probably know less than you....Good luck.

Dec 16, 2011 | Dodge Ram 1500 Cars & Trucks

2 Answers

97 cavalier starts and runs ok from a cold start after a few minutes of warm up it starts to run rough and miss. If i try to drive it it will start out ok but won't shift automaticly but shifts fine m


Sounds like possibly more than on problem, crankshaft position sensor, or ignition module likely on starting prob which maybe affecting shifting due to hard code in ecm, or shift prob could be shift solenoid in valve body of transmission. Both parts readily available from local parts store

Nov 27, 2011 | 1997 Chevrolet Cavalier

1 Answer

I am haveing trouble with my 1996 Mazda B2300, When I start my truck after its been sitting for any length of timeI have to rev the engine to get it started, I have to continue reving until engine is warm...


Replace the temperature sending unit/sensor. This sensor tells the computer to put the engine into cold start mode and it then sets idle a bit higher and puts a bit more fuel into the engine to keep it running without having to touch the throttle. Once it's warm, sensor tells computer to go to normal run mode and it's done. No problem.

Dec 19, 2017 | 2005 Dodge Caravan

1 Answer

1990 dodge 360. Runs fine. unpredictable backfire


You want to check your timing for accuracy and then check all plug wires for burned or cracked ends. Also check the single coil tower where the coilwire connects for very small cracks. Then check the inside of the disrtibutor cap for the same small cracks. Throughout this process I'm certain you'll find the culprit. Thanks, Dana

Jan 30, 2010 | 1990 Dodge W250

1 Answer

Runs rough, lags, and will backfire if I push it


This is probably one of four things or a combo thereof...dirty fuel injectors, cracked distributor tower/burned points (if it's not electronic ignition), burned valves or air/gas flow sensor if it's computer controlled (the chip is likely bad).

Jul 21, 2009 | 1997 Dodge Ram 1500 Club Cab

4 Answers

When car is cold it seemingly runs on 3 cylinders


seem like you got the same problem as my scion xa, check the fuel pressure regulater. bad regulater some time smell like leak gas. auto zone might cause you about $80.00.

Feb 09, 2009 | 1992 Honda Accord

Not finding what you are looking for?
1996 Dodge Avenger Logo

Related Topics:

261 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...