Question about 2000 Ford Expedition

2 Answers

2000 ford expidetion , running very rough but doesnt have any error codes ? replaced all of the coil packs and cleaned all fuel injectors --- dont uderstand why there is no check engine light ?

Posted by on

  • mikeshannayo Jun 30, 2009

    sorry -replaced that already as well . made no change in the why it ran.

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 290 Answers

Try cleaning the MAF sensor...it's a cheap route that may fix the issue. Here are some instructions:
http://www.fordf150.net/howto/clean-maf-mass-airflow-sensor.php

Posted on Jun 30, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

You have a vacum leak. mine was same way. its a 90 degree rubber boot that will have a hole the size of your little pinky. 3.99 at autozone

Posted on Oct 08, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2000 ford escort 2.0L. plugs, wires, coil pack, alternator, MAF sensor. hard to start and RPM around 1k wants to die (any stops) always runs rough. Says air intake sensor. catalytic converter or CCRM?


Have you cleaned the throttle body and throttle body valve? have you cleaned the idle speed control air bypass valve? are the injectors clean? Are there any fault codes in memory, do the things I mentioned if you haven't already. Also hard engine mounts can cause roughness at idle. Another thing is the timing belt tight?

Jan 27, 2017 | Ford Escort Cars & Trucks

1 Answer

Both coils do not fire on 1 and 4. Will start but only running on 2 cylinders. Could both coils be bad or should I look elsewhere?


Part 3 -How to Test the Ignition Module and Crank Sensor ...

easyautodiagnostics.com > Ford > 2.3L
Mar 1, 2012 - Spark plugs for cylinders #2 and #3 get spark at the exact same time. ...voltage -12 Volts) to both individual ignition coils within the coil pack. ... Ford Mustang or Ranger (or 2.3L Mazda B2300), this is what you'll need ... for this 'Switching Signal' at the coil pack... but you can also test this ... 1991, 1992, 1993.

How to Diagnose a Misfiring Cylinder (2.3L Ford Ranger ...

troubleshootmyvehicle.com > Ford > 2.3L
Apr 3, 2012 - Bad Fuel Injectors can cause a Misfire Condition. ... the ignition system on the 2.3L Ford Mustang or Ranger consists of 2 ignition coil packs, ...

2002 ranger misfire rough idle - Discussion on Topix

www.topix.com > Ford Ranger
Jul 27, 2007 - My truck is giving the code misfire in number 4 cyl. I replaced my spark plugs, Wires, Coil packs (both of them) and all my fuil ... three (3.0L v6) go bad, the fuel/air mixture gets messed up. Judged: 2. 2 ... My truck runs rough only at idle. ...code for ford ranger 2002, 2.3 5speed. truck runs like a champ but that ...

Extremely stumped! I need the best and brightest 1994 Ford ...

answers.edmunds.com > Edmunds Answers

Jan 31, 2016 | Cars & Trucks

2 Answers

Replaced coil packs and plugs in my 1995 toyota tercel but it still runs a little rough what else can I do to get it back running smooth


coil packs and plugs are half the job
injectors and fuel pressure also are responsible for rough running along with oxygen sensors
Run the fault codes first to check where a problem may be.

Mar 05, 2015 | 1995 Toyota Tercel

1 Answer

What could cause it to idle rough


No codes? In the following order I would clean the idle air control, change spark plugs, check plug wires, check for vacuum leaks, run some fuel injector cleaner through your fuel tank.

May 06, 2014 | 2002 Ford Explorer

2 Answers

The code is # 1 cylinder miss fire. i replaced plugs and wirers still running bad but no code yet


check for spark at the coil, if its weak, or no spark, replace the coil pack.

Dec 03, 2010 | 2001 Ford Windstar

3 Answers

My 2000 Ford Focus SE is throwing a P0302 code for misfire in cylinder 2. We replaced the spark plugs and wires, cleaned the fuel injectors, and checked all fluids. It still misfires and my gas mileage is...


Ignition coil is most likely..clogged injector is uncommon but possible..fuel injector cleaner can only do so much..coil would be the thing to start with..

Sep 03, 2010 | 2000 Ford Focus

1 Answer

Recently I had my 2000 gmc 2500 6.0 liter truck start running rough. I changed the spark plugs, checked the coil packs and replaced the fuel pumpand fuel filter. Still no change....Any suggestions?


ROUGH IDLING CAN BE CAUSE BY MANY THINGS.I AM LOOKING AT LEAKING VACUUM HOSES OR INTAKE MANIFOLD GASKET LEAK.DIRTY FUEL INJECTORS AND WORN ENGINE VALVES WILL CAUSE ROUGH IDLING.ALSO LOW IDLE SPEED CAUSE ENGINE TO RUN ROUGH.

Apr 18, 2010 | 2000 GMC New Sierra 1500

2 Answers

My Oldsmobile 88 Royale is intermittently running rough. I have tried to track down the problem but haven't found it, yet. I got the diag codes from the computer and it showed a 48 (misfire diagnosis. So...


hav u inspected the distributer system--also the ignition module-these things wear car is gitten up there! dont forget fuel delivery pump,injectors etc buy a haynes manual at a parts place

Feb 01, 2010 | 1990 Oldsmobile Eighty Eight

2 Answers

2001 ford 4.6 liter idles rough sometimes dies


may need 1 0r more coil packs replaced,or it could be what happened to my 2000 4.6---1 lifter expanded out and wouldnt collapse,causing the rocker arm to fall out of place and the valve could never open...try unplugging 1 coil pack at a time while running and listen for a change in the way it runs,if there isnt a change then its probably a bad coil pack,find a cylinder that runs and swap the coil packs,if no difference then its probably the valve staying shut.

Nov 21, 2009 | 2001 Ford F150 Styleside SuperCrew

Not finding what you are looking for?
2000 Ford Expedition Logo

Related Topics:

366 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

77499 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

fordexpert

Level 3 Expert

5626 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...