Question about 1999 Nissan Maxima

1 Answer

1999 Nissan Maxima

I have replaced the starter, fuel filter, iat sensor and my car is still hard to start. We tested the fuel pump and it is putting out the right psi. I had the battery and altanator tested and they are fine. I had no problems with my car until the starter went out. It started just fine. At a cold start is takes 30sec to 1 min to get it started once it is warmed up it takes 10 sec or less but it cranks over and over before it starts. It was never like this before. I don't have the money take it to the shop can you please help. We can't figure out what the problem is. We have put a code reader on it several times but it doesn't come up with any codes and the check engine light has never come on.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 750 Answers

Have you tried checking the fuel preasure regulator, remove vaccum line and check if it holds vaccum when aplied withj pump if not the diaphram in regulator is damaged

Posted on Jun 30, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a1999 Nissan maxima and it dies everytime I step on thegas


It sounds like it is fuel related, expecially since I didn't hear any codes mention. A fuel presure check would be a good place to start. The filter could be clogged, but if this goes on too long it just taxes the fuel pump too much than it gets weak...hope this helps.

Oct 19, 2009 | 1999 Nissan Maxima

1 Answer

Starting problems


IF its not a fuel issue as in you checked your fuel pump, fuel filter, fuel injectors and pressure regulator, try having your timing belt looked at. Maybe its time to replace it. Check your crank and camshaft sensors as well.

Jul 15, 2009 | 2000 Nissan Pathfinder

1 Answer

Nissan maxima


bad part bad starter

Jul 12, 2009 | 1999 Nissan Maxima

1 Answer

Hard to start


have u check you spark plug and leads make sure they are not worn out(or when was the last time you change them).or your injector could be block u should get some injector cleaner and pour it in your fuel tank when your next fill ( or get some one to clean them out $30 per injector)

Jul 04, 2009 | 1999 Nissan Maxima

1 Answer

Hard to start


You will only hear the pump for a couple of seconds until it pressures up. Your problem could be a faulty idle control system / sensor.

Jul 04, 2009 | 2008 Mercedes-Benz Mercedes Benz C Class

Not finding what you are looking for?
1999 Nissan Maxima Logo

188 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...