Question about 1998 Chevrolet Astro

2 Answers

Van sputters whenever you go to take off from a complete stop. recently had spark plugs, wires, dis. cap, fuel filter, fuel pump relay, thermostat, heating cooling sensor, mass air flow sensor, iac valve, pc valve, o2 sensors and egr cleaned, new vacuum bulb, all vacuum hoses in tact.

Posted by on

  • jennic Jun 30, 2009

    I have not checked the timing yet. I will look into that.

  • dedhead6969 May 11, 2010

    have you checked the timing

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hi there, i had the same problem with my 98 astro van, and took it to the shop, the computer pumped out a mass airflow sensor, they replaced it at considerable cost lol, but the van now runs good

Posted on Jul 03, 2010

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Have the drive gear on the distributor checked, these are known to wear and cause a timing issue.

Posted on Sep 14, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Car cranks but won't start. please help any ideas


Depending on your vehicle, if it has a distributor. You may have to change it out completely. It happened to me. Changed everything and that was the last item. Worked after that.

Dec 12, 2014 | 1999 Chevrolet Blazer

1 Answer

89 chevy s10 misfires and sputters when i give it gas, dies when i stop. Sometimes it runs fine, but recently it's just been bad. When i rev the engine it can stabilize the idle, but usually die


check fuel pump pressure- fuel filter --air filter --egr valve if carboned up clean or replace and cat converter feel the exhaust if feels restricted may be clogging up

Mar 30, 2013 | Chevrolet Blazer Cars & Trucks

1 Answer

My 94 e 150 Ford van is sputtering sometimes Idel and running how can we fix this I have changed spark plugs wires fuel filter dis cap rotor button


did it happend right after you tune it up if not and it was there before check the egr valve try disconecing it then test drive it if it goes away replace your egr valve let me know if it dont work so i can try helping you

Nov 12, 2012 | Cars & Trucks

1 Answer

My 2002 chevy 1500 van , 4.3 liter v6, will not fire. ran great, no signs of trouble leding up to now. Cranks,cranks, & cranks but no sputter, fire, anything


I would check and be sure I had fire to the plugs and fuel to the throttle body. I read what you wrote about the fuel pump but then on the end of the description where you put gas in the van the pump might not be working. If so you could have a bad wire to the fuel pump or a plugged fuel filter. Once you verify those items I would pull the 02 sensor ahead of the catalytic converter in the exhaust and make sure the cat or muffler is not plugged. If they are it will put back pressure on the engine and not allow fuel into the cyl. to fire.

May 23, 2017 | Chevrolet 1500 Cars & Trucks

2 Answers

Van Sputters And Loses All Power When I Accelerate


Internal combustion engines requires 3 things... fuel, air, and spark. You do not have enough of one or more of these. If the wires and plugs are old, change them.  Air filter, same thing.  Fuel filter can also clog up with stuff after awhile. When you take a look at the air filter check where the air comes from.  It is possible a little critter has built a home and blocked the air flow (rare, but, it has happened).

May 07, 2009 | 1993 Plymouth Voyager

2 Answers

Falls dead when driving, will restart after awhile


Did you try checking or replacing the coolant sensor? I think you should replace it along with the thermostat. Are there any problems like sputtering or any unusual noises or symptoms? Smoke, anything?

May 06, 2009 | 1991 Oldsmobile Cutlass Supreme

1 Answer

1991 Geo Metro Automatic/ Sputters, runs rough only in gear.


Could possible be a bad or stuck vaccum advantace mechanism. Check for operation.

Feb 16, 2009 | 1991 Geo Metro

1 Answer

2001 Chevy Astro Van


Needs Crank sensor. Good luck

Dec 28, 2008 | 1999 Chevrolet K1500

1 Answer

2001 Chevy Astro Van


buy a Honda or Toyota, they work

Jun 05, 2008 | 2001 Chevrolet Astro

Not finding what you are looking for?
1998 Chevrolet Astro Logo

489 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...