Question about 2006 Nissan Armada

2 Answers

Hi All ! My passenger side tail light doesnt work, brake does. Bulb is fine (tried on driver side) fuse seems to be ok....help!! Thanks 2006 armada le

Posted by on

  • 3 more comments 
  • labsgroup Jun 28, 2009

    will try that..Thanks

  • labsgroup Jun 28, 2009

    There is power getting to it. What now? I'm so confused !

  • labsgroup Jun 30, 2009

    Thanks for the help...Yes, the bulb sticks out far enough---still, not working. So frustrating !

  • labsgroup Jun 30, 2009

    I dont thinks thats the problem...Itook the entire unit from the passenger side to driver side and it works.

  • George May 11, 2010

    Does the front one work ?

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 167 Answers

If you have power at the unit then it must be an earth problem .
Check the earth , Try running a wire from the earth terminal to a screw or bolt on the car body .

Posted on Jun 30, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 44 Answers

There could be a bad earth somewhere in there causing it not to work. either that or the light socket itself could be faulty. check the contacts with a multimeter or test pen. check the wiring for any obvious signs of wear or damage and trace it back to where it joins the right side. hope that helps you out a bit

Posted on Jun 28, 2009

  • mutleysdoo Jun 30, 2009

    check that the bulb contacts are sticking out enough to contact the bulb in the socket.

  • mutleysdoo Jun 30, 2009

    how about the contacts in the light socket. maybe get a lil bit of white out and put it on them, then quickly put the bulb in then take the bulb out and see if there is white out on the contacts of the bulb. or u could try with 2 short peices of wire hold them on the socket contacts then hold onto the bulb contacts and it should light it.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2006 Jeep Commander Tail light


The tail light circuit is separate from the brake and turn signal circuit. Either the bulb socket has gone bad or a wire has flaked out. Check for voltage at the socket on either pin base when you have your parking lights on. If voltage is present, it is either a worn socket failing to hold the bulb properly, or another bad bulb. If no voltage, determine which wire on the other side is tail light power, and run a new wire across to the side that isn't working and connect it to provide power.

Apr 09, 2014 | 2006 Jeep Commander

2 Answers

Driver side brake light is not working. Replaced bulb, but didn't need to it is the same bulb that works the tail lights, which still worked. Ugh, 2006 jeep liberty. Someone said it was a brake...


THAT RIGHT IF BRAKE SWITCH BAD NO BRAKE LIGHT WILL WORK.SPRAY ELECTRICAL CLEANER IN BULB SOCKET BULB SOCKET COULD HAVE OXIDATION AND CORROSSION CAUSING POOR CONTACT.

Sep 12, 2011 | 2006 Jeep Liberty

1 Answer

I would like a diagram of the 740 gle 1990 tail light wiring, I cannot seem to get them working correctly


You don't really need a diagram, it's simple. If you open both tail light boxes in the trunk you will see at the connector on the bottom a yellow wire in the first position. That goes to the brake bulb. If both tail lights do not work, make sure you are getting power to the driver side light first, if it is not getting power, the passenger side will not work either, they are in line with each other. If it is only the passenger side not working, the bridging wire could be bad.. try jumping it. Also, make sure you are getting power inside the tail light bulb holder. The metal connections can come loose. If there is no power to the driver side tail light it could be the bulb failure relay, that is the round red relay in the rear left side of the fuse box behind the ash tray/ cigarette lighter below the radio in front of the shifter. You should be getting power to the third brake light in the rear window...that is a different circuit and will not be affected. Try changing out the bulb failure relay, it supplies the power to the tail lights.

Jun 22, 2011 | 1990 Volvo 740

2 Answers

Tail lights work on both sides. turn signal and


Sounds like you need to replace the drivers brake/tail light.

Dec 14, 2009 | 1998 GMC Sierra

1 Answer

2006 Ford Ranger. Rear passenger side tail light


Bad earth connection.Clean or replce wire.

Jun 18, 2009 | 2004 Ford Ranger

2 Answers

Right brake light out; tail light works fine


most rear tail lights and turn/stop lights are the same dual filiment bulb. it is possible for your tail light to work and your brake light not to and still have a bad bulb. I would check the bulb first, your brake light works on the left yes? this would mean that the fuse is fine

Mar 31, 2009 | 2006 Dodge Stratus

1 Answer

Brake light will work but not running light in rear drivers side


change the bulb in the tail light. And check your fuses for the license plate.

Mar 20, 2009 | 2000 Chevrolet Silverado

1 Answer

99 mercury mystide had rear running light broken


If the driver's side tail light is working, it's not a fuse. Use a test light to check for power at the bulb holder. One terminal will be for tail light, the other for brake/turn light. If the is constant power for tail light, replace bulb. If no power, trace wiring from bulb holder to driver's side junction. Probable broken wire between the two tail lights.

Jan 16, 2009 | 1999 Mercury Mystique

1 Answer

Mazda 3 tail light on, brake light not on


The bulb actually has two seperate elements in it.
That is why the tail light works fine.

If you take the bulb out you will see the seperate elements.
Change the bulb and it should be fine.

Jan 09, 2009 | 2004 Mazda 3

1 Answer

Passenger side tail lamp


could be the socket where you put the bulb or the wire that goes to the socket. there could be no power going to the wire.

tnx 4 using fixya,

drcool

Oct 14, 2008 | 1999 Ford Windstar

Not finding what you are looking for?
2006 Nissan Armada Logo

128 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

713 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...