Question about 1999 Ford Taurus

1 Answer

Battery drains with everything shut off car battery is good.

High beam light switch dosn't work; battery started draing after I replaced flasher switch that was not working.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 224 Answers

Have you checked the battery saver relay? It's located in the passenger compartment fuse box underneath the driver's side dash panel (it's just underneath the steering wheel). The lid will tell you which component it is. Relays are about $10.00 at autozone, so you can just pop the new one in if you want, or take it out and test it with a volt meter. If you want to test it, let me know and I'll post instructions.

Posted on Jun 28, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

New Beetle 2002 Hi-Beam lights only flash, don't stay on, what can I do?


I would test the relay to make sure it is still good and everything there is working like it is supposed to. I would also look at the switch and make sure noting came unplugged and it is still in good working order sometimes new parts are still bad.

Jul 26, 2015 | 2002 Volkswagen New Beetle

1 Answer

My 2007 Sebring headlights, signals, and wipers stopped working and I was told it was the multifunction switch. In the process of waiting on part I received a jumpoff because I left many hazardous lights...


Sounds like an alternator issue. Could be corroded wires at the battery also. When the voltage gets low, things like these will shut down first. Having the flasher on for five minutes won't drain the battery. Jumping the battery put it above the shut down threshold. Have the charging system checked, before replacing the multifunction switch.

Oct 26, 2014 | Chrysler Sebring Cars & Trucks

1 Answer

Have a 91 Ford Explorer. Front headlights having issues. Good bulbs I believe. Sometimes when switching between high and low beams on the column, lights would go oput for a moment then back on....


Sounds like it has possibly got a defective multifunction switch,which is part of the turnsignal lever/high beam lever switch. Aside from physically diagnosing the circuit I would say replacing the multifunction switch may take care of your problem.


Hope this helps

Oct 23, 2013 | Ford Explorer Cars & Trucks

1 Answer

CHECK ENGINE LIGHT WONT LIGHT.MUST LIGHT WITH KEY ON TO PASS EMISSIONS .I ALREADY REPLACED THE BULB WHICH WAS BAD'CHECKED CIRCUIT BOARD OK. ALSO TURN SIGNALS WORK NORMAL BUT WHEN YOU PUT THE 4WAY FLASHERS...


Sounds like a crossed wiring connection somewhere, if the four-way flashers are turning on the high-beam indicator. Check all the connectors in the associated wiring harnesses for the instrument panel. Good luck!

Jan 10, 2011 | 1996 Ford Explorer

1 Answer

When i started my the blue high beam light flickered for awhile and then turned off , then the head light automatically would not come on only manually.Now the tail lights will not shut off! I disconnected...


Not knowing the year make or model car i can only guess here, but it sounds like the switch may be bad, try unconnecting the connector from the switch and see if the tail lights shut off, the flickering high beam indicator may be due from a faulty switch or high beam relay but if all works manualy i dont think its the relay.

Oct 04, 2010 | Chevrolet Prizm Cars & Trucks

1 Answer

My high beams dont work.


high beam switch is faulty look at getting a new stalk.....

Aug 25, 2009 | 1990 Toyota Land Cruiser

3 Answers

High-low beams not working


Check for headlight relay and fuse. Some cars have separate circuits for head light flasher and normal high/low beam. From your description, I would suspect a bad connection to/from relay or relay itself.

Jul 07, 2009 | 2006 Hyundai Accent

1 Answer

High beams dont work


Could be that your high beam light's are burnt out and need to be replaced. When you say the the switch is new you mean the lever on the stearing collum is new right?? Good luck

Apr 06, 2009 | 1998 Pontiac Sunfire

1 Answer

Headlights staying On


You probably have a faulty sentinel switch. It's supposed to shut off, has a bult in elctronic timer. Does it even have the sentinel switch?

Mar 03, 2009 | 2002 Ford Explorer

Not finding what you are looking for?
1999 Ford Taurus Logo

155 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...