Question about 1987 Oldsmobile Cutlass Supreme

2 Answers

The tempature light came on and the car started smokeing

Posted by on

  • ccn7 May 11, 2010

    White or blue smoke?

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hey person..... prob you dont know much about cars but....
haha thats basic.... your car is missing some whater try looking where to put it .... and therefore the tank radiator tank might be broken...
if thats what happen... just put some water on the deposit
[its the tank on the left] sillerla_93@hotmail.com

Posted on Aug 12, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,056 Answers

You may have a busted radiator hose, or a leak somewhere. Overheating can also be caused by a clogged up radiator. The sypmtoms of clogged radiator is overheating at higher engine speeds, such freeway driving, but street driving is okay. The first thing you should be concerned right now is do not use the car untill the overheating problem is fixed, because overheating will surely damage the engine. Second, check to determine if there is no major damage to the engine at this point. Check your oil conditions. If its milky in color, which I hope is not. If it is milky in color thats a major repair, that cost a lot of money. I hope that everything is still okay on the engine, get the overheating problem fixed first which is a lot cheaper than replacing a bad engine, before you use the car again. Hope this is helpfull for you.

Posted on Jun 27, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 E320 I TOUCHED THE POSITIVE POST OF BATTERY TO THE MEDAL PART OF CAR


the e320 has been known to have elect harness problems the insulation that was used deteriorated and wires were shorting out and or melting the whole harness ---the other is your bcm [body control module ] is damaged or gone bad but look into the harness first

Jul 24, 2015 | Mercedes-Benz E320 Cars & Trucks

1 Answer

2001 Mazda MPV overheats. radiator hose doesnt feel pressurised ie very soft to squeeze. when i put coolant in after 5 mins of driving is backflows out of the reservoir and causes heavy smoking from t


at first,try to add coolant slowly to the radiator not to the reservoir,then start the car ,keep adding coolant on it ,until it is very full.u should see the radiator fan should be also running ,then that is the right tempature.drive a little bit & observe the tempature is the normal or not."""but if u have a coolang pressure tester""",u should do a pressure test & see any leak.it might somewhere in cooling sytem leak.hope it wasn't too late,it might cause head gasket burn,it will turn out a big job.

Jan 27, 2014 | Mazda MPV Cars & Trucks

1 Answer

1998 Sebring overheated, wont start


Is it possible you blew the head gasket and now you don't have compression on all cylinders ?

Jun 25, 2013 | Chrysler Sebring Cars & Trucks

2 Answers

97 mercury grand marquis wont start after warming up


You need to determine if it is fuel related or spark related. I have seen everything from a pick up screen in the tank to a crankshaft position sensor. Check the fuel pressure when the no start condition occurs, check for spark at the coils. Does all your electrical equipment in the car loose memory?

Mar 25, 2013 | Mercury Grand Marquis Cars & Trucks

2 Answers

Smell of coolant and smoking


smoke from exhaust could be cracked head or blown head gasket but normally when one of these two things happen it runs crappy if it runs at all smoke from under the hood you may have a pin hole in your radiator or hose or even heater core put some stop leak in it watch for puddle of anti-freeze under the hood and on the ground keep a close eye on your tempature gage and a close eye on you anti-freeze levels and dont add fluid when the motor is hot this will crack your heads good luck.

Dec 21, 2012 | 2003 Dodge Neon

1 Answer

HELLO I GOT A ISSUE WITH MY 1996 BUICK LASABRE ITA START FINE IT DRIVES FINE UNTIL IT REACHES THE NORMAL TEMPS OF 195 200 DEGREE AND ITA SPUTTER AND STALL OUT IT WILL NOT START UNTIL THE MOTOR COOLS...


the one thing in your statment is the knockes/knocking this what is known as the big ends and indicates the engine is under pressure and needs a lot of repair.If when you start the engine when cold if you stand at the back of the car and if the smoke coming out of the exhaust has a blue tint/ie like a old ladys hair tint ,as im sure you will see.[bottom line] the engine needs replaced.adrian,,,,

Sep 02, 2011 | Buick LeSabre Cars & Trucks

1 Answer

Engine runs fine, no problem want's tempature is


I had a similar problem with a Ford Excursion, it turned out to be intake manifold gaskets. It would stall then start right up again, it ran fine during warm up. But, once fully warmed up it would stall at stop lights and stuff like that. I did get a check engine light, the code was lean condition. I don't know on a Jeep, sorry I can't be of more help.

Dec 17, 2009 | 1998 Jeep Grand Cherokee

1 Answer

My 2000 VW Cabrio tempature light is flashing. I


you will probably need to replace the tempurature sensor it's self the car is not actually getting hot.

Oct 02, 2009 | 2000 Volkswagen Cabrio

1 Answer

Car runs rough when hot


mixture control black smoke is rich mixture ,but sorry not sure what or where the control is weither its a sensor or a ECU fault. most likely cause is the autochoke staying can only sugest the main agent or a decent garage who have some test equipment .if you see any sensors in or around the top of the engine try disconnecting them one at a time and see what happens if it stops,and engine will not start when its cold then you have found the problem .

Nov 11, 2008 | BMW 525 Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

138 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...