Question about 1991 Chevrolet S-10

1 Answer

My s10 wont idle but will run hard when i give it gas. i replaced the fuel pump,the tps, distributor and rotor. sounds like its missfireing. last week it ran fine. also the injector keeps pumping gas into the carb.

Posted by on

  • airelandjr26 Jul 03, 2009

    single point injection. 1988 pickup 2.5l 4 cylinder manual trans.

  • Colin Stickland
    Colin Stickland May 11, 2010

    what is a chevrolet s 10 and what year is it ,mono point injection ?? more info please

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I had the same problem in an 88 s10 with the same engine. i replaced the EGR valve and haven't had a problem since.

Posted on Jul 06, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1991 s10 falls on it face when i give it gas replaced tps temp cap rotor plugs and wires


Fuel delivery problem, or bad vacuum leak at gaskets, or vacuum hoses causing terrible fuel-air mixture. You will need a repair manual to be able to read codes and understand the ECU error codes, but it may help you understand the issues.

Apr 14, 2015 | Cars & Trucks

1 Answer

89 chevy s10 misfires and sputters when i give it gas, dies when i stop. Sometimes it runs fine, but recently it's just been bad. When i rev the engine it can stabilize the idle, but usually die


check fuel pump pressure- fuel filter --air filter --egr valve if carboned up clean or replace and cat converter feel the exhaust if feels restricted may be clogging up

Mar 30, 2013 | Chevrolet Blazer Cars & Trucks

1 Answer

Car dies when running and wont start again, i spay starting fluid in the throtle and it starts but if i let go of the gas it dies again and i can't start it normaly, fuel pump about 4 months old, new fuel...


Sounds like throttle position sensor to me. It will let engine go dead instead of maintaining an idle rpm. Try disconnecting battery,and after leaving disconnected for a couple of minutes,crank vehicle and maintain a steady rpm with gas pedal. Doesn't have to be revved up high just steady. Called relearning tps. Sensor might be bad but I would try this before buying a part first.

Feb 16, 2011 | Buick Roadmaster Cars & Trucks

2 Answers

1989 chevy s10 4.3L 4x4 (automatic)Truck idles and runs great when cold. As soon as it reaches operating temperature It acts like it's not getting enough fuel. It will have an erratic idle and when I...


Chances are you have an oxygen sensor problem. When the engine warms up, the engine computer moves from open loop operation to closed loop, and it then uses the O2 sensor readings to adjust the fuel. If the sensor(s) is contaminated, it will send a false reading to the computer causing this problem.

Mar 11, 2017 | 1989 Chevrolet S-10 Blazer

1 Answer

My 99 blazer s10 wit 4.3 engine at idle lopes or skips changed injectors,fuel pump,tps sensor thermostat,egr is workin,tuned up plugs wires cap rotor,fuel ,air filter, had inte man resealed,brougt it to 2...


replace the electric part of the ignition down on the steering colum ....u will have to drop the steering colum down but not totaly remove...fixed 2 s-10 trucks same year that way

Nov 26, 2010 | 1999 Chevrolet Blazer

3 Answers

My S-10 keeps giving a P0300 dtc. Can't figure out what is setting this code. Usually misfires at idle. Any suggestions?


if u change plug wires ,coils ,plugs and still having problems check the injecter with a pulse light the one that dont pulse the pcm is bad are broke wire if all of them are pulseing then change the injecter.had the same problem on a 2000 s10 2.2

Apr 27, 2010 | 2000 Chevrolet S-10

Not finding what you are looking for?
1991 Chevrolet S-10 Logo

Related Topics:

455 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6918 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...