Question about 1999 GMC Sierra

1 Answer

Rough idle I have a 99 GMC Suburban I replaced the plugs,distribator cap,and roter button, and it is still running rough and now it gets a back fire when put into gear. I read codes says O2 sensor heater circuit malfunction (bank 2 sensor 1) Is this part of my problem?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 216 Answers

Yes bad o2 sensor,check for vacuum leaks also.do you cross your plug wires?

Posted on Jun 26, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1993 gmc suburban rough idle, stall in reverse


Idle air control (IAC) control rpm idle during idle.

Test it on idle with ALL electrical on full force.
RPM should increase.
If RPM remain the same then IAC is question.

Jan 13, 2014 | 1993 GMC Suburban

1 Answer

Rough idle on cold start up 1992 suburban


Check the idle air control on the throttle body it is on when the engine is first started stays on until the engine is warmed up.

Apr 12, 2017 | 1992 Chevrolet Suburban

1 Answer

4.3 running rough after tune up


THE FIRING ORDER MOST LIKELY IS WRONG,UNLESS U CRACKED THE IGNITION ROTOR WHEN INSTALLING

Sep 12, 2012 | 1999 GMC Jimmy

1 Answer

1997 gmc yukon backfiring and running rough


need to check engine compression, possible you have a burnt valve, also double check your firing order on plug wires on dist. cap

Sep 03, 2012 | 1997 GMC Yukon

1 Answer

I have a 99 suburban just replaced the dis cap rotor plugs wires fuel pump fuel filter fuel relay. It ran great after all this then it will start running rough and die if i let it sit for awhile it will...


Hi, I believe you hit the nail on the head. Black stuff in the filter Meaning that there is something in the tank. You have to drop the tank and clean it out. Good luck.

Aug 03, 2011 | 1999 GMC Suburban

2 Answers

Cant get no fire/replaced distributor /cap and roter replaced crank sensor and coil put wires and plugs { and still cant get fire to distributor} 1996 gmc/1500 5.7liter


if i understand u correctly u replaced the distributor and cap if so i would start with making sure my pick up coil was installed correctlyand or replace it.i also would look at the possibility of it being a powertrain control module or neutral safety switch if this vehicle is equipt with one. hope ive been helpful

May 15, 2011 | 1996 GMC Sierra

3 Answers

Rough Idle when cold runs seems to run ok hot but still almost stalls when you turn on AC and you are at a stop also noticed that the volt meter reads 9v with the AC and the lights on with the AC and...


mcdevito75 here, Sounds like a faulty voltage regulator, it"s 1 unit with the alternator, change the alternator, also the alt. supplies juice to the ignition switch, distributor abd plugs, thus a rough idle due to bad alternator.

Jun 19, 2010 | 1994 GMC Suburban

1 Answer

87 gmc sub runs for a while then dies


I had a 99 Suburban that did almost the same thing, it turned out to be the Catyletic Converters were plugged. Try taking the exhaust pipe loose at the manifold for test purposes. If it runs good with the pipes loose, that's the problem. Replace the Cat's. There were no codes for either, it would start and run nice for about 5 seconds, then run rough and then stall.

Jan 23, 2010 | 1987 Chevrolet Suburban

1 Answer

Rough idle and accelleration in my 89 GMC truck with a 350 TBI


Try a new distributer cap and rotor button,these are notorious for wearing out the carbon pick-ups and leaving carbon tracks in the cap which messes up the fireing order.If that does'nt fix it try plugs and wires.

Nov 08, 2009 | 1989 GMC Sierra

Not finding what you are looking for?
1999 GMC Sierra Logo

433 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...