Question about 2003 GMC Envoy

1 Answer

I recently installed a new car radio The back of radio gets very hot not just warm but hot checked wiring.and fusses ?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 109 Answers

It is not unusual for a radio to get very hot. Internal amp is releasing heat

Posted on Jun 27, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

98 ford 150 4x4 Starter staying engauged! Is there any way I hooked up a wrong wire in my new radio installation that would cause that to happen? It was fine until I installed my new radio and now the...


You are some how putting power to the switch side of the solenoid on the fire wall. Take a test light and check the S switch side of the solenoid, it should only be hot when the key switch is turned on. It you have crossed this wire inside them you may be making this wire hot all the time. I would re check how you wired your radio.

Dec 31, 2014 | Cars & Trucks

1 Answer

Dash clock and radio will not turn on--HELP


The radio has three hot wires yes three, one is always hot this keeps the clock and your preset stations. one comes on when you turn the radio on and one comes on for a powered ant or an amp. Plus some radios have a ground wire and also ground through your ant. check all theses. And if you still can not get it going come by.

Feb 26, 2014 | 2003 Hyundai Tiburon

1 Answer

I recently had a after market stereo, Amp and bass box installed now my AC,Heater and vent blow out of the top dash defrost vents and not the ones facing the driver and passanger. I checked all the fusses...


Check for a vacuume leak, a small broken hose around the radio or heater controller or around the engine bay. Those snap real easy when they get old and maybe when they ran the wire from the battery or around the radio one got pulled out or snapped. Good luck..

Nov 10, 2012 | 2000 GMC Yukon XL

2 Answers

I have a 1999 ford mustang and the radio stop working. I think its the fuss. but the fuss panel is not marked. were is the radio fuss.


best way to do it is to get yourself a pair on needle nose pliers and start pulling fuses one at a time.

Jun 28, 2011 | Ford Mustang Cars & Trucks

1 Answer

I have an 2002 nissan centra I got a new stereo deck so I went and bought a wiring harness to install it, I matched all my wires by colour accordingly but I get no power at all!!.. There is one wire left...


Check all the fuses to see if they have power. I think the fuse your looking for is in the box under the hood by the battery. I recently had the same problem and had to tap into the big blue wire by the in the car fuse box to get the constant hot to the radio.

Nov 16, 2010 | 2002 Nissan Sentra

1 Answer

Installed a new radio now I don't have inside dash lights


Your old radio had at least 2 power wires, some had 3. One of them stays hot all the time for the clock and radio presets, the second is hot when the key is turned on. And the third is hot when your dash lights are on. If you get these mixed up when replacing the radio, you will have this problem. Most of the dash lights on a GM are under the taillight fuse. I would check them all with a test light. Make sure you are not powering your radio from this circuit. You don't want to dim your radio.

Mar 11, 2010 | 1989 Chevrolet Camaro

1 Answer

Hi I just recently got a Pursuit auto starter installed into my 2007 Toyota Camry but the radio does not come on until I insert the key into the ignition and turn the car on was it installed wrong


THEY DIDNT CONNECT THE HOT WIRE LEAD.. IT'S A SIMPLE FIX BRING IT BACK. OR U CAN LOOK AT THE WIRING UNDER DASH SEE IF SOMETHING CAME UNPLUGGED OR IS THER A LOOSE WIRE HANGING

Aug 04, 2009 | 2007 Toyota Camry

1 Answer

Dash light not working


The light that your having a concern with all appear to be part of the headlamp switch dimming circuit. Check the radio wiring again and make sure it was not wired into the the incorrect power wire that had to do with dash light circuit.

Mar 27, 2009 | 1998 Toyota Corolla

1 Answer

Dash lights wont hardley dim.


sounds like you have burnt through the insulation of two or more cables and they are fused together in the loom .Start looking from radio back

Jan 29, 2009 | 2000 Chevrolet Blazer

2 Answers

Wont hold charge in expedition


  1. Check the wiring of the new radio installed as follows..
  2. Disconnect battery ground
  3. verify radio ground wire is grounded to metal
  4. verify radio hot wire (normally red and thick) is connected to a power source that is off when the ignition key is in the "off" position.
  5. verify that the always hot wire is connect to a constant 12v power supply even with the ignition off.
  6. make sure the pwr antenna wire if not used is taped at the tip and not touching any metal.
  7. verify that all speaker wires are connect correctly and not shorted to ground.
  8. connect battery ground you may get a small spark if your courtesy lites work.
  9. start engine verify your battery is charging by disconnecting the battery ground cable while the engine is running, it should continue running if it don't, alternator maybe bad.
  10. If it continues running problem solved..

Nov 11, 2008 | 1987 Ford F 350

Not finding what you are looking for?
2003 GMC Envoy Logo

Related Topics:

80 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...