Question about 1988 Subaru XT6

1 Answer

Runs great til it warms up

Recently cars run fine til water temp get to where it suppose to be than wants to bog out like no power un less i tap on gas few times

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 41 Answers

Could be the engine temperature sensor faulty. Replace

Posted on Jul 06, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is my 99 dodge intrepid steaming after warm up then cuts off til cool


Which engine, 2.7L?? Is it full of coolant?? If the water pump has failed, it a pretty expensive repair.

Aug 10, 2014 | 1999 Dodge Intrepid

1 Answer

Gmc idles rough in cold weather


Check the coolant temp. sensor (It controls warm up RPM, open loop ECU mode) And change the fuel filter every 20,000 miles to prevent water in filter from freezing ( fuel starvation).

May 29, 2017 | 2005 GMC Yukon

1 Answer

Ram idles rough at start then fine after warms up


1. Injector cleaner.2. Does it have enough miles (75K-plus) to consider changing plugs?3. What's the air cleaner look like?4. Any codes showing?Here I am trying to give answers when I probably know less than you....Good luck.

Dec 16, 2011 | Dodge Ram 1500 Cars & Trucks

1 Answer

Runs fine til the temp out gets hot enough then dies. Wait ten mins and it will start again and run for a few mins then dies again


you didn't say if it was hot on the temp gauge? no matter, it sounds like you have a stuck t-stat. when the engine is cold, a mechanical valve keeps the water from coming out of the engine block until warmed up, then opens and lts the cooler water in. this cools down the engine and the colder temp of the water shuts the valve again. this happens constantly while the engine runs, and if your t-stat is stuck, the engine heats up the water in the block, but with nowhere to go, simply overheats the motor. a good repair book will locate the thermostat housing for you and should you the repair procedure. (i assume you have checked the water in the rad. low water will give you same symptoms). good luck.

Jun 10, 2010 | 1998 Chevrolet Express

2 Answers

1995 Lexus SC300 looses power as temp increases.


could be clogged cats or may even be bad crank sensor.

Jul 06, 2009 | 1992 Lexus Sc 300

1 Answer

Car drives and shifts OK then out of the blue bogs down and has no power exhaust manifold glows orange. After cooling the car runs and drives fine. Cat converter replaced and flow tested car drives fine...


disconect trany solenoids if you can test it at lower speedsi,,distribuitor may go crazy ,like high voltage going to wrong wires so change that if it is easy enough,fuel pressure regulator may play a roll or coolant temp sensor under the distributor also

Jul 01, 2009 | 1992 Honda Civic

1 Answer

1989 pontiac gta won't start when hot and runs bad after warm


i melted my module off of mine 89 gta once on my disturbertor and also had the plugs that snaps onto the coil pack cause a lot of problemns because it wasn't snapped all the way don on the coil pack not the plug wires but the wiring harness plugs and it gave mne a lot of problems.may want to check yourself took it to a dealer ship 4 weeks in a row and every time they said it was fixed i drove it for a couple hours and it would quit and not start and that was all it was but it started with a tune up wires, cap ,rotor button.

Jan 29, 2009 | 1989 Pontiac Firebird

2 Answers

98 chevy 1500 loses power


This sounds like the exhaust is the prob. My guess is the convertor! Frankster016

Oct 25, 2008 | 1998 Chevrolet K1500

1 Answer

Saab 2.2tid car loses all power when warm, rev counter goes to zero


Check fuel feed is ok and fuel pump pressure also check cold start injector could be running on this til warm.

Sep 16, 2008 | 1999 Saab 9-5

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...