Question about 2001 Kia Sephia

1 Answer

My car doesn't charge.

I've replaced both the alternator, and the battery with tested good new ones, and my car still doesn't charge. It starts and runs fine, but gets no power from the alternator it seems. I even ran new cable from my alternator to the battery.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 149 Answers

Make sure that alternator is grounded good. Outside of that I can't think of anything else.

Posted on Jun 28, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Battery doesn't charge


It doesn't affect the charging. Have your alternator tested. If it is good, check connections between alternator and battery, and check all fuses.

Feb 18, 2013 | Cars & Trucks

1 Answer

My 1996 Nissan Maxima's Alternator


Just because they're new doesn't mean that they work. I would find an auto parts store that does free electrical system checks before spending a dime elsewhere. I've gone through 4 batteries in 3 years because of bad products. And have most recently had to replace a brand new alternator because it, too, was defective.

Aug 07, 2012 | 1996 Nissan Maxima

2 Answers

My battey light is on in my 2001 oldsmobile alero


Did you have the charging system and battery checked first before you started throwing parts at the car? Because I'm start to think that its in the wiring from the alternator to the battery (if the alternator was tested good). the symptoms are pointing to a bad alternator with the car not running after a jump. (the car is running off the battery which doesn't have much a charge and then it dies when the battery voltage drops too low). I would bet that your ignition wire to the alternator is bad (or signal wire) which tells the alternator the car is on and to start charging. I had a similar issue with my Honda and only a technician who rebuilt alternators was able to show me how to test it. Seems like you have a similar issue. Have the alternator and battery tested at any local Autozone and if they both test good I would start with the wiring as I suspect this is the issue you have. One of your alternator wires is the ignition wire which puts 12volts to the alternator (turning on the charging) to allows it to put out voltage to your battery.

Nov 14, 2011 | 2001 Oldsmobile Alero

1 Answer

I have an '05 Honda Civic, and we thought the battery was gone. We jump started the car, and drove it home. We fully charged the battery, but it still doesn't start. Lights are funny, and while...


if your seeing 12 volts after the charge, it doesn't mean the battery is good,, a single cell thats bad in a battery will give you fits and produce the problems you listed,, remove the battery , and have it LOAD tested, that way you will get a true correct reading, a battery can show `12 volts, but a bad cell will not let it charge to the correct amps it needs to start the vehicle. once you've done that , and your sure you have a good battery ,, start the vehicle,, ( make sure that when you replaced the battery , that all the connections are clean and tight) with a meter, place one lead on each battery terminal, you should get a reading between 13.5 and 14.5 volts, if you do , then your alternator is doing its job, if not,, replace the alternator, ( your vehicle doesn't have a generator)

Sep 18, 2011 | 2005 Honda Civic

2 Answers

Battery tests good & alternator tests good on 2002 buick lesabre. keep charging battery and then it does start, but not after driven for about 20 miles, then it won't start again.


Hook a digitalmeter to the battery in your driveway while the car is running. It should read 13.5vdc. If it doesn't, something is pulling it down. We can start there. Looking forward to hearing from you again.

Jun 06, 2011 | Buick LeSabre Cars & Trucks

3 Answers

Inconsistent charging voltage (12-13.5 volts). Had alternator rebuilt and checked good on bench. Still not charging correctly


I would guess the alternator is trying to run a maximum capacity, thats usually why they get hot, if you put the alternator on, take it back to the parts place you got it and have them warranty it, if you had a shop do the reapirs a year ago, you should still have warranty on it.. ps the light may flicker if its overcharging as well as undercharging. usually the regulator internally is bad.

Good luck.

Apr 22, 2011 | 1995 Jaguar Vanden Plas

1 Answer

Battery keeps drianing alternator test good but have a short in the engine ignitin feed


Even though the alternator tested good it still may be your problem. Unhook the alternator power wire and let the car set for the amount of time it usually takes to run down the battery. If it starts right up, you've found your problem. If that doesn't help, sometimes a relay can stick and cause a draw on the battery. You might try the same thing with the relays, pull them out and let it set. Replace them and see if it starts.

Apr 21, 2011 | 1996 Plymouth Neon

1 Answer

Ive got a 1991 Eagle talon turbo with 5 speed trans,ive replaced the battery and alternator and still wont charge?


If you know for sure that the alternator is good then use an Ohm meter to check set to DC 20 when the car is in the ON position but not running. Unplug the alternator and put the red end on the positive side of the alternator plug and touch the negative to any other metal surface. Should be the same reading as your battery is when you do the same test on the battery. If not, then the wiring is bad and needs to be replaced.

Just because something is new doesn't mean it works so if this test doesn't work, take out the alternator and have it tested.

Also check fuses!!!

Sep 16, 2010 | 1991 Eagle Talon

2 Answers

1995 nissan pickup new alternator and battery


it is problem with main +ve supply for alternator from battery, fix new wire to alt to batt only for +ve supply and then try ,it will start charging,if it wont charge then problem with instrument cluster, only two could be cause.

Jan 24, 2010 | 1992 Nissan Pickup

Not finding what you are looking for?
2001 Kia Sephia Logo

Related Topics:

311 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8215 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...