Question about 2004 Nissan Maxima

1 Answer

Tap sound from my engine on a cold start and when

Tap sound from my engine on a cold start and when it's warm. Does this mean I will change the tappet valve or perhaps the belt is bad. Moreover, is it timing chain Nissan Maxima has or timing belt. Please I need your immediate response. Thanks for your contributions

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 216 Answers

Try changing to an heaver oil first,if your using 10-30 go to 10-40,see if this helps,before looking at the valves.

Posted on Jun 28, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Slight tapping noise from engine when accelerating when engine is warm.Started about 3 days ago but hasnt got any worse.Doesnt do it when cold.


tap usually associated with lifters when vehicle warms up oil thins out and a bad or worn lifter will make a tapping noise --other oil level low --oil needs changing --low level will starve rockers/push rods/and lifters which will also cause tap ---damaged /dirty{sludge oil can cause same problems

May 24, 2016 | Cars & Trucks

1 Answer

Bottom falls out of idle after revving engine cold


Its probably a problem with the water temperature sensor. Also do not rev a cold engine. The engine has a "cold start sequence" which is similar to a choke. When the engine gives a cold signal, the fuel mix is made richer and the timing is changed until the engine warms.

Let the engine warm at the preset factory settings. Sometimes the O2 sensors will cancel the cold start sequence before the water is warm. Racing the engine will warm the O2 sensors too quickly.

May 14, 2014 | 1993 Mercury Grand Marquis

1 Answer

Mine is a 1991 ranger


Hi there.
From the info you sent was all the same problem and that is the wire harness between engine bay and rear lights has a brake in it which sounds like burnt out on the exhaust or rubbed on a U bolt in the chassis find it and you have found your problem ,except the heater that could either be a fuse / heater tap witch is in the heater pipe from engine to heater going through the firewall and is either operated by either air pipe or a cable in dash.
Start engine run to warm and check the small heater hose and it should be warm one side of tap and cold other side ... answer get new tap.

Apr 24, 2014 | 1991 Ford Ranger Supercab

1 Answer

Misfires when cold


Just means it isn't warmed up yet when sputters and misfires. Most likely a bad connection on the temperature sending unit in the engine or that sending unit is faulty. This sending unit tells the computer when engine is warm or cold and has to be functional. When working properly, it tells the computer to put engine in cold start mode, which it is not doing. The sensor is stuck in open position or warm mode and not giving the engine enough fuel when cold making it misfire and sputter. Fix that and you'll have no other problems with revving either.

Mar 07, 2014 | 2005 BMW X5 4.4i

1 Answer

I have no heat in my 2002 Dodge Stratus. I have changed the thermostat and flushed the heater core? What else could this be?


See if your library has a Stratus shop manual and check the heating system chapter. You didn't say if the engine was reaching operating temperature or not. If the engine is warm but you are not, I would say the problem is in the heat exchanger somewhere. If your engine is cold, you can't really expect the heater to get warm, now can you. Then you have a different problem to chase.

Lack of water on your floor means your heater core is not leaking. It could still be plugged somewhere. The fact that you get some heat initially, but it turns cold when you turn the fan on, sounds like a lack of adequate warm water to the heater core to me. If the engine is warm, it could be a circulation problem of some sort.

Nov 06, 2012 | 2002 Dodge Stratus

1 Answer

97 acura 3.2 tl temp gauge doesnt read anything stays at cold doesnt move at all, whats could it be???


Your thermostat which closes when cold to let the engine warm up and opens when the water gets hot and lets it circulate through the radiator. If they stick closed your engine overheats in short order. When they stick open it takes forever and a day for the heater to warm sufficiently. This also makes the engine use more fuel. If your thermostat is indeed stuck open it is easy to tell. With the engine cold, take the radiator cap off and start the engine. If it is stuck open water will immediately circulate as seen at the radiator cap opening. If the thermostat were operating normally you would not see water moving for 5 or more minutes of idling. You should always drain the coolant, flush and refill every 2 years. Never ever grab that garden hose and put tap water in your radiator. They come from the factory with distilled water (about $1 a gallon at any grocery store) which has no minerals in it. The minerals in tap water promotes rust and scale build-up in the cooling system reducing it's efficiency. Don't use tap water unless you WANT to have problems.

Jan 03, 2012 | 1998 Acura TL

1 Answer

NOISE WHEN COLD THEN GOES AWAY WHEN WARMS UP,SOMEONE SAID MAIN BEARINGS GOING BAD


Hard to say over the internet but I will try to explain. If the noise is a distict KNOCK KNOCK and it sounds like it is coming from the bottom of the engine, then it most likely is a rod or main bearing. If it is a TAP TAP noise that sounds like it's coming from the top of the engine, then most likely a valve lifer is failing/failed.
the fact that it goes away when the car is warm, makes me lean towards a bad lifter. Normaly if a bearing is bad and knocking, the noise doesn't go away.

The KNOCK noise will be somewhat hollow sounding and the TAP TAP sound will be more solid. If the KNOCK KNOCK is solid, then a rod or main bearing has most likely failed to the point that a new/reman engine will be needed.

Jun 14, 2011 | 1994 Pontiac Grand Prix

2 Answers

2006 Dodge Grand Caravan with 3.8L engine. When engine is cold and especially when outside temperature is also cold, the normal engine sound is a loud whine that varies with engine speed. When the engine...


could be cold oil in the power steering making the pump whine or in the transmission
may be a transmission oil change or pump oil change could point to the problem

Nov 19, 2017 | 2006 Dodge Grand Caravan

Not finding what you are looking for?
2004 Nissan Maxima Logo

Related Topics:

288 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...