Question about 1995 Chevrolet Blazer

1 Answer

95 s-10 blazer idles rough

95 s-10 blazer 4wd. idles rough but runs smooth once you get going

Posted by on

  • 2 more comments 
  • blue_eyes_of Jun 25, 2009

    When i took it to autozone the random misfire code is the only one that comes up.

  • blue_eyes_of Jun 25, 2009

    we have already did that

  • blue_eyes_of Jun 25, 2009

    what is an ect sensor and where is it located at

  • yadayada
    yadayada May 11, 2010

    ANY SYSTEM TROUBLE CODES?

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 79,865 Answers

CHECK FOR A LEAKING INTAKE MANIFOLD GASKET, USE A CAN OF CARB SPRAY AND SPRAY AROUND THE TOP OF THE ENGINE, IF U HIT ON A LEAK U WILL HEAR THE ENG CHANGE TONE AND IDLE RPM.

Posted on Jun 25, 2009

  • yadayada
    yadayada Jun 25, 2009

    THEN CHECK THE ECT SENSOR AND CLEAN THE FUEL INJECTORS ALSO CHECK FOR INTAKE LEAKS

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

89 Toyota 4WD 22RE runs smooth at RPMs above 1500 but real rough idle specialy in cold climates , help please ?!


Hi there I have a 96 toyota 3.4l although not same than yours, all problems related to idle in earlies toyotas are only about 3 things:

Air
Fuel
Ignition

I did all this on mine and niw is smooth and believe it or not rough idle was going away as I was fixing more ..

I rechecked all vacuum lines And replece a few they were cracked plus I added clamps to all the hoses to make sure no leaks

Replaced f injectors with reman. From toyota

New ign wires and spark plugs

New air filter

New fuel filter

And I remove 02 sensor resistance (5 to 14 range means they are good)

And I left them soaking in gasoline one day and I brushed them witg dremmel tool after checking they are good


I APOLOGIES 4 too long story but now my pick up it runs Smooth and fuel consumption is what is supposed to be

I hope this helps somewhat...

Dec 20, 2017 | Toyota Cars & Trucks

1 Answer

96 4x4 Blazer runs rough when you first start going ,when you give it the gas it's having a hard time ,but smooths out ?only low RPM


Very common problem the fuel pressure regulator under the plenum is leaking and causes a rich running condition on start ups and if bad enough can cause it at idle all the time

Apr 18, 2015 | 1996 Chevrolet Blazer

1 Answer

My Blazer will idle rough on startup but is ok when the engine is speed up beyond idle.If I disconnect the MAP sensor the engine runs smoothly.Also once the engine has been run for a while,it will idle...


Lately there has been alot of questionable fuel going around, I'd start by running a good fuel system cleaner through it and change fuel filter. Another question for you... when was last tune up? plugs, wires, all fluids & filters? I would get the basics on a "ground zero playing field" before unplugging electrics to diagnose - that will usually have you chasing ghosts and throwing parts at an easy fix.

Apr 05, 2011 | Chevrolet Blazer Cars & Trucks

2 Answers

91 chevy silveraldo 4x4 wont engage


Hi and welcome to FixYa!
As a first course of action I strongly suggest that you replace the transmission fluid. If the transmission fluid is burnt it tends not to engage, will surely run rough and may cause to shifting failure.

Once the transmission fluid is replaced, a smooth run and shifting will be noticeable.

Hope this helps and thank you for using FixYa! Have a good one!

Feb 16, 2011 | 1989 Chevrolet S-10 Blazer

1 Answer

I've got an 2003 blazer 4wd with a 4.3L. It idles rough once above idle its fine. Its not missfiring. The distributor, cap, rotor button, plugs, wires and crank sensor have all been replaced. Everything...


I would recommend having a fuel injector balance test performed as these injectors have a common problem with plugging up. Off idle the other injectors may be compensating for this fuel deprivation.
The air/fuel ration can also be reviewed with a scan tool. Good luck.

Mar 31, 2010 | 2003 Chevrolet Blazer

1 Answer

1993 gmc sierra 4wd 5.7L running rough mostly during low rpm, hesitates, then smooths out. Problem is becomming more prevalent, wider rmp range. New plugs, wires, cap, rotor, fuel filter. Still happening.


timing might be off a little...or your low idle control might not be functioning. try unhooking your idle control module on throttle body, if it doesnt change idle when you disconnect it, its faulty.

Dec 19, 2009 | 1993 GMC Sierra K1500

1 Answer

Blazer runs rough when running at 45 to 55 mph


the problem was low transmission fluid. added half a quart and the problem went away.

Sep 28, 2008 | 2000 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

840 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...