Question about 1994 Oldsmobile Bravada

1 Answer

I have a 1994 bravada that shuts off about 5 minutes after reaching opperating temp. i have replaced fuel pump, thermastat, temp sensor, and the problem remains the same. it runs perfectly until it cuts out.

Posted by on

  • rwarren1013 Jun 25, 2009

    you are the second person to mention this possible solution. will give it a shot. thanks for the input

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Oldsmobile Master
  • 3,854 Answers

If there is an Auto Zone around your area, have your Ignition control module (ICM) tested. It's common for the ICM to fail when they heat up causing the engine to stop running. The ICM is located under the rotor in the distributor, check the wire's and look for any corrosion or damaged wires to the ICM. The ICM is $40.00 and Auto Zone will have the step by step instruction for you to get the job done with common tools. Good luck and keep me posted, be glad to help. 

Posted on Jun 25, 2009

  • Harvey N Tawatao
    Harvey N Tawatao Jun 25, 2009

    Welcome, there is a vent screen on the bottom side of the distributor so it can breath preventing condensation to form. The screen is known to get plugged up by dirt and condensation forms causing corrosion to the wire and promoting the ICM to fail. keep me posted. 

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have ford escape that run for and shut off after 5 minutes


Test using fuel pressure gauge and spark test to determine what is causing shut down. If fuel, filter, regulator or pump could be bad. If spark, things which might fail as they heat up include coil/module, crank/cam sensors, coolant temp sensor.

Oct 13, 2014 | Ford Escape Cars & Trucks

1 Answer

Why are so many trouble diagnostic codes being thrown


sounds like you speed sensor and your throttle poistion sensor

Sep 02, 2014 | Cars & Trucks

2 Answers

Engine dies


if it shuts off while driving down the road. and restarts after 10 minutes, its usually a bad crank sensor that does this. it messes up timing and shuts off fuel supply.

Apr 05, 2014 | 1994 Chevrolet Suburban

1 Answer

83 280 zx dies when warm


I think you have a failing fuel pump. This is exactly what they do when they are about done working.

May 18, 2017 | Cars & Trucks

1 Answer

Engine gets to operating temp. and just quits.. oil pressure good new fuel pump and checked complete fuel system ..when it cools down again it starts..3.8


causes are: low coolant, failing coolant temperature sensor, air in water pump, failed radiator fan, kinked heater hose. it takes 10 to 15 minutes to reach normal range.

Jun 08, 2011 | 1994 Pontiac Trans Sport

2 Answers

1991 Dodge Shadow. When its warmed up and im driving it around, the engine just shuts off. I pull over, try to start it again and it wont turn over. So i wait 5 minutes and it'll start but 5 minutes later...


this is a typical Coolant Temp Sensor issue. the part is about $20 and can be done in a few minutes. I can further help if i knew which engine was in the car.

Apr 22, 2011 | 1991 Dodge Shadow

1 Answer

94 bravada temp.gauge not working on dash could it be temp.sensor


It could be the sensor or the wire harness it self where it connect's the the sensor. There is just one lead wire and it may be damaged due to corrosion or a broken wire. Check the wire first before replacing the sensor, remember the Bravada is 15 years old. Good luck friend and keep me posted, be glad to know you got your Olds running 100% again. 

Sep 03, 2009 | 1994 Oldsmobile Bravada

1 Answer

94 Bravada that stumbles and stalls.. won't start when warm..


Try checking the exhaust flow when someone else is pushing down on the gas petal.The farther the petal gos down,the more exhaust should be coming out. I replaced my catalitic convertor at 44000 miles, it was clogged. I had them install a high flow type.

Sep 03, 2009 | 1994 Oldsmobile Bravada

Not finding what you are looking for?
1994 Oldsmobile Bravada Logo

207 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8215 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...