Question about 1996 Ford F150 Regular Cab

1 Answer

# 29 5 amp fuse (instr cluster) keeps blowing on 98 reg cab . no rhyme or reason. speedometer, gas, temp, & volts out.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 41 Answers

Got a short in that circuit somewhere.Look on the volt meter gauge make sure all is tight. look for the obvious frayed wires etc.

Posted on Jun 24, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What relay controls the cluster


gauges on cluster, (speedometer, odometer, tackometer, temp, volts, gas), get there readings from sensors
No Relay
Fuses, in under hood fuse box

Feb 26, 2017 | Cars & Trucks

1 Answer

1997 Ford F-150 Reg Cab, V-6 Keep blowing fuse #24,Power Box under hood,30 amp, PCM power,


Try unplugging the power control module. If the fuse still blows its wiring if it doesn't I would guess the power control module is bad.

Nov 12, 2016 | Ford F-150 Cars & Trucks

1 Answer

How do I fix my gauges? (Ie, gas gauge, temp gauge, speedometer, odometer)


Fuses? Blown fusible link? Most gauges work by getting 12 volts from the ignition switch when on, and getting a ground from the sender. Often the 12 volt supply wire goes to more than one so if dead, both will fail. If you have a wiring diagram, you might find which wire to cluster should be hot, and trace it backward to find the issue. Easier to check for ignition switch feed first.

Jul 01, 2015 | Cars & Trucks

1 Answer

Blowing fuses keep


Could be a short in the circuit board inside the speedo cluster. Does the fuse blow if the cluster is unplugged ?

Jul 25, 2014 | 2001 Chevrolet Chevrolet Blazer

3 Answers

Speedometer, gas gauge, odometer, rpm gauge not working


My gas guage, speed odometer and tempiture does not work
The speed odometre is reading 9999999 what should i do

Jul 29, 2009 | 1998 Nissan Frontier

2 Answers

Speedometer not working


I would hold off on trying to buy a new or used instrument cluster unless your sure thats the problem.... your vehicle is equipped with a speed sending unit and that can be faulty ask your self is the other functions of the cluster working? tachometer, fuel, lights etc? then may only be sending unit for speed have it checked out by a pro or follow instructions of troubleshooting section of your repair manual I always try to keep it simple did you check the fuses and relays? then move on from there. If it is sending unit or cluster heres a place I have used for years to get hceap good used and new parts Peach street autorecycling 18003652341 ggod luck and dont forget to rate me if I have helped.

Dec 29, 2008 | 2002 Chrysler Town & Country

Not finding what you are looking for?
1996 Ford F150 Regular Cab Logo

222 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...