Question about 2013 Subaru Impreza WRX

1 Answer

Wont rev above above 5000

The car is 2003 and it has started to give trobule i got the car remapeg about a year ago and it well but it is started now not to reve above 5000 vevs

Posted by Anonymous on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 27 Answers

Possible blocked exhaust, possible slipped timing belt.

Posted on May 19, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wont rev above above 3000rpm


Hi Anonymous, I want to help you with your question, but I need more information from you. Can you please add details in the comment box? Such as what kind of vehicle

Sep 01, 2014 | Cars & Trucks

1 Answer

Coughing feels like its missing


be looking at emissions controls vacuum systems for leaks or broken hoses..

Dec 23, 2013 | 2003 Jaguar X-Type

1 Answer

My 2003 Mercury Mountaineer has an electrical problem. It started about a year ago with the key fob not working, I have bought 3 and all won't work even after re-programing. now tonight I went to


Could be a windshile leak down the A-Pillar & water
gets into the delayed accy relay for the GEM Module
(Body Computer as ford called it for a few years) & you
get what you have now

Try Goolge as I did a few weeks ago for a relative
He had the same issue with the blower being on &
killing the battery

No real fix I found for the windshield leak
Seem a robot didn't put the rubber sealant
on correctly at the factory fo about 5 years
on several fords.

If it isn't water related then the GEM Module
controls all those body features

If you get a used one & match up the numbers,
you supposedly can avoid buying a reman gem
& the expense of having to reflash it to your factory
built combination

Jan 27, 2013 | 2003 Mercury Mountaineer

1 Answer

2003 Saturn Ion won't start in the cold weather


First of all your service light came on so give it a service then have the service light reset then check the thermastac, water levels and the choke is working properly and all the elecric working parts are good

Jul 05, 2017 | 2003 Saturn ION

1 Answer

My E 270 cdi year 2003 not get any ifomation


Hi There, I'm having the same problem but the car wont start of the key! I have to put jump leads onto the batter befroe i will start. id you have the same problm?

Oct 11, 2009 | Mercedes-Benz E-Class Cars & Trucks

1 Answer

Iv got a disco 1.And when im towing and need more power, it wont rev above 4000 revs. checeked all the hoses, cleaned the intercooler, replaced fuel/oil fillter, give it oil change.Its got a KnN air...


Hi,
Are you getting a lot of black smoke?
If so your egr is more than likely goosed.
Easy fix in a 300.
Mine suffered from this a few years ago and I blanked off the egr. You can make a blank yourself or buy one with instructions for a few quid of eBay.
Well worth it and you will certainly notice the difference.
hope this helps.
Iain

Oct 11, 2009 | 1995 Land Rover Discovery

1 Answer

Car revs up to 3000 rpm when I start it. I have unplugged the idle control valve and it makes no difference


It is an electrical relay problem, that is part of the EFI system, I had an Audi of about the same age with the same problem many years ago. The relay was under the dash to the left of the steering wheel. Sorry, can't be more precise, but the dealer at that time had the relay in stock and one mechanic at the dealer gave me enough info to find the relay and replace it, and that solved the problem

Apr 20, 2009 | 1986 Audi 5000 CS

1 Answer

Mercedes c 180 engine fault


sounds like a faulty airflow mass meter

Dec 29, 2008 | 1995 Mercedes-Benz C-Class

1 Answer

Ford focus 53 plate wont start


may have problem with selonoid on top of starter jamming give it a tap with hammer then try

Nov 22, 2008 | 2003 Ford Focus

1 Answer

Mk1 problem


could still be the clutch make sure it releases good or is not just done afdter testing new engine good luck

Jul 07, 2008 | 1997 Volkswagen Golf

Not finding what you are looking for?
2013 Subaru Impreza WRX Logo

Related Topics:

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...