Question about 2004 Buick LeSabre

1 Answer

04 Buick LaSabre Abs light still on after changing left rear hub

I changed the left rear hub but the ABS and traction off lights are still on.The fuel gauge does not work all the time. I don't know if the problems are related. this is a 2004 Buick LaSabre. I have reset the computer. I think maybe it is an electrical wire problem but the wire harness by the hub looks good.

Jerry

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 225 Answers

Check relay under hood of car,sounds like the relay is not working, easy fix

Posted on Jun 23, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Changed bearings and abs light and stabletrack still on do they reset after u replace the bearings and if so how long


Service Traction Control - Stabilitrak and ABS light, Help - Page ...

chevroletforum.com > ... > Tahoe & Suburban
Aug 16, 2012 - Service Traction Control - Service Stabilitrak and ABS light came on. ... Its supposed to still be under warranty, "Major Guard". ... I replaced my rear shocks with OEM re-manufactured Arnott shocks (great company) and in the ...

SilveradoSierra.com • Traction Control, Stabilitrak & ABS Issue

www.silveradosierra.com/.../traction-control-stabilitrak-abs-issue-t18976...
Jan 28, 2014 - Traction Control, Stabilitrak & ABS Issue. Tue Jan 28 ... The wife and I got in to head out and see my brother and as soon as I turned the key the ServiceTraction Control, Service Stabilitrak messages flashed and the ABS light came on. ... check your wheel bearings my was gone and caused the same thing ...

Chevrolet Impala Questions - Hello. I have a 2012 Chevy ...

www.cargurus.com > Questions > Chevrolet > Impala

CarGurusApr 6, 2013 - Occasionally when I hit the brakes I get a Stabilitrak Error Message " ... I believe GM still had 3 year/ 36,000 mile bumper to bumper ... After about 2 months of intermittent noises the ABS light came on, the service stabilitrak warning, servicetraction ... Edit....left hub bearing change after the right one changed.

Replaced front hub - now ABS/Stabilitrak lights on... - Chevy ...


Dec 12, 2015 | Cars & Trucks

1 Answer

Abs light comes on


Have codes checked, most common is a failed left or right wheel speed sensor , part of front wheel hub/bearing assembly.

Jan 21, 2014 | 2002 Buick LeSabre

3 Answers

Traction control and anti-locks(ABS) lights come on.


Traction control and anti-locks(ABS) lights come on there is sensors that are pluged in behind the rotors check and see if they are disconected or loose sometimes when you change your brake pads they might come loose and not making contact.

Jul 06, 2010 | 1998 Cadillac DeVille

1 Answer

Speedo suddenly not working and two warning lights appeared on dashboard one being ABS light warning light.


If the ABS (and likely the traction control) light came on at the same time that the speedometer stopped working, you likely have a faulty wheel speed sensor at the right rear wheel. You can test this by swapping the two rear wheel speed sensors (ABS sensors). If the speedometer then works (but the ABS & Traction control lights stay on), replace the sensor that is now at the left rear (was at the right rear). If no change, you may have a fault in the ABS & Traction control - control unit.

Rear wheel speed sensor at www.bavauto.com

http://www.bavauto.com/shop.asp?HC1=0&Htarget=search.asp&HCY=2001&HCM=330i&SearchStr=rear%20abs%20sensor

Nov 22, 2009 | 2001 BMW 330

1 Answer

TRACTION LIGHT STAYS ON AND ABS LIGHT AFTER STARTING CAR 97 buick lasabre


There is a good chance that the wheel speed sensor, (ABS sensor) has gone bad or gotten to dirty. It's common for the ABS sensor to get too dirty and can not read the speed ring on the wheel hub since it's magnetic. The common repair is to spray Brake Parts Cleaner on the ABS and speed ring on the hub and inspect for damages to the wire harness. The ABS sensor is on the inside of the wheel hub so it's easy to get to, if you not sure what your looking for. Remove the wheel and along the A-arm, you will find a wire harness which leads to the wheel hub (Bearing). There is where your going to find the sensor, just clean it and inspect for corrosion and gap, you can take paper and fold it 5 times and place it between the sensor and speed ring for the proper gap. Good luck and keep me posted, if there is a Auto Zone around your area, have them scan the car just to make sure it's not your ABS modulator which would cast $$$ to replace.

Nov 02, 2009 | 1997 Buick LeSabre

1 Answer

Abs , brake, traction control light on in 04 lesabre


check to make sure that all the the bulbs in the rear are working,even the third light

Apr 08, 2009 | 2004 Buick LeSabre

3 Answers

Buick rendevousz headaches


I own the 2002 Buick Rendezvous CX and I've encountered the same problems listed here. The ABS / Traction Control Lamp stays on and was throwing a code for the left wheel speed sensor as well as an anti-lock brake code (both in the wheel bearing hub assembly). I replaced the left and right front wheel hub assembly yet this did not eliminate the abs codes. 
Ultimately, I traced this problem to a break in the wire that leads to the left hub assembly. Although the sensor was properly connected, the wire (which is encased in a plastic housing) was broken. This is the wiring which leads from the abs wiring harness under the hood down to the left wheel abs sensor. 
I would suggest that you simply remove the left wheel and inspect the wire that leads to the abs sensor (there is only one wire on each wheel). Mine literally fell apart when I removed the plastic housing around the wire. I spliced the wire together and put it back in the plastic housing. After this, my abs codes disappeared and my anti-lock brakes began working again!
This is a simple fix that many people spend $1000 + on by replacing the hub assembly which does not fix the problem.

Aug 20, 2008 | 2002 Buick Rendezvous

Not finding what you are looking for?
2004 Buick LeSabre Logo

455 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...