Question about 2006 Chevrolet Tahoe

1 Answer

Sre my stepper motors bad?

Randomly my battery light will flicker on and off with all the gauge needles bouncing to zero then back and a clicking noise in the dash as it does this. The alternator or pumping out around 14 on a multimeter, what could be causing this?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

They may very well be bad. It is a common problem that affects thousands of GM/Chevrolet owners. Check grounds first, multi meter will show positive if bad I would think. GM may at their own discretion replace them for you if enough pressure is applied to the dealer. Lastly, stepper motors can be found on many sites including eBay and you will save a ton of money if you DIY. Sorry, my 2003 Tahoe has been fine so far although less than 20,000 kms on the gauge. Just used to tow boat and race car to local track. Good luck and if I find anything else, I will post!

Posted on Jun 07, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 599 Answers

SOURCE: fuel gauge k1500 98 Z71 fuel gauge vibraiting or bouncing

gauge failing (dash)

Posted on Dec 08, 2008

tripletauto
  • 1450 Answers

SOURCE: fuel sensor gauge

you will need to replace the fuel level sensor.(sending unit) it is in the tank and is hooked to the fuel pump. you can buy seperatly from pump. you may finf it easier to remove the bed if you have some help. it is six or eight bolts and harness unplugs then you can get right to it.

Posted on Jan 13, 2009

  • 10 Answers

SOURCE: 2004 Blazer Dome lights, dash lights and headlamps with flicker

bad ground at battery or chase.

Posted on Jan 28, 2010

  • 250 Answers

SOURCE: Fule gauge speedometer and rpm gauges stopped

Go to the fuse box and change the fuse for "Gauges". I think this might solve the problem.

Posted on Feb 23, 2010

daltonp
  • 361 Answers

SOURCE: My oil pressure gauge is bouncing all around on my

Sounds like the oil pressure sensor. Thatt is the easiest thing to change. If not its the gauge. Put voltage to the wires from the switch and see if the gauge stops jumping and stays pegged, if it does its the switch Good luck

Posted on Jul 23, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Oil pressure gauge is ready zero in 2003 2500hd 8.1 liter


Hello, this problem is due to a failing stepper motor. The stepper motor is the motor behind the gauge that controls the movement of the needle. When a stepper motor begins to go out it will cause the gauge needle to stick, skip around, stay at zero or max out on the gauge. The only way to fix the problem is to replace the stepper motor with a new one. While replacing one motor it is best to go ahead and replace them all as the others will go out in time as well. Your cluster will have one motor for each gauge. Here's a link to a page showing exactly how to replace a GM stepper motor and where to get the correct parts to do the job! DIY Finally How To Repair GM Instrument Cluster At Home Speedometer And...

May 21, 2012 | Chevrolet Suburban 1500 Cars & Trucks

1 Answer

Oil pressure gauge drops to zero and comes back up to 80


Hello, this problem is due to a failing stepper motor. The stepper motor is the motor behind the gauge that controls the
movement of the needle. When a stepper motor begins to go out it will cause the gauge needle to stick, skip around, stay
at zero or max out on the gauge. The only way to fix the problem is to replace the stepper motor with a new one. While
replacing one motor it is best to go ahead and replace them all as the others will go out in time as well. Youre cluster
will have one motor for each gauge. Here's a link to a page showing exactly how to replace a GM stepper motor and where
to get the correct parts to do the job!
DIY Finally How To Repair GM Instrument Cluster At Home Speedometer And...

Feb 25, 2012 | 2006 Chevrolet Silverado 1500 2WD

1 Answer

The check gages light comes on and off while driving, at the same time, the oil pressure gage drops and then bounces back up after hitting zero


There a couple of possibilities; you could have an intermittent oil pressure switch or an intermittent stepper motor in the instrument cluster. The stepper motor drives the gauge.

Jun 30, 2011 | 2003 Chevrolet TrailBlazer

2 Answers

Speedometer is stuck at 120mph


Try giving the gauge pod a solid hit with your hand. This may jolt the needle back.

Otherwise,
  • remove the gauge pod.
  • remove the front clear panel from the pod.
  • move the needle back the zero position.
  • reassemble.
See if the speedometer now works.


SD

Jan 07, 2011 | 2004 Chevrolet Suburban

2 Answers

My speedometer started going crazy when stopped it says i am doing 75 and at 30 i am doing 120 how can i fix this problem


the speedometer clusters go bad alot you can take it out and have it repaired or replace it and have it reprogramed

Jan 29, 2010 | 2005 Chevrolet Trailblazer Ext

4 Answers

Speedometer does not function properly. needle


A faulty vehicle speed sensor will cause this.
It's mounted on the back end of the transmission where the drive shaft slides into, near the top, it's just held in with a bolt, on the right side of the tranny, also has a wire connection.

Oct 23, 2009 | 2004 Chevrolet Silverado 1500 Crew Cab

2 Answers

Speedometer has stopped working. The rest of the dash cluster is still functioning


you very well could have a bad speedo sensor gone bad . check the passenger side of the tranny and towards the top should be a sensor you will have to unplug and take out one bolt to replace . it should run about 30-40$ to replace

Aug 05, 2009 | 2003 Chevrolet Silverado 1500

Not finding what you are looking for?
2006 Chevrolet Tahoe Logo

37 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8531 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...