Question about 1984 Chevrolet Cavalier Type 10

1 Answer

I have a 1984 Chevy Cavalier that was running pretty well until just recently. It started making a puttering noise, has trouble accelerating, and the oil light is always on. Goes through coolant rather quickly. Changed oil about 2 weeks ago, don't know really where to start.

Posted by on

  • acleitzel Jun 24, 2009

    Hey guys, op here...

    The oil is not milky. It's not being contaminated by water or coolant. I got some mystery marvel oil which kind of helped it out, but I'm almost positive now I'm leaking oil because whenever I stop the oil pools somewhere on the engine and the engine eats up the oil obviously causing smoke.


  • polkadice May 11, 2010

    probally head gasket. Was the oil "milky, had water in it"" when you changed it?

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 41 Answers

Check to make sure your pcv valve is clean.

Posted on Jun 24, 2009

  • 426 hemi Jun 24, 2009

    Check to make sure your pcv valve is clean.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Starter problems with 1995 Chevy Cavalier


http://www.autozone.com/autozone/repairinfo/repairguide/repairGuideContent.jsp?pageId=0900c1528003d007Your fusible link could be burnt and not getting a good connection,follow all wiring tied into positive battery cable for burnt or swollen wires.Click on link.

Sep 09, 2012 | 1995 Chevrolet Cavalier

1 Answer

I have a 1998 Cavalier (147,000 miles) that has made a ticking noise when I start it. However, revving the engine will quiet the noise before driving. Recently, it began making a extremely loud grinding...


unfortunately at 140,000 miles much like humans parts start to wear... now you can try to flush the oil system...I DON"T RECOMMEND IT.... I have seen engines tear apart from engine oil flushes.... drain refill the oil/filter with new oil and an additive may help, or pin down the noise to what lifter is going south and have it replaced... may end up being a very expensive repair depending on what they find when they open the engine up with high mileage...or just continue driving it untill it completely wipes out... I do belive its a hydraulic lifter that is not pumping up causing the tick and if so they usually last a long long time noisey.

Aug 12, 2010 | 1998 Chevrolet Cavalier

1 Answer

Boat starts fine runs idle fine, accelerate no


make sure that the timing advance mechanism in the distributor is working freely.

Sep 30, 2009 | 1984 Chevrolet Chevy

1 Answer

Had trouble starting the vehicle for two days on the second day when it finally started it puttered after it did start. let it set for a second to get itself going. when i put it gear kind of puttered some...


We have the same problem we changed the fuel pump and it fix the problem for about a week, the van started puttering and didn't start until the 20th try. Now we are looking at the fuel filter. What a way to spend the 4th.

Jul 01, 2009 | 2000 Chrysler Grand Voyager

1 Answer

I have a 2001 Chevy Cavalier cd player error


the cd sensor light which spots the cd is dirty run a cd cleaner through it should fix it

May 18, 2009 | 2001 Chevrolet Cavalier

1 Answer

Puttering sound


You could have bad gas, Try running some injector cleaner and then chaging your fuel filter after a week of drving. Good luck

Apr 05, 2009 | 2000 Chevrolet Cavalier

1 Answer

1996 Cavalier--PLEASE HELP


Maybe try to replace the map sensor and the oxygen sensors

Jul 26, 2008 | 1996 Chevrolet Cavalier

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

235 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

81423 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22359 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...