Question about 1997 Mercedes-Benz Mercedes Benz Sl Class

1 Answer

Sl320 engine cuts off after 30mins

Restarts immediately any suggestions what sensor needs to be replaced?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 305 Answers

Well it sounds like a fuel problem i would check my fuel pressure first now if a code came up find out what it means and address it and make sure you have fuel in the tank

Posted on Jun 18, 2014

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
taran_2005
  • 10515 Answers

SOURCE: need to replace oxegen sensors on 1997 sl320

Hi,
Oxygen Sensor Location - Under vehicle, passenger side, below seating area, front of catalytic converter, mounted in exhaust pipe.
Procedure to Replace

  • The sensor is threaded into the exhaust manifold.
  • It can be difficult to remove unless a special anti-seize compound is coated onto its threads.
  • Torque the sensor to 30 foot-pounds using a special socket.
  • A sensor that is too loose or a cracked exhaust manifold can result in a lean signal to the computer.
  • Check the vents in the thimble of a replacement O2 sensor.
  • There should be the same number of holes and they should face clockwise or counterclockwise like the ones on the original sensor.
  • Installing the wrong sensor can result in slower cross counts.


Let me know, if needed further assistance.
Hope i helped you.
Thanks for using ' Fixya ' and have a nice day!!

Posted on Nov 04, 2009

  • 20 Answers

SOURCE: Sl320 engine cuts off after 30mins

Bring to auto parts store and have them check for any codes stored in the computer and go from there, There are far too many options to list here.

Posted on May 13, 2014

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine will die after warmed up


depends on what you mean by "warmed up". If you mean engine reaches normal working temprature and works normally then cuts out , but restarts wwithin 5 minutes and then carries on working normally until it cuts out again, and then restarts withing minutes...have the throttle position sensor checked. It may be that you have a warning code on the dash?
It might be the pedal position sensor alternatively.
If your engine works ok until fully warmed up this may be the problem.
If there are any symptoms before the cut out happens can you please add the details and repost thwe query

Oct 26, 2015 | Cars & Trucks

1 Answer

Sl320 engine cuts off after 30mins


Bring to auto parts store and have them check for any codes stored in the computer and go from there, There are far too many options to list here.

May 13, 2014 | 1997 Mercedes-Benz Mercedes Benz Sl Class

1 Answer

Engine cuts after 30mins driving


Check/replace the fuel filter

May 13, 2014 | Cars & Trucks

1 Answer

My mercedes 1999 cuts out and wont start 30mins later it will


this happens on my partners a class but only when the fuel gauge drops to 1/4 full.Now we keep it filled up with no problems.We had the fuel filters replaced without success.I think maybe there are fuel sensors which are telling the car it is out of fuel.Like yourself we would wait for a while then the car would start.

Mar 14, 2013 | 1999 Mercedes-Benz E-Class

2 Answers

01 Nissan Altima cuts off at red lights


Hi Nichelle, Take the vehicle for a diagnostic scan. If the engine sounds smooth and is running well, I do not believe you need an new engine. What is more likely is a defective fuel pump or fuel regulator. A very common fault on Nissans is the mass air flow sensor, which sounds as if it is the problem with your vehicle. Regards John

Oct 24, 2012 | 2001 Nissan Altima

1 Answer

MONDEO TDCI 2.0L CUTS OUT UNDER ACCELERATION AND THE DEISEL PLUG LIGHT FLASHES.ENGINE RESTARTS IMMEDIATELY.NEW CLUTCH AND FLYWHEEL SENSOR FITTED RECENTLY


There has to be a loose connection somewhere. Being pulled apart under hard acceleration. Do you have any OBDII codes stored? This will lead you to your fault. Hope this helps...

Mar 10, 2011 | Ford Taurus X Cars & Trucks

1 Answer

I am hoping that some of you jeep brainiacs out there can help with a suggestion of the problem with my 1992 Jeep Wrangler 4.0 hi-output. Symptoms: backfire from time to time....cuts off when driving, cuts...


I remember the "Parts Replace" routine all too well from my truck. It's probably the fuel filter needing to be changed, clogging up and clogging the flow.

Dec 19, 2010 | 2003 Jeep Wrangler

1 Answer

1994 Jeep Cherokee with 215,000 miles 4.0 Liter automatic. Engine dies at 2,000 rpms and will coast to a stop and restart. If kept below 2,000 rpms there is no problem. I have replaced fuel relay, a/c...


I would try the crankshaft sensor. About the only thing left in the electrical department. These are known to heat up and fail. Also could be a weak fuel pump, but not as likely as you say it restarts immediately. You should have the fuel pressure checked before replacing it, as it's pretty expensive. ~ $175. I had one that would die intermittently, then it wouldn't restart until you got under the back and kicked the gas tank.

Jun 19, 2009 | 1994 Jeep Grand Cherokee

1 Answer

Cold Start Idle Issue


Problem might be the air control valve, it's located at the right side rear of intake manifold and has a hose going to the air intake duct from the air cleaner, as a test you might try pinching off that hose when the idle is a problem.

Aug 17, 2008 | 1990 Subaru Legacy

Not finding what you are looking for?
Cars & Trucks Logo

57 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

yadayada
yadayada

Level 3 Expert

76691 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...