Question about 2007 Nissan Tiida 1.6

1 Answer

What can cause Nissan tiida 2007 not to accelerate?

Engine start but refuse to accelerate, the accelerator can not go above 20km/hr

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Nissan Master
  • 50,583 Answers

Run the fault codes as it appears that the engine /transmission has gone into limp mode and is restricting the rpm to prevent damage .

Posted on Jun 15, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 603 Answers

SOURCE: My check engine light is on and it often shakes

Bring it in so that the check engine light will be off and it will run smoother.

Posted on Jan 12, 2010

duane_wong
  • 6826 Answers

SOURCE: Hi my 2001 Nissan Maxima

Try a cts coolant temperature sensor if it is out of range.

Posted on Oct 07, 2010

  • 60 Answers

SOURCE: nissan n15 almera,problem with engine

needs a new set of leads or plugs

Posted on May 04, 2009

  • 7 Answers

SOURCE: top engine mount

You need to loosen the motor mount slightly--just a full turn or two. Place a jack under the oil pan and lift the engine until the strain is relieved on the motor mount and finish removal. Replacement installation is the opposite except you'll want to tighten the new motor mount into place fully (if possible) before lowering the jack.

Posted on Aug 25, 2009

  • 32 Answers

SOURCE: can a bad map sensor cause a 2002 nissan maxima to

If the sensor is bad it causes the computer to change air/fuel mixture for the fuel injection and would have that effect,other possible causes would be a clogged fuel filter or the fuel pump is going bad but you need to change the map sensor if it is sending a code.

Posted on Sep 04, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my car's RPM goes down when idle and AC turned ON?


No idea here i would suggest a visit to the garage that installed the gas conversion ,if i had my head inside the engine i might be able to work out whats wrong but from afar ? i stand no chance

Aug 05, 2014 | Suzuki Swift Cars & Trucks

1 Answer

My Pajero GDI engine v6 petrol has idling and acceleration problem.


it is a possibility the potension meter does not working. It is on the accelerator pedal,by using a scanner surely you will get the correct fault.

Mar 06, 2013 | Cars & Trucks

1 Answer

Can't get accelaration over 20km/h


LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Nov 28, 2012 | Cars & Trucks

1 Answer

Fan like noise when accelerating above 20km/h


No idea without a good look ,sorry but please ask a local mechanic to have a look for you

Sep 24, 2012 | 2007 Land Rover Freelander

1 Answer

Cant get passed by emission test. No codes are coming up but someone keeps saying evap system Catalytic converter, fuel pump, gas cap. O2 sensor has been replaced . Also eating alot of gas. Engine light...


You have to do a drive cycle, the fuel tank has to be between 1/4 and 3/4 of a tank of fuel, can not be above or below this fuel level.
To perform an OBDII Driving cycle do the following:

1. Cold Start
In order to be classified as a cold start the engine coolant temperature must be below 50ºC (122ºF) and within 6ºC (11ºF) of the ambient air temperature at startup. Do not leave the key on prior to the cold start or the heated oxygen sensor diagnostic may not run.

2. Idle
The engine must be run for two and a half minutes with the air conditioner on maximum and rear defroster on. The more electrical load you can apply the better. This will test the O2 heater, Passive Air, Purge "No Flow", Misfire and if closed loop is achieved, Fuel Trim.

3. Accelerate
Turn off the air conditioner and all the other loads and apply half throttle until 88km/hr (55mph) is reached. During this time the Misfire, Fuel Trim, and Purge Flow diagnostics will be performed.

4. Hold Steady Speed
Hold a steady speed of 88km/hr (55mph) for 3 minutes. During this time the O2 response, air Intrusive, EGR, Purge, Misfire, and Fuel Trim diagnostics will be performed.

5. Decelerate
Let off the accelerator pedal. Do not shift, touch the brake or clutch. It is important to let the vehicle coast along gradually slowing down to 32km/hr (20 mph). During this time the EGR, Purge and Fuel Trim diagnostics will be performed.

6. Accelerate
Accelerate at 3/4 throttle until 88-96 km/hr (55-60mph). This will perform the same diagnostics as in step 3.

7. Hold Steady Speed
Hold a steady speed of 88km/hr (55mph) for five minutes. During this time, in addition to the diagnostics performed in step 4, the catalyst monitor diagnostics will be performed. If the catalyst is marginal or the battery has been disconnected, it may take 5 complete driving cycles to determine the state of the catalyst.

8. Decelerate
This will perform the same diagnostics as in step 5. Again, don't press the clutch or brakes or shift gears.

Aug 26, 2011 | 2001 Pontiac Grand Am SE

1 Answer

My car a diesel engine cant go above 20km/hr. it goes up to 20 km/hr then cuts off and switches off


The magnetic switch is defective,fuel line cloged up,dirty fuel line system.

Aug 09, 2011 | 1999 Isuzu Trooper

1 Answer

LIMITED ACCELERATION NOT BEYOUND 110KM/HR ON GEAR 5


sounds like you have a faulty mass air flow meter.Change it.hope that was helpfull.

Jul 18, 2009 | 2004 Jeep Liberty

1 Answer

Acceleration - cannot get above 40 miles per hr.


If the engine revs up while in drive and running at 40mph, your transmission is probably slipping. Try checking your transmission fluid level. If it is OK, I would get it by a garage to have them look at it to cofirm.

Mar 30, 2009 | 1998 Land Rover Discovery

1 Answer

Hyundai accent 05, goes to 5000rmp at speed 20km/hr


You need to have to transmission filter changed. Dirty filter and not letting it shift. Can you start the motor and let it run about 10-minutes befroe driving. It could be that the fluid is cold and thick, not wanting to shift????? Try that.

Jan 15, 2009 | 2005 Hyundai Accent

Not finding what you are looking for?
2007 Nissan Tiida 1.6 Logo

Related Topics:

381 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...