Question about 2004 Suzuki Verona

Open Question

My engine light stays on all the time after driving it about 10 minutes engine light starrts flashing ita small hesataion in it after this put stll has a lot of power. what could cause this?.

Posted by Anonymous on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Reset security system


To review - the factory VATS security system will not let the engine crank or start if the wrong key is used or there is a problem with the system.
So if the engine was cranking the security system was not at fault.
You may have to get a used shop manual to get the testing procedures for a no start-stall problem.

Feb 25, 2013 | 1999 Chevrolet Cavalier

1 Answer

CHECK ENGINE LIGHT FLASHES 10 TIMES


Run scanner and computer for test can be MIL see the diagram
9_19_2012_6_22_11_am.gif

Sep 18, 2012 | 2005 Dodge Dakota Club

1 Answer

I just put a new steering column in my 200 saturn sl2 because my ignition lock was messed up. Now when whe try to start the car, it will start up but immediately shut off and then the security light...


Hello: Will try to give you instructions: Attempt to start car, leave key on (security light flashing) let set for 10 minutes, After 10 minutes security light out. Turn key off for ten seconds, turn key on, let set for 10 minutes, turn key off for 10 seconds. turn key back on let set 10 minutes, turn key off for ten seconds, the engine should now start and stay running.

Jan 14, 2011 | Saturn SL2 Cars & Trucks

1 Answer

Intermitent electrical problem - 4wd lights flash


have the sensors on the trans checked this is a common problem

Apr 19, 2010 | 2000 Chevrolet Blazer

2 Answers

The car fires but stops immediately


I had a problem with a 97 Achieva recently.Someone else replaced the PCM/ignition switch and passlock sensor.I replaced the ICP.Engine would turn over but wouldn't start and the security lamp was dim and flashing and then it would go solid.I tried the wait 10 minutes thing but,the light would never go off! I put the original passlock sensor back onto the lock cylinder. But this is what fixed the problem.I cleaned the contacts on the black wires and green on the ignition switch with tv tuner cleaner! After I cleaned those contacts the security light was flashing brightly.So I turned the key to run and left it there.After a few minutes it stayed on solid.I waited about 10 minutes but the light never went out.So I turned off the switch and then tried starting.It started right up and the security lamp flashed and then went off.Has started every time since.Note:I also scraped the pins that I cleaned with the cleaner with a knife.

Nov 11, 2009 | 1997 Oldsmobile Achieva

1 Answer

Installed a new ingintion switch know security light flashes and car will not start


this process will take about half an hour to doyou might want to put a battery charger on it on the low setting because if the battery dies in process u have to start over.first thing is try to start car,it might start then stall,when that happens leave the key in the on position and the security light will be flashing and it will keep doin it for 10 minutes,then it will stay on solid,when it does that turn the key off for 2 seconds then turn it to the on position anfd the light will be flashing agian for 10 minutes,then it will be on solid,then turn the key off for 2 seconds and then back on and 10 minutes later when it stops flashing this time u should be able to start it and the light should be off,hope this helps

Sep 23, 2009 | 2003 Oldsmobile Alero

2 Answers

1996 Oldsmobile Achieva: Security light flashes upon startup


Here is what you do, but only when the SECURITY light flashes - if it is always ON or OFF it's no use.
Turn the key in the ignition to ON.
Wait for exactly 10 minutes ( SECURITY light will flash for 10 minutes and then stay on SOLID)
Turn the key to OFF
Wait 5 seconds.
Turn the key in the ignition to ON.
Wait for exactly 10 minutes.
Turn the key to OFF
Wait 5 seconds.
Turn the key in the ignition to ON.
Wait for exactly 10 minutes.
Turn the ignition OFF.

Start the car normally.
It has relearnt the keycode and you're good to go.
NOTICE - it takes 30 minutes to relearn, that's THREE cycles of ON - 10 minutes - OFF.

Good luck.

Jul 11, 2009 | 1996 Oldsmobile Achieva

1 Answer

Sputtering real bad if it dont warm up


clean your idle air control valve on your throttle body and clean the throttle body with spray carb cleaner at the same time.

Apr 02, 2009 | 1996 Ford Thunderbird LX

2 Answers

Put new ignition in 2003 sunfire. engine wont stay running and theft lock symbol on in dash


HI.

Follow this step to keep running your sunfire.
1 - Be sure the battery is full charged.
2 - Is better if you put a battery charged
3 - Turn the key to run position and tray to start the car and leave with the key in run position,
With a watch let pass 10 minutes no less. you gonna see the security light flashing and stop flashing after 10 munites.
4 - After 10 munites turn the key to off position during 30 seconds, with watch on your hand, OK.
6-- After the 30 seconds try to star the car

I hope this solve your problem.
Please letme know.

Thank you for use fixya.

Jul 11, 2008 | 2003 Pontiac Sunfire

Not finding what you are looking for?
2004 Suzuki Verona Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...