Question about 2004 Chevrolet TrailBlazer

1 Answer

Where does the light green sensor plug connect to?

After my mechanic worked on my engine head, my 2004 trailblazer is now running rough and hot. I found a light green 2 pin connector that is not connected to anything and hope to identify the sensor and its location. thank you for your help in advance. brawley resident

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers

Hello there

the cylinder head on your truck needs to be machined and if it's really bad then you need to get good cylinder head

Posted on May 11, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

royhyreno9
  • 50 Answers

SOURCE: Runs rough at idle and low rpm. misfires. gets better @ high rpm

sounds to me you have a emissions problem check your EGR valve and MAP senser

Posted on Jan 16, 2009

  • 4 Answers

SOURCE: 2002 chevy trailblazer has rough idle

it could be an o2 sensor. it could also just need a tune up

Posted on Mar 15, 2009

sidlas
  • 95 Answers

SOURCE: OBD II Connector identify and location?

2004 Chevy Aveo LS, the OBD-II connector is against the panel closest to the driver's knees above the brake pedal.

Posted on Jun 13, 2009

  • 1 Answer

SOURCE: BLOWER FAN NOT WORKING PROPERLY

I had the same problem change your blower motor resistor.

Posted on Aug 17, 2009

outdoorsman5
  • 631 Answers

SOURCE: Vaccum hose diagram for 97 chevy tahoe 5.7 liter

I have the diagram you need. If you send me your email I will scan it off and send it to you. outdoorsman592003@gmail.com

Posted on Sep 12, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

2006 Chevy Trailblazer started to run rough in idle but only after it warms up. My mechanic got P0017 code on his scan tool and told me I needed to replace the Crankshaf and Camshaft sensors. Both sensors...


Bad coolant temp sensor or EGR valve stuck. You can remove and test temp sensor (the one for the ECM--has only one wire) using cold and then hot water and read resistance with ohm meter.

Jan 28, 2015 | 2006 Chevrolet Trailblazer Ext

2 Answers

I just had the head serviced and replaced ,but found a connector loose. The connector tip is light green more round than oval like the other connectors. The car starts but doesn't. Feel right I. Hav


What is the color of the wire with stripes or solid color? I have access to a wiring diagram. Sounds like a temperature sensor. This tells the ECM how much fuel to give the motor and also regulates the fan to turn on and off to keep the engine from overheating.

May 11, 2014 | 2004 Chevrolet TrailBlazer

2 Answers

Can i run my 02 trailblazer without my front 02 sensor plugged in


Not if you want any type of fuel control, after you go to
closed loop, around 3 or 4 min after start up & as the
coolant temp passes 150

Why are you asking?

I guess you don't know what oxygen sensors are for!

Feb 11, 2013 | 2004 Chevrolet TrailBlazer

2 Answers

2005 trailblazer flashing engine light


your timing belt on your vehicle is connect and turns the a/c pump if it run rough with the air on you may either have a vacuum leak in a hose or either your ac pump may be going out

Jul 06, 2012 | 2005 Chevrolet TrailBlazer

1 Answer

5.3 liter Chevy engine #1 Cylinder not firing at idle


My opinion...

Year? Miles?

There's no way I'd dive into a "HEAD GASKET"
diagnosis without pressure testing the cooling
system and (wet/dry) COMPRESSION testing
the whole engine...

Even if it is a "HEAD GASKET"... the entire engine
might be ready for a REFRESH... and tossing a new
Head gasket into a TIRED ENGINE not insubstantial
(a lot of wasted time & money)...

Come back with some compression numbers...

but don't bother with any of this if your engine oil has water in it.

(in my opinion)

Carnac the Magnificent

Apr 04, 2017 | 2005 Chevrolet Silverado 1500 2WD

1 Answer

Rough running under load both o2 sensors changed with new plugs. I think the trouble light was on too long and sum how killed the converter


did you check the coils and plug boots when you replaced the plugs? often times the coils get weak and don't complete the burn to the plugs. also check the connections at the coils to make sure no terminals got bent when you plugged them back up. the convertor can be bad or will go bad if the engine running problem isn't corrected.does the check engine fault codes reveal misfire codes or catalyst below efficiency code? the misfire codes need to be fixed first.

Aug 10, 2011 | 2004 Chevrolet TrailBlazer

2 Answers

I have a 2004 chvrolet trailblazer. Since I got it when at idol it stalls. I brought it numerous times to the dealership for this. They said it was the idol. About a year ago my orange check engaine light...


Was it the hose to the throttle body that you're talking about? Or another thing that would cause it, would be the little tiny hose on the right hand side of the plastic resnonator, this goes to your fuel pressure regulator. AND the larger size hose on the bottom left front which would all cause it to run rough also. All these things would cause it to run rough and you're not the first to forget to hook those back up. Is the engine still running hot? The guage means nothing, need to have it looked at by a scanner to get true accuracy. Should be solid at 210 always.

A couple of things.....while the thermostat was replaced, did they replace the coolant temperature sensor right above the thermostat? This could cause mis readings if it's bad, mine is bad right now so I need to replace mine.

Also, when it would stall, did you have the A/C or defroster on when it did this? If so, it's a very common problem, need to clean the throttle body to get rid of this problem. If you have any more problems or anything with this vehicle, let me know, you got the right guy for Trailblazers.

Jun 01, 2011 | 2004 Chevrolet TrailBlazer

2 Answers

2002 chevy trailblazer has rough idle


it could be an o2 sensor. it could also just need a tune up

Mar 15, 2009 | 2002 Chevrolet TrailBlazer

1 Answer

Oil in spark plugs


Could mean a variety of things.....
Possible head gasket leak....(cheap fix if caught early)
Possible Worn piston rings
possible valve guide oil seals

Jan 12, 2009 | 2004 Chevrolet TrailBlazer

Not finding what you are looking for?
2004 Chevrolet TrailBlazer Logo

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...