Question about Cars & Trucks

1 Answer

I have a 1999 buick century the driver side front turn signal will quit working then i will take the bulb out and put it back in it will start working again what could be causing that

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 50,058 Answers

Check for a bad or loose earth point for the bulb. Remove any rust and dirt in the socket and check and earth wires

Posted on May 11, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad
  • 2309 Answers

SOURCE: 1999 Buick Century. Right front

check for voltage going to the socket, then check grounds

Posted on Nov 04, 2010

roniecon
  • 6927 Answers

SOURCE: front driver turn signal quit. changed bulb,

Check for head light (daytime)relay to be bad,this might have to do with the turn signals also,if the turn signals on this car,also have running lights in them,If this relay is not bad,replace the body control module.

Posted on Nov 07, 2009

SOURCE: front Left turn signal lamp doesnt work

check wire contacts in socket. If they are melted change the socket
It can be removed easily just unplug the wires.
I have replaced both front sockets on my 1999 Buick Century.
Hope this helps.
Ron

Posted on Aug 08, 2008

cadman000
  • 607 Answers

SOURCE: 02 Buick Century turn signal problem

try 2 new bulbs

Posted on Apr 21, 2009

jturcotte
  • 8836 Answers

SOURCE: Have a 2002 buick century,

Hi, for the headlamps, I suspect the high/low switch, because the fuse and relay run both the high and low beams. Replacing the high/low switch requires removal of the airbag and steering wheel, etc.

For the dash lights, I would suspect the dimmer on the headlight switch. This is the same part as above.

For the left signal--which bulb are we talking about? front or rear or dash? Is it possibly getting wet?

For the window--are we talking about a power window not working? Does it go one direction or not at all? If not at all, you probably need a new motor. The door panel will have to come off to replace the motor.

Not sure how much of this work you want to do yourself, but I can provide procedures if you want to try. Please let me know if you have questions, and thanks for using FixYa.




jturcotte_863.gif


jturcotte_864.gif

Posted on Jan 18, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 1998 buick century, the front blinker on the driver side will not stay working. Does not burn the fuses out. works for about 5 days then the turn signal starts clicking fast then a few days later...


This behavior is usually caused by water leaking into the socket or just a bad socket. Clean it up and use some dialetric grease on the contacts.

Nov 13, 2017 | 2002 Buick Century

1 Answer

Turn signal light staying on in front driver side and back turn signal light blinking too fast on driver side in back. All bulbs good.


Double check your front drivers side bulb sounds to me like the bulb is bad. It may look ok but could be bad. You might try swapping bulbs between the right and left front lights to test it. If the problem moves to the other side then you've found your problem. Good luck.

Nov 03, 2009 | 1998 Buick Century

4 Answers

Front driver side turn signal light doesn't flash.replaced bulb,replaced socket,all other lights work on emergency flasher,except front driver side.rear driver side turn signal light works,but flashes...


replace flasher......usually located in fuse block area...listen in this area....select passenger side ...then select driver side...you can hear flasher clicking...you have seperate flashers for each...FLASHERS are small cubes plugged into fuse block....probable bad driverside flasher

May 09, 2009 | 1998 Buick Century

1 Answer

Front driver side signal light flashes on and off very fast


if it is the front drivers side...then the rear drivers side bulb is out

Feb 02, 2009 | 1999 Buick Century

1 Answer

1992 Buick Century turn signal


You may have some corrosion in the socket where you plug in the bulb. This would cause the lights to not blink. Put the turn signal on, and check the lights, front and back. Are then on, and not blinking, or are they not on at all? If the bulbs are good, and they aren't on, it's the bulb socket problem. Get fine sandpaper, fold it around a pencil eraser, sand off any gunk or corrosion inside the socket. It could also be a faulty ground wire, check for a loose wire at the light assembly. front and back.countrycurt0

Aug 22, 2008 | 1992 Buick Century

1 Answer

Front Left turn signal lamp doesnt work


check wire contacts in socket. If they are melted change the socket
It can be removed easily just unplug the wires.
I have replaced both front sockets on my 1999 Buick Century.
Hope this helps.
Ron

Aug 03, 2008 | 1999 Buick Century

3 Answers

1998 Buick Century Signal Issue


Remove the bulbs one at a time and check for dirt and corrosion at the contacs inside the sockets.The corrosion will cause higher than normal resistence and will make the signal to flash rapidly.As this only happens to the right side only check the right side.

Jun 25, 2008 | 1998 Buick Century

Not finding what you are looking for?

Open Questions:

0 Answers

My 2007 Dodge Ram 1500 4X4 with the 5.7 Hemi engine threw me for a loop yesterday. Stay with me on this as it gets weird. First the engine shut down as did the tach. Then started back up as I coasted down the road (in Mexico of all places). Next it did the same thing again but in addition the cruise would not work and the overdrive didn't work (usually @ 2000 RPM at 60 then the tach showed 2500 RPM. Sure enough by engaging the button on the shifter no change in RPM. Then the engine shuts down, tach inop, OD inop, cruise inop, and the check engine light comes on. Then (it gets better) all of the above happens and I coast to a stop. Shut the ignition off, turned it back on and the cruise works, the overdrive works but the engine shuts down BUT the tach is now working. Long story longer I limp back to Green Valley, AZ with the truck and run the codes and the only code is a P0300 (random cylinder misfires within a predetermined period of time (No S#@t). Also was able to determine the following codes. P0339 (crankshaft position sensor intermittent, P1128 Closed loopfueling not achieved-bank 1 as well as P1129 (the other bank). I'm leaning towards replacing the ECM. Could it possibly be the IPCM (integrated power control module)? OR do I have a loose connection somewhere? It seems the problem gets worse when I go over rough roads (about all of Mexico is ROUGH roads. LOL) Call me "Looking for answers before I pull the rest of my hair out".

May 26, 2018 | Dodge Cars & Trucks

Cars & Trucks Logo

Related Topics:

20 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

79186 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

john h

Level 3 Expert

13735 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...