Question about 2000 Toyota RAV4

1 Answer

The speedo in my 2000 Rav4 doesnt work.

Speedo doesnt work. The speedo drive has a 3-pin connector going to it that has 12v on two wires and the other is a earth. Have tried another speedo drive but still the same. Should both wires have 12v when key on? Have checked both wires for pulsing when driving but they stay at battery voltage.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Toyota Master
  • 14,036 Answers

To test vechicle speed sensor.safely raise front of vechicle.block back wheels besure you are on level ground.get some help to do this.you need a digital volt meter set it on AC SCALE.TURN IGNITION ON DONT START ENGINE.TAKE VOLT METER BACK PROB THE VECHICLE SPEED SENSOR CONNECTOR.TURN YOUR WHEEL WITH ONE HAND YOU SHOULD GET 0.5 VOLTS.AS YOU SPIN WHEEL FASTER YOUR VOLTS ON AC SCALE SHOULD INCREASE.IF IT DOES NOT WORK.IF WIRES ARE OKAY.YOUR VECHICLE SPEED SENSOR BAD OR THE MAGNET GEAR IN TRANSAXLE IS BROKE..

Posted on Jun 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No speedo on Toyota rav4


broken speedo cable or loose connection

Feb 25, 2015 | 2004 Toyota RAV4

2 Answers

1995 vw jetta speedo and trip gage cutting in and out.


From what you say i think you are correct in saying it is a connection problem, Remove the cluster and check wiring to cluster. make sure pins are good, you may need to bend pins to make them tight when you connect the connector to cluster.

Sep 03, 2012 | 1995 Volkswagen Jetta

1 Answer

NX speedo not working


vehicles of this age normally have a speedo drive mounted in the extension housing( back of the gearbox) this will have a plug normally with 3 wires on it, if this connection is not connected and working neither you speedo or trip meter will work. this will also affect your gear change, fuel economy the whole kit and caboodle. earlier cars use a speedo cable and later models use GPS(no visable drive at all)

Nov 25, 2011 | 1991 Nissan NX

1 Answer

Speedo don't work and loses power sometimes


look on the transmission there should be a either a cable or a wired connector either way make sure its plugged in, if that doesnt help try taking out the speedo cluster in the dash and check connections

Mar 08, 2010 | 1991 Honda Accord

1 Answer

No speedo i have a honda civic 1.4 2000


it's missing - or it stopped working?
Check the speed sensor (tach) or VSS wiring and sensor itself for failure.
If you have an aftermarket alarm or remote starter - the installation may be poorly done - and the speed sensor wire cut or disconnected with vibration.

The Tach wire is blue - and found at the coil.
The VSS (vehicle Speed Sensor wire) is blue/white found on the Passenger's Firewall - 3 Pin Connector (top Transaxle for the sensor itself)

Thanks for using FixYa - a Very Helpful Rating is appreciated for answering your FREE question.

Jul 31, 2009 | 2004 Kia Sorento

1 Answer

Speedo stopped working


check wire/wiring connector on right rear section of transfer case.
disconnect wire connector and remove and inspect gear drive for worn teeth including gear inside case.

Jul 29, 2009 | 1992 Isuzu Trooper

1 Answer

Speedo not working corectly


This is an electronic speedo, could be several things but probably 1st and easiest thing to try is repalceing the vehicle speed sensor(vss). Also need to know if check engine light is on, and if any other electrical items are malfunctioning.

May 31, 2009 | 1997 Toyota RAV4

1 Answer

Speedo doesnt work


your speedo run off of a sensor on the tranny

Feb 26, 2009 | 2000 Chrysler Grand Voyager

Not finding what you are looking for?
2000 Toyota RAV4 Logo

469 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8266 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...