Question about 2002 Pontiac Grand Prix

2 Answers

What would cause my transmision to drop to a lower gear between 50 to 62 mph

About 5 months ago I started my car and the speedometer needle pinned all the way to the right. I shut the car off and restarted,every thing was fine. It happened about once a month but I didn't bother with it as I was going to get another car, but plans change. The car is OK in the morning, I can drive about 20 miles before the speedometer needle starts wiggleing and the transmission seems to be searching for the correct gear. I've owned a car that had a slipping transmission, this problem doesn't feel the same, I don't lose speed, just slightly higher engine revs, and a temporary drop to a lower gear. It isn't a constant problem,it will happen and then be normal for 5 or 6 miles.In the morning it happens sooner than 20 miles if I park the car at a store. When the trans problem started I ran a tube to the bottom of the trans pan pumped out some fluid, and added a bottle of lucas treatment [didn't help]. The fluid I pumped out wasn't dark, didn't smell bad and had no particels. A friend who is a hot rodder says I need to put a new trans filter in and a new speed sensor and that will solve the problem. The guy that owns the local transmission shop tells me I need a transmission over haul and that I would be wasting time and money with the new filter and speed sensor.Any ideas on this, thanks

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Pontiac Master
  • 3,679 Answers

Your friends comments are good advice, but first did you check the trans fluid level when you checked the condition etc of the fluid ? as low fluid could cause these symtoms,if the level is ok i'd then get the OBD codes read as this will show what sensor/switch may be faulty ie the speed sensor mentioned by your friend but by doing the OBD you will have a diagnostic result,keep me posted

Posted on May 09, 2014

Testimonial: "The level is fine, what would you expect to pay for a code reading at a shop?. Advance auto parts doesn't do diagnostics on a car of my vintage. It's a 1992 chevy lumina 3.1 4 speed. It's high miles but all county driving, constant speed ,very little stop and go. Thanks"

  • 1 more comment 
  • steve May 09, 2014

    ok the original post had it as a 2002 year vehicle, if the level is ok then i'd be looking et the fuel/air system ,these older vehicle dont have such a comprehensive OBD system so i'd log into a chevvy owners forum as these groups will have a wide range of knowledge on these vehicles, a few quick check you can do is look at the pipe work to and from the air intake/filter box for cracks ,splits etc, also the crankcase breather pipe than goes to the rocker cover may be getting to the blocked stage so give that a flush through with some solvent ,run engine in the dark or a closed garage with a pipe on exhaust out side ,dont want to gas yourself,and look to see if there is any arcing across the plug leads , distributor,coil etc , the chevvy forum would be the best place for more involved advice keep me updated and good luck

  • steve May 09, 2014

    your friend s suggestions are also a valid way to procede as wont cost a lot and could well be the solution

  • kevin kelly
    kevin kelly May 09, 2014

    The mechanic that works on my car did do a cheapy fix on the crankcase breather pipe with a rubber hose and a brass fitting to the air intake on the far side of the air filter. Thanks Steve, clean that out.

×

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Filmmaker:

    Uploaded 5 video answers.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 40 Answers

Sounds like your having a a computer problem... what year make and model

Posted on May 09, 2014

Testimonial: "Rick when I posted this question i thought I changed the make and model . I guess I didn't It's a 1992 chevy lumina 3.1, 4 speed, thanks"

×

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: Trany would slip at high

Replace the ranny oil, dont flush it just drain it throught the trany oil pan and replace the filter and gasket then refill the tranny with type F oil this should stop the slipping

Posted on Oct 23, 2008

emissionwiz
  • 75051 Answers

SOURCE: transmission speedometer problem

This all can be caused by a defective Vehicle Speed sensor, also called a VSS, also run a test on the computer to see if any codes are in memory that will help to sort this problem out.

Posted on Nov 08, 2008

  • 6982 Answers

SOURCE: Engine revving, but car moving slowly until higher gears

Check fluid level and see if it smells burned. If you do not work on it yourself, have a good reliable trans shop check it out. Usually the repair shop you use can recommend which trans shops do good work.

Posted on Apr 14, 2009

emissionwiz
  • 75051 Answers

SOURCE: Transmission problem ?

the very 1st thing to do is have the system tested for trouble codes related to the trans problem, u may have a defective trans shift solenoid.

Posted on May 20, 2009

  • 14036 Answers

SOURCE: car losing power for a few minutes then starts running fine. happens often

replace fuel pump relay.if it still loses power. check fuel pump pressure.if all good scan it check for egr valve going bad.

Posted on May 25, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The speedometer not working right why? and the left front seat want move why how do i fix it what is causing it not to move? i can hear a sound when i press the seat switch.


A few possible issues that may cause your speedometer to not work are a bad speed sensor / gear. Could be an internal gear inside the transmission, not as common of a problem.

What type of sound do you hear when trying to move the driver seat ? Is it a clicking or the motor seat motor running ? This can help determine what may be your problem.

Jul 24, 2017 | Lincoln Cars & Trucks

1 Answer

1986 Alfa Romeo Spyder. WHen stopped, speedometer shows about 12 mph. At highway speed, it shows about 20 mph. Odomater seems fine.


Phylspilot, my 86 Spider never displayed less than 10 mph. If you look closely, you should see a tiny pin that the needle touches at about 10 mph. That prevents it from ever falling to zero. The needle will not move up until the speed exceeds 10. From my experience, that is normal. In your case, not displaying >20 is NOT normal.

The problem could be a few different things. Since the odometer appears to be working ok (I assume you checked that it racks up the miles at a rate commensurate with your approx speed), the speed needle may be sticking. I had the opposite problem with mine - speed needle okay, and odometer messed up.

I recommend pulling the speedometer housing out of the dash and checking to see if anything is causing the needle to bind. If it isn't, then check the fine spring where the needle is attached to ensure the spring is okay. You should be able to move the needle with your finger smoothly and have it return gently to the start position (in your case 12 mph).

This is a tricky operation. If you remove the needle from the stem, carefully place it back on the stem. Do this without moving the stem. Just reinsert the speed needle on the stem exactly at the small pin that holds the pin at about 10 mph.

Check the entire speedometer housing for cracks. Any crack could be enough to prevent proper operation. (That was the source of my odometer issue.)

Have fun putting it all back together.

Mar 20, 2013 | 1986 Alfa Romeo Spider

1 Answer

How to fix a speedometer cable


Well you know it does not have a speedo cable since you replaced the speed sensor in the transmission.
My guess would be a problem with the speedo or cluster.

Jan 09, 2013 | 2004 Oldsmobile Silhouette

1 Answer

2000 hyundai Elantra speedometer making noise and reading wrong


sounds like speedometer cable is gone or the gears between the cable and transmission which makes the reduction for sppedometer if no cable on that year they have a sensor

Nov 28, 2012 | 2000 Hyundai Elantra

3 Answers

Speedometer bounces from current speed down to zero (where it sometimes sticks)


It won't be a cable, as it's impossible for a cable driven speedo to perform this way.
It's an electronic speedo.

Check and/or replace the speedo sensor in the gearbox housing.

Nov 12, 2012 | Hyundai Motor 2003 Elantra

1 Answer

I was driving a couple of days ago and my speedometer pinned past a 120 mph and will not go back to 0 mph i put a new speed sensor in 8 months ago


Hi
It sounds like it has came loose from the back of the clocks / display, quite common.
Hope that helps
Regards
Dan

Nov 08, 2010 | 1991 Honda Accord

1 Answer

Speedometer


look closly at the needle, there is a pin that the spedo needle sits on when the vechile is not moving. it normally sits on the top of it.
look closely and if it is actually under that pin then, this might sound like a joke, you have to reach execsive speeds to get the needle back to normal position. there are 2 ways to do this, long stretch highway or block up the vechicle and floor it. let me know how it turns out i came across this 5 times in the past year

Apr 28, 2009 | 2001 Chrysler Town & Country

1 Answer

1985 4Runner 22RE (injected / auto trans) has NO accelaration.


From minor problem to major problem. Try to replace your spark plug wires, rotor cap and the spark plugs, also it can be the injectors, plus if possible, try to replace the fuel filter which is located low under your EFI unit. If problem not solved, then it will probably be your A/T trans.

Nov 10, 2008 | 1985 Toyota 4Runner

1 Answer

Transmission speedometer problem


This all can be caused by a defective Vehicle Speed sensor, also called a VSS, also run a test on the computer to see if any codes are in memory that will help to sort this problem out.

Nov 08, 2008 | 1994 Pontiac Grand Am

Not finding what you are looking for?
2002 Pontiac Grand Prix Logo

74 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7710 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...