Question about 1990 Plymouth Acclaim

1 Answer

I can't figure out what is left that can be making my car still run hot. It does not run hot as bad as before but still does. I have replaced the water pump, hoses, temperature sensor and switch, thermostat, radiator cap. Does a 1990 plymouth acclaim have a temperature sending unit? I can't find it and when I look on Advance Auto it doesn't even show that one exists for a my car. Please help, frustrated in Florida. Thanks.

Posted by on

  • sherbear316 Jun 22, 2009

    Yea, sorry flushed the radiator, no leaks and fan is working when a/c is on and when a/c is off and the car reaches hot the fan comes on like it should. How about the sending unit?? Do you know if they have one and where it is? Thanks.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 750 Answers

Did you try serviceing the radiator? and cooling fan,does the a/c fan come on when its in use?

Posted on Jun 22, 2009

  • steve noel Jun 23, 2009

    what engine do carry?

  • steve noel Jun 23, 2009

    found sending unit at Autoparts.com (p/n TS176)

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What could be wrong with my 2006 Honda Odyssey. It has no heat, but the engine is running hot. I thought maybe coolant level was low but overflow tank was right at max


Temp gauge runs hot but car makes no heat...... HELP ...

honda-tech.com/honda.../temp-gauge-runs-hot-but-car-makes-no-heat-h...
Mar 28, 2010 - Temp gauge runs hot but car makes no heat. ... Honda-Tech Member ... I figured my theromstat was going bad so I replaced that and it did nothing. ... Any help would be awesome, im losing my patience fast and I have a real big hammer ... This is between the engine and the heater core (under the hood).

Overheating Issue - Honda Odyssey Forum

www.odyclub.com/forums/9-problems.../151854-overheating-issue.html

Nov 13, 2011 - 10 posts - ‎5 authors
I have a 2000 Honda Odyssey with 200K+ on the odometer. ... small head gasket leak,but not enough to see coolant pouring out and no ... 4) Bad thermostat (your new onecould still be bad) - Since your engine is getting hot but you are not getting any heat, ... My coolant was changed at 10yrs/150K miles. Thread: 2007 Odyssey LX - cabin heating issues, no heat ...
7 posts
Nov 19, 2012
Hot air on driver side vents - Cold on passenger side ...
16 posts
May 9, 2012
Thread: Overheat while idle
16 posts
Feb 29, 2012
Thread: No or very low Heat - Wife Is Pissy
16 posts
Dec 13, 2010
More results from www.odyclub.com

Dec 28, 2015 | 2006 Honda Odyssey

1 Answer

MY MECHANIC REPLACED THE RADIATOR ONN 1999 VOYAGER,HE COULD NOT GET FAN TO WORK SO HE HOT WIRED IT TO THE BATTERY,HE GOT A SENSOR BUT CANT FIGURE OUT WHERE IT GOES- HELP!


HACK! the radiator relay is probably bad, located down near radiator left lower corner,bolted to frame,have to get at it from underneath. Be sure fuse #24 (40 amp) is good. A scanner should activate the fan if the relay is good, if not its probably bad, Make sure the fan does not pull more than 20 amps when running, if it does, that could have burned up the relay.

Sep 14, 2011 | 1999 Plymouth Grand Voyager

1 Answer

Heater not heating up... 1993 cellica


Hi there,

You need to figure out what's wrong by process of elimination. Locate the two heater hoses that come off the engine and go into the firewall (the wall behind the engine). These two hoses lead to your heater core (like a miniature radiator behind that wall). With the engine hot, feel the hoses (usually one on top and one beneath, on the left when you are facing the rear of the car) When the engine is hot, and both hoses are hot, that means your heater core is plugged(least likely). If that's the case you need someone to flush out the core, under pressure.

The most likely scenario is that one or both of the hoses are cold to touch. This means the thermostat is not working right and needs to be replaced. A bad thermostat will not open and make your engine run "cold" which will also kill your gas mileage. A good mechanic should be able to replace a thermostat without bankrupting you! This would be the best and easiest problem you could wish for.

Good luck...

Jan 16, 2011 | 1993 Toyota Celica

1 Answer

I have a 95 camaro with the temp gauge problem says its hot when its not and when left running antifreeze comes out overflow tank


Sounds like the temp sensor is bad. Replace the radiator cap make sure to get the correct replacement cap in lbs. Good luck, dont forget to rate.

Jan 10, 2010 | 1995 Chevrolet Camaro

2 Answers

I replaced the top radiator hose, and added coolant it still runs hot and left side air is cold, right side air is hot


Sounds like 2 different issues. Change the thermostat and then check the heater core valve for the left right issue.

Nov 09, 2009 | 2000 Buick Century

2 Answers

Transfer Case Problems


Wow, that could be a host of things. A bad shock, tie rod end, wheel bearing etc.
Back to the tranny..... did you check the fluid level while the motor was running and fluid was hot? That is when most cars are checked. It should say so on the dip stick. you may have done a bad thing and over filled that tranny.

I check mine after I go out to the
market.
Oh, a reminder.... "Quart" as in milk

Sep 19, 2009 | 1999 Jeep Grand Cherokee

3 Answers

I need a wiring diagram on my 1992 toyoata celica gt coupe for the stereo wires. the colors are different and i need to figure out what each is. thank you very much.


92 toyota celica gt - w/o cd player schematic is :

light green = right front tweeter + right front speaker

pink = left front speaker + left front speaker

grey = 15 amp fuse / hot in acc or on posistion

blue/yellow = dome light / hot all times

blue = right front speaker + right front tweeter

violet = left front speaker + left front tweeter

brown = ground

black/red = power antanna
pink/blue = power antanna

red = right rear speaker

black = left rear speaker

white = right rear speaker

yellow = left rear speaker

this was for the WITHOUT cd player , hope thats the model you have , since you didnt specify . repost if you need with the cd player

Dec 24, 2008 | 1992 Toyota Celica

2 Answers

1986 Ford Econoline 350 Temp Guage Problem


The gauge can very well be "lying" to you.

As a precaution, I would do a routine cooling system service on it. This includes completely flushing the coolant, replacing the thermostat and radiator cap (believe it or not, a bad cap can cause issues too).

On the few Fords I have owned, mine were always in the middle, or to the left of the middle.

Motor homes should run cooler actually, beings as they tend to have heavy duty large capacity cooling systems.

Jun 19, 2008 | 1986 Ford Econoline

Not finding what you are looking for?
1990 Plymouth Acclaim Logo

Related Topics:

118 people viewed this question

Ask a Question

Usually answered in minutes!

Top Plymouth Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Plymouth Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...