Question about 1998 Jeep Wrangler

2 Answers

Have 97 Jeep Wrangler with instrument cluster problems...no speedo, tach, temp gauge, oil pressure, odometer..airbag light is on. Took cluster out....terminals look ok. Bent each one slightly with needle nosed pliers....still does not work.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I am having the same issue with my 98. Did you figure it out?

Posted on Apr 25, 2010

  • meanasss9 May 27, 2010

    having same problem with my 97 but cd player dont work also....is it tge wiring???

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

The problem on a Wrangler that I just fixed was a bad AIRBAG CONTROL MODULE. I replaced the module, and everything started working again.

Posted on Oct 13, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My cars gauges just stopped working last weekend.


Could be a fuse. Have somebody who knows about cars look at the instrument cluster fuse to see if the wire inside is broken.

Jun 07, 2016 | 2004 Saturn VUE

1 Answer

All my gauges quit on my 2003 silverado the dash lights still work but none of the gauges move


Hi, this is a pretty common problem on these Silverado instrument clusters. We can definitely help you out with that. Click here to learn more about these Silverado instrument cluster problems: Dr Speedometer Instrument Cluster Repair Speedometer Repair Guage...

Jan 09, 2014 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

Randomly driving- the airbag light comes on followed by the RPM gauge not working. Also the MPG gauge goes dead- but it runs and drives fine?


instrument cluster probly failn--u usually takum out and a shop rebuilds um--when the speedo goes thats the cue

Oct 11, 2013 | 2000 Jeep Wrangler

2 Answers

My 2004 Trailblazer instrument cluster has stopped functioning. The Tach, speedo, oil press, gas, and temp guages spin irregularly and their readings at this point are meaningless. The only things that do...


Hello Mcook389,
If you have above average soldering and de-soldering skills you can perform the repair yourself.
I have repaired many GM instrument clusters and without question this issue is affecting GM instrument cluster all over the country. The particular item that is giving you the bad gauge readings is the stepper motor that drives each gauge.
Please visit my website for complete repair information if you decide to outsource the repair. www.kincerservice.com
Thanks Mike

Jan 25, 2010 | 2004 Chevrolet TrailBlazer

1 Answer

1998 airbag light comes on and off. when light is on the spedometer and rpm dials go to zero when airbag light goes off they work again. This is not a continous problem but does it off and on.


There is a loose connection (or corrosion) where the instrument cluster attaches to the wiring harness mount. Remove the screws (2) from the dash cover below the steering wheel and remove the panel. Remove the defrost vent cover (just lift carefully, it only snaps into place. Remove the screws around the cluster panel cover and remove the cover. Remove the the instrument cluster (it pulls straight out toward you) and make sure the wires are not corroded. Make sure the wiring harness is firmly attached to the metal bracket that holds them in place. Carefully push the instrument cluster back into place. While firmly holding the cluster in place, install and tightnen the screws that hold the cluster. After tightening, wiggle it and make sure it's solid. Start your Jeep and make sure everything works. Shut jeep off and install the rest of the panels in the reverse order of removal. This should fix your problem. What happens is, the cluster becomes loose, speedo quits working (sometimes all other gauges quit also) and gives an airbag code.

Nov 13, 2009 | 1998 Jeep Wrangler

1 Answer

Instrument cluster on 97 Wrangler


IF YOU REMOVE INSTRUMENT CLUSTER AND UNPLUG IT,PLUG IT BACK IN AND UNPLUG IT AGAIN..DO THIS A FEW TIMES..IT SHOULD CLEAN OFF SLIGHT OXIDATION ON CONNECTOR TERMINALS..HAVE SEEN THIS BEFORE..I ALSO THINK REPAIR CONNECTORS AVAILABLE FROM DEALER

Jun 21, 2009 | 1998 Jeep Wrangler

2 Answers

97 Jeep Wrangler Dash Gauges Arent Operating..everything else ok!


ck the engine to body ground.located back side of engine and srew to firewall.

Jun 01, 2009 | 1997 Jeep Wrangler

1 Answer

Instrument cluster damaged after battery shorted out.


4 resistors on the back of cluster bad get them at radio shack.

Dec 14, 2008 | 1998 Buick Regal

Not finding what you are looking for?
1998 Jeep Wrangler Logo

1,595 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

77169 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Kevin Daniels

Level 3 Expert

1455 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...