Question about 1998 Pontiac Bonneville

1 Answer

Engine started dying after serpentine belt replaced. Had mechanic check codes, none showed up. After picking up the car, drove 5 miles, engine died again frequently on way back to machanic. He drove and checked codes again today. Found nothing. Am worried about traveling home (330 miles) tomorrow( Sunday) Any suggestions?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Governor:

    An expert whose answer got voted for 20 times.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 15 Answers

If I remember correctly, the serpentine belt change on this motor can be quite involved. It may require the battery being disconnected to avoid shorting out cables. Check for loose battery cables especially on the negative side where it is secured to the engine block.

Posted on Jun 20, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What makes 2001 Pontiac Montana stall and die while driving, speed doesn't matter?


Amazing.....At this very moment in time.....my 2000 silhouette is doing the same thing....if you were unaware.....ventures Montana's and silhouette are from the same mold. Very similar in all aspects. My diagnostics have got to the fuel pump part of suspects....but I have already checked filter, relays, fuses and ignition electronics....my latest suspect is the pressure sensor that monitors the pressure of the gas tank....there is also a pressure sensor on the injector rail I'm suspicious of. I'm going to find out how to place each sensor in "okay ....fuel pump turn on and pump fuel to the throttle body" to check them. In my case....I don't smell any gas after turning the engine over....trying to start it.....sometimes for over an hour....never any gas smell....so I suspect fuel delivery is the problem. The fuel pump has several sensors that control whether or not it needs to run....and pump gas. I can hear my fuel pump run for 2 or3 seconds when I turn the ignition to the on or start positions.testing all of those sensors is my plan of action for this 3 day weekend. Your on track with your work and suspicion of the position sensors......vacuum leaks will follow the sensor checks. Vacuum leaks could cause a couple of sensors to fail too.....I dropped my fuel tank last weekend....and found the fuel pump to be in working condition.....I removed my fuel filter and punched a hole through it for free flow.....to eliminate it from the list...after checking the vacuum angle....I will move to the electronics side.....with the ignition switch first and the transmission position indicator switch following.....I've plugged my trouble code reader in and didn't get any indication of any failed electronic devices......my problem and your problem seem to be very similar, except that I am doing all of my work on the van myself. I will try to keep you informed of my diagnostics through fix it.it would be nice to know how yours is advancing too.....there are a few directions you can progress into.....hope one solves your problem....if not.....there will be more ideas to come....until I solve my problem....good luck to. Us both and onward we go......Nick.ps couldn't spell or grammar check because I'm using my phone to compose....and the typing pad covers the entirescript being typed. Sorry for any problems. Associated

May 22, 2015 | 2001 Pontiac Montana

2 Answers

2006 BMW F650GS


i would look to see if it is like efi on a car there must be a way to pull codes from the computer on it

Jul 25, 2012 | Cars & Trucks

1 Answer

I had a po102 code, i replaced the map & maf sensors, the engine light went off. I drove the car 25 miles and then the car turned off and a volt light came on the dash. I checked the serpentine belt it...


alternator is probly failing--have it load tested at a shop to confirm--just checkin it at a partsplace isnt sufficiente-------get battery inspected too

May 18, 2012 | 2000 Buick LeSabre

1 Answer

93 Deville, 4.9L, 113k miles. I'm a decent mechanic (have replaced engines, heads, etc.). The latest problem is an intermittent stall. The first time it happened the car was driven for 10 mins then...


Now you can do the Fuel Pump

They seize up mechanically and fail
Electrically

Did you drive with a fuel pressure gauge,
taped to the windshield

Got a good fuel filter

Looking won't help you

Always do some type of testing,
before replacing anything

Dec 15, 2010 | 1993 Cadillac DeVille

1 Answer

Dies after running for awhile


you have vapor lock...try a fuel stabilizer...that should fix it

Jul 09, 2010 | 1997 Jaguar XK8

1 Answer

Car Runs and Loses Power and Quits Running


Try cleaning the fuel pump filter. Under the seat behind the driver lift the carpet and you will find a round cover with six screws remove the cover. The fuel pump is directly below unscrew the retaining round plate and remove the pump. At the base of the pump is a small filter if it is covered in black muck that's your problem. clean and replace. job takes about 10 mins good luck. please let me know how you got on!

shauunswbc@aol.com

Mar 10, 2009 | 2002 Land Rover Freelander

1 Answer

1992 Mercedes Benz, 190E, 2.6 engine died when idle. Won't start.


check your airfilter. your dirt road is killing it much faster than driving it on pavement

Mar 07, 2009 | 1986 Ford Ranger 2WD

2 Answers

Stalls / Dies / dead


this engine fuel pump prassurae low. it fuel pump celan. Your problem sovel

Jul 13, 2008 | 2003 Ford E150

Not finding what you are looking for?
1998 Pontiac Bonneville Logo

168 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8548 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...