Question about Citroen C

1 Answer

C3 1.4HDi 2003 engine fault light comes on during acceleration at 50 in fourth

C3 1.4HDi 2003 engine light comes on during acceleration at about 50 in fourth, then power is reduced presumably by limp home mode. Error codes P0108 and P0237 are generated. Car can be reset by re-starting until next time it is asked to accelerate. Does anyone have any ideas as what might be causing this. Many Thanks

Posted by on

  • Desz
    Desz May 10, 2014

    Thanks for that. Do you have a pinout for the ECM so I can check connectivity. If not there is a lot of wiring loom to open up, to trace it back. Also, do you have a feel of what programming is required to replace the ECM? Presumably the injectors need to be programmed in but what about the immobiliser or is that handled by something else? Thanx

  • Desz
    Desz Nov 16, 2014

    Eventually found the problem. The last owners so called 'mechanic', had reversed the vacuum pipes on the turbo waste gate solenoid, meaning that the gate was closed 99% of the time and the vacuum reservoir was being vented to the atmosphere!

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Citroen Master
  • 42,825 Answers

The MAP sensor has a short to ground problem so I would consider replacing it and checking the wires and connections.

Posted on Apr 23, 2014

Testimonial: "Thanks for that Bill, examined the wiring at the MAP / Boost sensor, and all seems good. Bought a replacement sensor, but the same problem still occurs."

  • Bill Boyd May 10, 2014

    It seems that I may have misled you so sorry about that . Code p0108 refers to manifold absolute pressure(MAP) sensor/Barometric pressure --high input==causeswiring short to positive---MAP sensor---Baro sensor---ECM Code p0237 refers to MAP sensor A TC system--low input===causes ---wiring short to ground---MAP sensor---ECM . Seeing as to you have replaced the MAP sensor that leaves the baro sensor or the ECM and the wiring. Check or recheck the wiring checking for circuit continuity or shorts or a voltage reading where there should be none If you can get your hands on a known serviceable ECM then have it installed to eliminate or prove the ECM as faulty

  • Bill Boyd May 10, 2014

    It will not be necessary to undo the entire harness to check wiring . Find the wire colour on the MAP sensor and it will be the same colour at the ECM plug. Use extended leads on the multimeter to get to both ends of the wire. IF you go to a speed shop that has a dyno they will attach a computer /laptop to the data connection point and the monitor will show all the functions happening from the sensors in the ECM. They will be able to adjust the parameters of each sensor in the CPU program to achieve what you want.. INjectors are just electronically controlled valves and the pluse to activate them is set in the ECM by the program in the CPU. THey should be able to read and repair any problem in the immobiliser program as well. An ECM is only a computer and the CPU program is the operating software installed . IT can be altered by the use of another computer the same as you putting in a software disc to re set your operating system in your computer.

×

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 1024 Answers

SOURCE: car is in

check and see if the traction control light, abs light are on the dash. those things can put your car in a reduction mode, because the computer thinks you are on a skid

Posted on Mar 24, 2010

Testimonial: "thanks dude "

  • 462 Answers

SOURCE: engine power reduced

Locate the IP to body harness connector, which may be located in and around the left hand kick panel area or inside the IP. Check to see if there is a water leak into the area and repair as necessary.

Posted on May 24, 2009

  • 1 Answer

SOURCE: 2001 volvo s60 t5 - performance reduced warning message, limp mode activated

I had exactly the same problem on my UK 2001 S60.
It was caused by the throttle control housing gaskets not being serviced properly and consequently the entire housing had to be replaced - not a cheap job -and a valuable lesson learned - use a reputable volvo specialist to service your volvo - I didn't and I learnt the hard why! only a volvo specilaist would have known about this I went to several other main street garages & none of them could even diagnose the problem let alone fix it. Although they did do numerous other things first before they gave up - ie replaced titanium spark plugs.
Before it stoppped running altogther and went into "limp home mode" there were tell-tale engine/throttle surges when the car was idle, but in gear.
It is now running "like new" & I will never get another garage to service it, as this could have been avoided - however they can also wear out after about 10years - so my bad services just made it happen sooner!
I hope this helps!

Posted on Apr 06, 2009

  • 1 Answer

SOURCE: 2004 Mitsubishi Colt 1.1 Engine management light & code P0122

My girlfriends car has just started with the same problem, a limp home from the garage, a sleep over night and als well next day, for a while... I spoke to Mitsubishi and they have told me the TPS (throttle positioning sensor) is on the accelorator pedle assembly. There PN for this is MN125791 and its circa £88 + VAT. After exhausting all other options I may attempt this replacement and will advise the results.

Posted on Apr 13, 2010

  • 138 Answers

SOURCE: Audi A6 3.0 tdi Quattro 2005, glow plug light comes on, limp mode

16619 -Engine boost condition - Limit not reached. Check intake hoses/ connections for leaks. Check Turbo charger waste gate regulating valve/ waste gate working correctly. Must move freely when accelerating, won't achieve full boost if waste gate sticking open. Check Turbo impeller turning freely, oil feed pipe for turbo can get blocked causing impeller to seize. Engine compact, not easy to access these components.

Posted on Jun 06, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 trailblazer vibrates from speeds 50-70mph no engine codes when I checked it only vibrates during acceleration


engine /gearbox mounts
suspension wear or bushings
out of round tyres or off balance

index-ogsu1mqj3yijjrowlazn2dop-4-0.jpg

Jan 25, 2017 | Cars & Trucks

1 Answer

What would cause your accelerator to stop working?


My 2003 Sorento started but wouldn't accelerate with a fault light in the engine management section, turned out to be water had ingressed from the airbox and trickled down to the accelerator pedal and got into the accentuator. Unplug and remove the throttle pedal, open the accentuator and dry it out with a hair dryer, re assemble. Throttle will work but you'll need to get the fault light reset.

Jul 10, 2014 | 2003 Kia Sorento

1 Answer

Lancer 2003 idles at 4000rmp


run fault codes to find the sensor/ servo that is causing the fault.

Nov 10, 2013 | Mitsubishi Lancer Cars & Trucks

1 Answer

I have got a mercury grand marquis 2003 LS ultimate and having a knocking noise for few seconds when accelerating sometimes specially when the engine is hot and that will reduce the power. any ideas?


When you say the engine is hot are you talking about the normal operating temperature? Has the Check Engine or Service Engine light come? If so, was the On Board Diagnostics system checked for a codes? Usually a knocking sound during acceleration indicates a improper fuel mixture or low octane.

Jan 19, 2013 | 2003 Mercury Grand Marquis

1 Answer

The check engine light continues to come on, changed the fuel filter 3 weeks ago. light came on today flashing and now just stays on. it did this upon acceleration


The check engine light/service engine soon (yellow light) comes only when the computer control unit (called the PCM) senses a fault in the electronic controls of the engine and/or the emission system u will seldom feel the car engine run any different, there are about 200 possible faults that turn the light on, to know what has developed a problem you must have the system tested, this is called an OBD2 fault code test, Kragen and Autozone parts stores do this testing for free.

Sep 30, 2010 | 2003 Ford Crown Victoria

1 Answer

2002 Montero Sport 4X2 jerks during and after shifting into 3rd or fourth gear. Particularly bad going uphill. Not so bad during hard acceleration. Have changed fuel filter, plugs, etc. Even changed center...


Check the 'U' joints in the drive line. Check the engine/transmission mounts for damage or looseness. The real enigma is trying to determine if this is an engine or a chassis problem. If the check engine light is on, doing a scan of the computer should show engine problems. If no light, concentrate on anything in the chassis for periodic binding. Good luck!

Mar 15, 2010 | 2002 Mitsubishi Montero Sport

1 Answer

PT Cruiser (turbo) CK engine light comes on after acceleration


instead of cacelling the engine light , next time take it in and have the fault codes read
all you are doing is cancelling the codes but not fixing the problem

May 19, 2017 | 2006 Chrysler PT Cruiser

1 Answer

Cuts off at 70mph when accelerating.


Best thing to do is go to an Auto Zone and have them scan your truck for any DTC codes. Auto Zone scan free of charge, there is just to many things that can cause the engine issues your running through such as detonation during acceleration due to timing issues to lack of fuel pressure. Good luck and keep me posted, be glad to help you get your truck running 100%

Sep 30, 2009 | 2003 Chevrolet Silverado 1500

1 Answer

Surging during acceleration


If it always, under acceleration, reguardles of what gear you are in, it is must likely, your ignition wires. If it's while coasting, past 45, vehicle in fourth gear, then it would be an isue with your trans. i.e. trans coming in and out of fourth gear or a torck converter clutch problem. Should have codes. If so what are they?

Jan 16, 2009 | 2001 Buick Century

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

297 people viewed this question

Ask a Question

Usually answered in minutes!

Top Citroen Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14363 Answers

Are you a Citroen Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...