Question about 2002 Jeep Liberty

1 Answer

Changed the plugs an fuel pump still as a miss once in awiale

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Night Owl:

    An expert who has answered 10 or more questions between 12 midnight and 6am on the same day.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 130 Answers

Try going to your local Autozone store and ask them to check
your vehicle for emissions and other engine problems.
This is a free service. They will show you a print out of the probable causes of the problem you are having and the cost of the parts you need to fix your vehicle.

Posted on Apr 22, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2006 honda civic EXcheck engine light code miss fire cyl 1 new fuel pump new plugs coil packs running lean need help mike


Change the #1 fuel injector to #2 and #2 to #1 position.If the miss fire code changes to #2 cyl that fuel injector may need to be changed.I would try that first before spending $$$

Apr 20, 2017 | Honda Cars & Trucks

1 Answer

What is causing miss?


runs like it's missing
Have scanned for trouble codes, could be dirt in a fuel injector or a weak/bad coil.

Mar 31, 2016 | 1999 Chevrolet Cavalier

1 Answer

**** miss at an idal once in awial with slite


check for water leak in and around the spark plugs

Jul 05, 2013 | Cars & Trucks

1 Answer

Engine Misses / Surges under load


Sounds like either bad fuel, plugged fuel filter or a bad fuel pump. I would try some fuel additive first unless your fuel filter is easy to change out. A weak fuel pump will eventually quit working so that would be the last thing to check since it involves more labor and replacement costs.

Oct 12, 2012 | 1987 Toyota Cressida

1 Answer

2000 grand am rough idle, sounds like it's missing once it's been running for a bit.


Seems that the engine needs a tuning. check the plugs , remove and check the plugs, replace if they are found to be worn out. Also check the timing, the fuel filter/fuel pump.It is important to check the ignition pulses and the HT to the plugs.

Dec 29, 2011 | Cars & Trucks

1 Answer

1993 deville 4.9 missing at idle and intermittant missing at speed. Has new wiring harness new plugs, new ignition coil etc


CHANGE FUEL FILTER AND CLEAN FUEL INJECTORS,CLOGGED FUEL INJECTORS WILL CAUSE ENGINE TO MISS, MAKE SURE SPARK PLUG GAP IS 0.060, LEAN MISFIRE FROM WEAK FUEL PUMP,CHECK FUEL PRESSURE SHOULD BE 40 - 50 PSI. IF EVEVY THING CHECK OUT OKAY,MISSING PROBLEM COULD BE LOW CYLINDER COMPRESSION OR INTAKE MANIFOLD AIR LEAKS.DO A COMPRESSION TEST IF NECESSARY.

Apr 08, 2011 | 1993 Cadillac DeVille

2 Answers

My 98 century first started missing on steep hills, cutting out then smoothing out once it leveled out. i changed the fuel filter. the gas that came out didnt even smell like gas. plus it was black...


Larry

I assume the fuel issue is now sorted, you have good clean fuel now running through the system and contaminated fuel is not now causing the problem.

I also assume you have checked that the fuel pump is working properly.

If you have had some bad fuel or contaminants in the system I suggest you run the car on at least 2 full tanks of premium fuel before reverting to the usual cheaper regular unleaded. This will also help clean up the injectors.

If you have had problems with moisture in the fuel system do NOT ever use any fuel with an ethanol component. In any event I would never use any fuel containing ethanol in an older model such as yours. Ethanol is not only highly corrosive, but it also absorbs moisture(water) which will then settle in your fuel tank and cause problems once it builds up over a period of time. (This will occur
in any fuel tank). By the way Ethanol will slowly eat away at any plastic parts in the fuel system like plastic components used in some fuel pumps.

When the engine is missing under load as you have described (during hard acceleration or going up hills) it is often due to faulty spark plugs or the plug leads. More often than not one or more of the plug leads will be faulty.

If the spark plugs have not been changed in the past 24 months change them. Otherwise remove them and clean them and reset the gaps.

Renew the plug leads with good quality replacements and retest the vehicle.

Nov 23, 2010 | Buick Century Cars & Trucks

1 Answer

Car is missing in both high and low rpm's changed fuel filter and stopped missing for a while then started up agian. have already swapped spark plugs, distributor & rotor and spark plug wire as well....


It could be that you have picked up a batch of dirty fuel that has clogged the gauze input filter that is part of the fuel pump inside the fuel tank.
You will need to remove the pump assembly from the tank. Access to it is usually through a removable plate in the floor under the back seat. Once you have the pump assembly out allow the gauze filter to dry. You can assess the amount of clogging by shining a torch through the gauze and see how much light comes through. Clean it by brushing with an old tooth brush and blowing clean with compressed air. If there is a lot of dirt/rust in the tank, try draining it. You may have to repeat the cleaning process again in few months if the symptoms appear again.

Aug 20, 2010 | 1997 Nissan 200SX

2 Answers

My 91 ls400 acts like it vaper locks dies out has to sit awial then actes like it has low power for awial then serges to normal what may be the problem?


this is a computer problem. 91-96 lexus ls400 are known for having their computers go out on them. I would have never believed it but my ls400 did the same thing. I sent the computer to Auto Computer Exchange in Davie FL. They reprogramed it for $310 sent it back to me in a day. It fixed the car. I have had no problems out of the car. I now work on ls400 on the side to fix the same problem for other people.

Oct 10, 2009 | 1991 Lexus LS 400

Not finding what you are looking for?
2002 Jeep Liberty Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Kevin Daniels

Level 3 Expert

1455 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...