Question about Cars & Trucks

1 Answer

Not sure why 99 olds alero sputters at 2000 rpm but idles fine

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 15 Answers

Egr may need cleand

Posted on Apr 21, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: 99 OLDS ALERO 2.4 IDLING PROBLEM

intake manifold has a vacum leak or other vacum leak hose etc.

Posted on Dec 03, 2008

MNfisherman
  • 11896 Answers

SOURCE: 99 escort sputters and stalls, engine bogs down in idle

The CAMshaft position sensor is faulty.

Posted on May 06, 2009

  • 881 Answers

SOURCE: 2000 Alero idles low and dies when stopped.

How does it idle when you first start or idle when hot.
On the top of the air intake tube there is a small screw which should when screwed in speed up the idle and if it dosent work or it idles fine when cold or warm at idle then its your GEARs are binding up and there's not to much you can do about that ........sorry

Posted on Oct 16, 2009

  • 5 Answers

SOURCE: i have a 2000 alero that idles rough and smells like old gas

I, too, have a 2000 Alero 2.4L and am having the same problem, but worse. Whenever I brake to a stop while in Drive, the engine stalls sometimes. I thought it was the torque converter going bad. I tried the cheap fixes first when fuel system cleaner and air filter. I took it to a parts store and they pulled the code. "Service Engine Soon" light came on. "Too Rich Bank 1" was on the screen of their code machine. I was thinking fuel filter on my way to the parts store, but wouldn't a clogged fuel filter make it too lean? I have cleaned my air filter and have ran two tank fulls with "Sea Foam" additive. I have had some better low-idle performance, but it hasn't cured the problem. Today I held the throttle down at 1,500 RPM in Park to see if it was running steady, and the engine began to stall! I had to let off the throttle so that it wouldn't stall. That's when the "Service Engine Soon" light came on. About a year ago, I had the fuel injectors professionally cleaned at a shop. Is the throttle actually electro-mechanical? Is there a throttle relay or servo that's going bad?

Posted on Oct 17, 2009

  • 37 Answers

SOURCE: license plate bulb 99 alero

remove the 2 license lamp screws from outside,above the lic.plate then from insidethe trunk pull up the lic.lamp housing and replace the bulb.it should pull straight out

Posted on Dec 07, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Grand prix sputtering


First off, is a check engine lite on,if so do you know the codes?It does have a cam sensor,the cam sensor malfunction gives a code reading,in general fuel probs do not give a code this is done bymanually checking fuel press ect....the module does give specific codes as well...I have seen a cam sensor give the prob. you list, BUT TEST BEFORE YOU BUY,you can get your own codes from the a.l.d.l connector,under dash...take a coated jumper wire and push one end into the g .circuit ,the other into the b terminal and watch the lite flashig in the dash,,ie, 2 flashes...pause then 4 flashes is an example....wilf





1

Apr 05, 2014 | 2004 Pontiac Grand Prix

1 Answer

2002 alero sputters in drive with break on.


the other more than likely has something to do with ABS

Jan 16, 2014 | Oldsmobile Alero Cars & Trucks

1 Answer

99 GMC Sierra 5.3L sputtering and hesitating


Check TPS for smooth and linear electrical response over the entire range of motion. If the response is jumpy or erratic at all, replace TPS.
Thank you for using fixya and good luck.

May 11, 2010 | 2000 GMC New Sierra 1500

1 Answer

2004 Olds Alero with constant high RPM


Try cleaning the throttle body. Possible idle air control valve problem.

Mar 15, 2009 | 2004 Oldsmobile Alero

2 Answers

99 OLDS ALERO 2.4 IDLING PROBLEM


intake manifold has a vacum leak or other vacum leak hose etc.

Dec 03, 2008 | 1999 Oldsmobile Alero

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

29 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...