Question about 1997 Dodge Ram 1500 Club Cab

1 Answer

I was changing the alternator, dropped it, which blew a 50amp fuse. Now Even with the new fuse and alternator, the guage says the battery still isn't charging. The battery is new as well.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Dodge Master
  • 3,904 Answers

You may have shorted out the battery and have to replace. Fully charge your battery and have it tested at a shop.

Posted on Apr 21, 2014

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 29 Answers

SOURCE: charging problem, new alternator, battery. my

maybe a bad ground

Posted on Feb 05, 2010

  • 3640 Answers

SOURCE: Driving down the highway turn lights on battery

first of all, check voltage at battery car off should read at least 12.5 to 13 volts. now start car. at battery it should read at least 14 volts, if lower then 14 volts check alternator.

Posted on Dec 17, 2010

  • 2976 Answers

SOURCE: "I have a new alternator and battery but battery is still not charging up Is there a fuse somewhere that could be blown"

Check your battery cables for a fuze-able link. It is a fuze, built in to one of the cables.

Posted on Dec 15, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Briefly installed battery backwards. 2000 Ford Ranger. New Battery, new alternator, but alternator not charging battery. Truck starts on battery-new starter motor. Lights work, all electrical works


Is this the alternator that was in the vehicle when you hooked the battery up wrong? If so, you probably blew out the voltage regulator in the alternator.

7ee291ce-61c8-4856-a139-5690f9596cea.gif

Jan 11, 2015 | 2000 Ford Ranger SuperCab

1 Answer

I have an 01 kia rio that seems to be having a problem with the battery holding a charge, battery, alternator, and even the starter are all brand new. Everything will run fine for a day or two then I


place an amp meter in the circuit of the battery earth wire and get an idea of what the current draw is so you can have an idea of what piece of equipment is using the power. Radio amps require a big draw where glove box light, boot light, interior light are small draws. If it shows a medium draw the pull the ECM fuse, or IGN fuse or light control module fuse to see if the current draw drops . Even new alternators can be faulty especially if the unit was not wired up correctly and blew a diode. All it takes is a simple touch . have an accredited auto electrician check it out on the bench

Oct 01, 2014 | 2001 Kia Rio

1 Answer

2000 dodge ram check guage light comes on. have a new battery and new alternator. also blew a 50 amp fuse.


Hi Les, I;m glad to help. There is an fusible link that runs off the battery cable pull on it and see if it comes apart, if it does replace it and see if everything is working properly. Hope this helps and have an awesome day Les.

Apr 20, 2014 | 2000 Dodge Ram 1500 Truck

2 Answers

I have a 2009 volkswagon jetta diesel my battery was bad so my son put his truck battery in it and hooked it up backwards now the power steering light is on and no power steering also alternator light is...


Hi, first thing to do and if you know location of the fuse box take light tester and test each fuse may you find some fuses blew. change theme first. if you change the fuses and the the problem for each item you describe still on that mean damage went to the items you say.

Dec 14, 2013 | Cars & Trucks

1 Answer

MY 1991 ACURA INTEGRA 50 AMP FUSE UNDER HOOD KEEPS BLOWING OUT WITHOUT THE KEY BEING ON...... WHERE IS THE SHORT ? WHERE DO I START LOOKING/?


50amp only clue and you dont have the book, the FSM.
nor access to alldata.com?
if you did youd, not be asking right?
my guess is that fuse is in the mains box under hood..
and is a real fuse and not a circuit breaker found elsewhere....????
old car, and can be anything this old.
sounds like fuse #33 in the main box blew. and feeds the white wire main.
USA car? ABS opted? A/C opted. sure.
top cause, shorted alternator, so take off that big wire from alternator
and see if fuse blows now. (do so with battery neg lug removed
the remove alt big wire and tape it all up, so it can touch metal.
then put back battery Neg lug, and last the fuse.

the whtte feed goes vast places and runs whole sections of
the cab fuse boxes and power windows.

if the Alt is good.
then you must start dropping all white wire loads.
if it still blows, the harness is shorted.
I personally just uses a temporary circuit breaker in place of the
50 amp to find the short and an ampclamp DC ammeter.
fast.
login to alldata.com and follow the big white wire.

Sep 17, 2013 | Acura Cars & Trucks

1 Answer

I was changing oil on my 99 escort zx2 and my wrench touched the back of the alternator and blew the main 100 amp fuse. I replaced it and now the temp guage, and fuel guage do not work and the wipers will...


Have you checked the rest of the fuses? Both under the hood and under the dash. It sounds like you may have also blown the wiper switch. The 'gauge' fuse is suspect, make sure you check it as well. FYI, the oil filter in these cars are hand tighten only.

May 19, 2010 | 1999 Ford Escort

1 Answer

My alternator fuse blew when i replaced it my gas and my hot cold


you may have blew the whole cluster but not likely,
check the fuses to all accessories and guages. check your field wire on the altenator and make
sure it is hooked up correctly on the altenator.

Feb 10, 2010 | 1999 Ford Escort

Not finding what you are looking for?
Cars & Trucks Logo

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...